hi
i have banana bpi-r3 with OpenWrt 23.05.5.
i connected nvme m.2 hard drive and installed transmission .
in transmission test the port it appears closed unless i disable obtain ipv6 address in Network>interfaces>wan.
disable obtain ipv6 causes issues with other devices in the network.
thank u for the ideas.
- You mean WAN6?
- Out of curiousicity, did you ever open the IPv4 (and IPv6) test port in the WAN's firewall?
- How are you testing the port closed?
How do you forward port (section from config/firewall)?
hi
i open both ports and i test using transmission test port .
now i tested via online
in online its ok.
Let's take a look at the config to see if we can spot any issues:
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/dhcp
cat /etc/config/firewall
ubus call system board
{
"kernel": "5.15.167",
"hostname": "OpenWrt135",
"system": "ARMv8 Processor rev 4",
"model": "Bananapi BPI-R3",
"board_name": "bananapi,bpi-r3",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.5",
"revision": "r24106-10cc5fcd00",
"target": "mediatek/filogic",
"description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix '::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'sfp2'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.0.135'
option netmask '255.255.255.0'
option ip6assign '60'
list dns '94.140.14.140'
list dns '1.1.1.1'
list dns '94.140.14.141'
config device
option name 'br-wan'
option type 'bridge'
list ports 'eth1'
list ports 'wan'
config device
option name 'eth1'
option macaddr ''
config device
option name 'wan'
option macaddr ''
config interface 'wan'
option device 'br-wan'
option proto 'pppoe'
option username ''
option password ''
option ipv6 'auto'
config interface 'wan6'
option device 'br-wan'
option proto 'dhcpv6'
cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'
option confdir '/tmp/dnsmasq.d'
config dhcp 'lan'
option interface 'lan'
option start '10'
option limit '60'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
option ra_useleasetime '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
cat /etc/config/firewall
config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'transmission 135'
option src 'wan'
option src_dport '57854'
option dest_ip '192.168.0.135'
option dest_port '57854'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'transmission 135 ip6'
option src 'wan'
option src_dport '57854'
option dest_ip 'ip6'
option dest_port '57854'
This rule is referencing the local system (OpenWrt):
Is the OpenWrt router the device that is running Transmission? Or is there a host behind OpenWrt running the service?
hi
the router is running transmission over nvme m.2 connected in bpi-r3
In that case, you should be using a traffic rule, not a port forward.
hi
it worked ok this way over a year no problems - maybe new build.
how to config traffic rule?
thanks
delete the port forwards.
add a rule like this:
config rule
option target 'ACCEPT'
option src 'wan'
option dest_port '57854'
option name 'Allow-transmission'
Also meta skuid transmission accept
hi
thank u it looks ok
hi
i have a second device 134 with port 57844 connected to the first one .
how can i config it in first and in second device.
hi
got it figured out
in first router 135
config rule
option target 'ACCEPT'
option src 'wan'
option dest_port '57844'
option name 'Allow-transmission134'
option dest '*'
config rule
option target 'ACCEPT'
option src 'wan'
option dest_port '57854'
option name 'Allow-transmission135'
in router 134 2nd router should look like
config rule
option target 'ACCEPT'
option src '*'
option dest_port '57844'
option name 'Allow-transmission135'
If you can connect to internet you can tcpdump where connection is expected, next time easier...
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.