Poor WAN performance on BT HH5A <--> G.Fast MT992 Modem

I’m experiencing poor WAN performance intermittently but can’t seem to identify where the issue is. I suspect the issue is with the hardware not being powerful enough or some sort of setting / management setup that is incorrectly configured. I'd really appreciate some help to resolve the WAN speed issues.

Setup / Hardware

  • 150Mpbs TalkTalk UK Connection
  • A BT Home Hub 5a Router flashed with OpenWrt 21.02.1 r16325-88151b8303 / LuCI openwrt-21.02 branch git-21.295.67054-13df80d
  • BT HH5a is setup as DHCP client and connected via a physical cable on the designated WAN ports to an OpenReach G.Fast Modem MT992. The MT992 is connected to the phone line that comes into the property.
    • The OpenReach G.Fast Modem MT992, doesn’t appear to have an IP address on the local network. When I connect a computer directly the modem via a cable, I get a WAN like IP and the router also looks like a WAN like IP.
    • I’ve tried to set the modem up as an interface in LUCI, but there’s no visible GUI interface to access from my local network.
  • My WiFi is provided by a separate BT Whole Home WiFi (3x discs), one of which is connected via a LAN cable to the BT HH5a.
  • Regularly the connection is approx.
    • Ping 359-450ms
    • Download ~40Mbps
    • Up ~1.5-2.5Mbps
    • Occasionally I will get much better numbers but these are a rarity. Approx. 15ms Ping, Down 100Mbps, Up 7Mbps.

Observations / What I’ve tried so far

  • Poor WAN connection speeds are noticeable when there are multiple clients connected to the internet / WiFi.
  • The connection speeds are particularly bad on 2x Windows 10 Laptops and one embedded Linux client. 2 of these are in the same room as the BT HH5a and main WiFi disc. The other client is about 10m away, with a number of walls in between.
    • I’ve noticed sometimes a phone will get a good connection speed test result when one of the Windows computers will show low WAN performance.
  • Poor WAN speed is noticeable most during the day but does happen day and night.
  • Utilising the WiFi network built into the BT HH5a still causes poor WAN performance.
  • Connected my MacBook directly to the OpenReach G.Fast Modem MT992 for a couple of one-off tests got results of about 110Mbps DOWN and 7Mbps UP. And a more reasonable 10-20ms ping.
  • Software flow offloading > Enabled
    • This doesn’t appear to help the speed, either enabled or disabled.
  • I was previously on TalkTalk 60 UK Package and used the built-in BT HH5a DSL modem. I was able to achieve 70-80Mbps DOWN, 18Mbps UP and 10-15ms ping consistently. I was encouraged to upgrade by the provider to G.Fast but so far feels like a step backwards. I was previously using OpenWrt 18.06 when on this previous package.
  • I’ve recently had an OpenReach engineer visit. They’ve tested the line, they can’t see any issue at the socket inside the property. They were getting approx. 120Mbps Down and 9Mbps Up. They said we’re approx. 320m from the cabinet on the street which may be causing some issue but not to the extent I’m seeing on the local network.
$ cat /etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr ''
option netmask ''

config globals 'globals'
option ula_prefix 'fd86:ec5f:9f6f::/48'
option packet_steering '1'

config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option nameprefix 'dsl'

config dsl 'dsl'
option annex 'a'
option tone 'av'
option ds_snr_offset '0'

config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0.1'

config device
option name 'eth0.1'
option macaddr '00:37:b7:38:a6:f2'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option netmask ''
option ip6assign '60'
option ipaddr ''

config device
option name 'eth0.2'
option macaddr '00:37:b7:38:a6:f3'

config interface 'wan'
option proto 'dhcp'
option device 'eth0.2'

config interface 'wan6'
option device '@wan'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 6t'

config interface 'modem'
option proto 'static'
option device '@wan'
option ipaddr ''
option netmask ''


The chipset of the BT HH5A is going to struggle with those speeds, holding the TalkTalk ipoe connection and doing NAT.

It's the bottleneck and you need a better router.

1 Like

Any recommendations for a more suitable router?

Also, when I was using the DSL modem I was able to achieve decent speeds, 80Mbps Down, 18Mbps Up. I presume this was using some sort of different performance / hardware than the ipoe that's now being used with the standalone modem?

fwiw, I posted some iperf results running latest snaphot on HH5a


Have you tried using the TalkTalk router for a few days to rule out issues with the incoming GFast or Talktalk service?

The HH5a at end of the day is too slow when running OpenWrt stable for 100+ mbps services. You need a faster device.

Nevertheless, those awfully slow speeds and 3 figure ping times don't add up. The HH5a is slow, but not that terrible!

Any recommendations for a more suitable router?

Plenty of low cost Mediatek MT7621 (wifi issues aside) routers available. There were even some open box Xiaomi R4A Gigabit for less than £19 last week on ebay from a UK seller (£32 new from Xiaomi UK). I think Archer C6 uses same chipset. The R4AG achieved 320 mbps when I tested client mode wifi the other day in openwrt using iperf3 between two laptops.

1 Like

Thanks Bill!

Yes these speeds are really really bad. I'm running OpenWrt 21.02.1 r16325-88151b8303, the recommended stable build from Tue Oct 26.

I'll see if I can get hold of a Xiaomi R4A Gigabit to try.

Do you know if the Archer C6 suffers from the same wifi issues as the R4AG? If it's the same Mediatek MT7621, I would presume so?

I just realised, is all your own testing done only over wifi ?

ie. what is the actual ethernet performance like through the primary HH5a?

I just did a few tests now both using WiFi and Ethernet directly connected the BT HH5a. All the devices are in the same room within 2m of the BT HH5a hub and master Wifi Disc.

  1. Windows 10 > WiFi: 397ms ping, 15Mbps Down, 1.1Mbps Up.
  2. Macbook > WiFi: 292ms ping, 14Mbps Down, 3.38Mbps Up
  3. Macbook > Ethernet: 286ms ping, 51.5Mbps Down, 1.27 Mbps Up.

What ping times do you get from www.bbc.co.uk ?

Could it be packet loss on Gfast line, or some sort of wired ethernet issue between the MT992 and the HH5a ethernet wan port?

eg. faulty ethernet port on HH5a ?

Do you have a TalkTalk router to connect to the MT992 ?

Try this Windows app for pinging external websites to detect packet loss.

Provided your IP address doesn't change frequently, this may be useful for detecting packet loss too:
(Remember to enable ping on hh5a wan port)

Mikrotik RB750gr3, Xiaomi R4a Gigabit, both have the same chipset and current OpenWRT support.

Your direct tests via ethernet to the MT992 are suggesting the HH5a is the issue

After a lot of fiddling around I’ve managed to find out some more information.

  • A direct LAN connection the G.Fast modem via my macbook gives me good performance stats.
    • Approx. 15ms Ping, Down 108Mbps, Up 8Mbps.
  • G.Fast ←→ TalkTalk Wifi Hub works fine and seemed to provide good connection speeds when tested on my macbook via Ethernet and WiFi.
    • I find the TalkTalk Wifi Hub to be pretty garbage. You can’t set specific IP reservations or easily setup some Port Forwarding rules (I get a generic, unhelpful error when setting up Port Forwarding). Which means that a large number of my devices will need to be changed.
    • So I’ve not been able to leave G.Fast ←→ TalkTalk Wifi Hub connected for more than an hour or so, as I need the rest of my network devices to work with the current IP reseverations and port forwards that are being provided by the OpenWRT router.
    • Is it possible to use the three devices connected in some, allowing the TalkTalk router to do the heavy lifting, but allowing BT HH5a to handle the LAN DHCP, etc? G.Fast <--> TalkTalk WiFi Hub <--> BT HH5a?
  • One of my Windows computer does a constant backup to the cloud and syncs to a Google Drive. These are generally large files, 1-5GB of data a day.
    • This seems to be what’s killing the connection, as soon as I’ve disabled both the backup service and GDrive, the WAN performances speeds return to an acceptable level; 14ms, 60-80Mbps Down, 7.5Mbps Up.
    • When I using TalkTalk 60 / VDSL conneciton via the OpenWRT router, both the backup service and GDrive were both running and never encountered any issues with speed.

I’ve managed to get hold of a Xiaomi R4a Gigabit, which hopefully will arrive today (17/02/2022). I’m hoping I can flash this with OpenWRT and get better WAN performance. I’ll report back.

With the Mikrotik, is OpenWRT much better than the factory RouterOS? I've been reading up on Mikrotik and heard it can be quite difficult to set up using their RouterOS, but wondering if it is more complicated and unsupported than OpenWRT? I find the OpenWRT to be really helpful, supportive and responsive.

Try installing SQM on the HH5a (section 9.13 of my install guide for HH5a has some hints about buffer bloat, but not specific for your GFast situation though) to see if it helps.

But TBH, I'm not sure how Google Drive on Windows manages its data transfer speed. Is there a setting to restrict speed? dunno.

Thanks Bill, based upon the Dropbox HH5a guide you've written, is the G.Fast connection classed as True Ethernet (eg. FTTP) Ethernet, Packet Overhead: 44, MPU: 84?

It looks like Google Drive upload can be rated limited in the app. And the same with the cloud backup. What would you recommend setting these to be? Or is it complete trial and error?

Why is it that my previous VDSL connection never suffered from these issues, even though it's the same hardware and I previously had an 18Mbps Up connection speed?

In short we do not know, but these values likely are okay. I have never looked into the G.fast standards and hence have no idea about the used encoding and overheads (ITU documents are not much fun to read).

1 Like

G.Fast and FTTP are not the same thing? I don't know to TBH

Perhaps use the

  • When in Doubt, it's better to overestimate - Choose overhead 44 (mpu 96)

If you previously had 18Mbps upload speed with VDSL, that may indeed be why you didn't witness any issues.

TBH, 7.5Mbps upload on G.Fast is not great at all if you knowingly upload quite a bit of data.

It is indeed trial & error for setting Google drive upload rate if it needs setting. But you may find by enabling SQM, the issue is less severe than previously witnessed for download related activities?

Thanks Bill! Perhaps that was the case. Frustratingly I was encouraged by the TalkTalk provider to upgrade because it was a free upgrade but wasn't made clear that the upload speed would be sacrificed so dramatically in order to achieve a 20-30Mbps increase in download speed. Feeling like I've gotten a bit of a rough end of the deal now.

I'll test SQM throughout the day and see if there are any performance improvements.

Mikrotik, is an unsupported OS better than the stock OS?
Both are linux based operating systems, RouterOS stock configuration is Eth1 is the WAN port, OpenWRT Eth1 is the WAN Port.
Mikrotik has a steep learning curve, the RB750gr3 or hEX mentioned has the same chipset as the Xiaomi R4A Gigabit, but a couple of extra ethernet ports, twice the RAM, and a USB port and microSD Card slot.
RouterOS7 and OpenWRT are pretty equal in performance at present.

G.Fast is a improved version of VDSL/FTTC.

If you are uploading that much, then the your current upstream speed is a downgrade in the quality of your connection and it may be worth forcing TalkTalk to regrade you to FTTC/VDSL

BT Openreach doesn't allow isps to sell G.fast unless the expected speed is 120Mbps or greater (not sure if that is actual throughput or sync rate), so the line must have been pretty marginal, or may have failed to reach its targets

There's an issue in 21.x release with software flow offloading causing IPv6 packet loss https://openwrt.org/releases/21.02/notes-21.02.1#known_issues


The Xiaomi R4AG arrived today and I've replaced the HH5a with it. So my current setup is G.Fast MT992 ←→ Xiaomi R4AG ←→ BT WiFi discs.

Although there's some improvement, something still isn't right even with this faster router. Here's what I've observed:

  • WiFi or Ethernet to the R4AG via MacBook gets decent speeds.
    • 12ms ping, 105Mbps Down, 8Mbps Up
    • With SQM enabled:
      • 12ms ping, 80-90Mbps Down, 6-7Mbps Up
  • When my Desktop computer is connected via WiFi (I don't have s long enough cable to run an ethernet directly to the router) and running GDrive and cloud backup everything on the network grinds to a halt. High ping latency and slow up and download rates.
    • Ping 300-400ms, 20-40Mbps Down, 0.5-2Mbps Up
  • Enabling SQM helps to keep some of the network usable but the WAN performance is still taking a hit.
    • Ping 100-200ms, 60Mbps Down, 1.5-2Mbps Up
  • As soon as the desktop computer is turned off or the Cloud and GDrive services are turned off, then the network WAN performance improves to expected levels. I have a deficit of about 5gb of unsynced data on my Desktop that needs to sync to GDrive and 2GB to sync to cloud backup. It appears that GDrive is trying to sync 10-20 files at one go, so it could be the number of concurrent connections causing an issue?
  • Adding a rate limit in the GDrive app of 50-200kBps appears to help for a short period of time but soon the WAN performance will drop off a cliff.
  • It appears, once constant and sustained uploading of data is initiated, the network WAN performance takes a massive hit to latency, download bad upload that affects every client.
  • Various articles regarding TalkTalk 150 speeds indicate Download Speed (average): 147Mbps and Upload Speed (average): 29Mbps. My downloads speeds aren’t far off but the upload speed seems to indicate something really isn’t right with this connection.
    • Prior to upgrading from TalkTalk 65 to 150, I have stats daily (Jan-Feb 2022) stats from a SpeedTest that’s run on a schedule on a HomeAssistant instance. Every day I had a solid connection of 10-20ms ping, 75-80Mbps Down and 16-18Mbps Up. The upload speed is on a par with the advertised average speed and download is better than average when I’ve looked at the speeds in noted online.

SQM Settings

$ cat sqm

config queue 'eth1'
	option qdisc 'cake'
	option script 'piece_of_cake.qos'
	option interface 'wan'
	option debug_logging '0'
	option verbosity '5'
	option linklayer 'ethernet'
	option overhead '44'
	option linklayer_advanced '1'
	option tcMTU '2047'
	option tcTSIZE '128'
	option tcMPU '96'
	option linklayer_adaptation_mechanism 'default'
	option download '94500'
	option upload '7110'
	option enabled '0'

Is it possible that I've configured something wrong on the router? I’ve mimicked the same setup that I had with the HH5a but from a fresh install. There are no configuration options I can find for the G.Fast MT992. Could the 320m from the cabinet and a higher than expected SNR (open reach engineer mentioned this when they last visited) be causing the issue?

The only thing I've not been able to test yet is connected the window desktop directly to the G.Fast modem. I'll try and find a long enough LAN cable in the next few days as the two are far away from one another.

Based upon the speed test performed when connected directly to the G.Fast modem, it sounds like I'm not getting to that 120Mbps down margin threshold. Are you indiciating that G.Fast probably isn't going to work in my home given the current Openreach hardware in the street and my distance from it?