Poor streaming with additional AP

That means switching off WMM. Tried that. Made it worse.

The features you can enable in the EAP225 are Load Balance and Airtime Fairness but you don't want me to try that then? :wink:

And VLAN! You can give both 2.4GHz and 5GHz bands their own VLAN ID. That won't do miracles either, will it?

Do you think its signal is too strong for the wireless station? I tried different distances from the AP. Didn't seem to make much of a difference.

Hi,

just a thing to check perhaps ...

Are you certain your EAP225 is in AP mode ?
If not, if it is in router mode. Your client and your sat receiver will not be on the same lan subnet and the EAP225 is doing NAT between the 2 lan segment that can be a big pb for multicast packets.

in that case it is not routing but simple bridging, and that is what you want.
To be sure, do an 'ipconfig' on your client connected on the R6220 (or any other switch) and then again as an EAP client in Wi-fi, you should obtain IPs with on the same scope

my 2 cents

1 Like

Use a wifi analyzer app on your phone and check the signal strength by placing your phone next to the streaming device also do a speed test from same location

1 Like

Thanks for your reply and help.

I used ip addr but the result is the same on both R6220 wired LAN and EAP225 wireless LAN:

    inet 192.168.0.12/24 brd 192.168.0.255 scope global dynamic noprefixroute enp1s0
    inet 192.168.0.10/24 brd 192.168.0.255 scope global dynamic noprefixroute wlp2s4

Bridging, exactly. Thank you for that.

Try 5G along with band steering

Do you have any way to test the EAP with a different network cable ? even if you need to install the EAP for few minutes near the R6220.

Perhaps your cable beetween the EAP and the R6220 is simply bad ?

Edit: you can also perhaps plug a laptop on the EAP's network cable and do an iperf test again, you will be able to compare with your previous test without the EAP, directly with the same wire ?

Edit 2: I made few tests at home:

  1. with my smartphone on the 2.4 band and 20Mhz, iperf3 as client without any option: same as you, 40~50Mb/s
  2. same but with option -P5, I get ~90Mb/s
  3. with my laptop and a better 2x2 (40Mhz channel wide) Wi-Fi card I can get ~180Mb/s with -P5

You can duplicate your iperf3 tests with the -P5 (or 4 or 10 ...) option to have more iperf streams in parallel to better check your 2.4Ghz bandwidth

Does your client (laptop) is able to use 5Ghz band ?
Others asked you to try on that band
with the r6220 as an AP, wich band did you use ?

1 Like

I would try with every weird setting switched off.

It's not connected at all with your problem. If they were in different vlans, there would be no communication at all.

Last but not least, it seems to me that the problem is getting out of OpenWrt scope, as the EAP we are troubleshooting is running on stock firmware and the R6220, which runs OpenWrt, didn't have any issues with the streaming.

1 Like

I agree. It may be due to the cable between EAP225 and R6220.

Let me explain. With CAT5 cable the link was only 100Mbps. So I bought a CAT6 cable and... violΓ‘: 1000Mbps!

But... This is the long stretch (5m or so) between the PoE adapter and the EAP225. There is still a patching cable of 10 or 20 cm between R6220 and PoE adapter. This patching cable may not even be CAT5 now.

I thought it wouldn't matter because it is so short but all data runs through it so maybe there is crosstalk or something.

I'm going to try and replace it, with CAT6 if necessary.

I'll let you know.

I did flash openwrt onto the EAP225. I wasn't going to but got desperate so took the risk. To my surprise there was no LuCI, but I got it working anyway.

Most importantly, the video streaming issue is still there :cry:.

I may need a hand to get the stock firmware back in, if I've got to return the device finally. I made a backup of the stock firmware following the guide for EAP-225 Outdoor but I've never flashed from the CLI, which is the only option now LuCI isn't there.

Is it impossible to install LuCI from CLI?

You have installed a snapshot image. Read the link for instructions how to install Luci, which is not installed by default in snapshots.

1 Like

Great! Many thanks for that. The information is all there, but sometimes you can't find it because you don't expect it.

I suppose there is no stable release. It would be listed here otherwise, right?

Yeah, or here.
However there is 21.02-rc3 if you feel brave.

The issue is solved after changing the patching cable between PoE adapter and R6220. It is working flawlessly now with a CAT5E patching cable.

Thank you for insisting it had to be the cable. I didn't think of the patching cable as the CAT6 cable upgraded the link from 100Mbps to 1000Mbps.

This is where the PoE adapter and the cables fit in:

sat -cable- R6220 -20cmCAT5E- PoE -5mCAT6- EAP225 -wireless- client for streaming

I find it difficult to understand that CAT5 didn't cause any problem so far. The stretch from the SAT box and the R6220 is far longer and is CAT5. The EAP225 definitely needs CAT6.

Oh yes, I'm very happy to learn it is solved :+1: :partying_face:

Cables are some (not so) simple mechanical things, and, as for all mechanical things, they can have defects.
Any other Cat5 can probably do the job without any pb.
This particular one has perhaps a shielding default or any other problem, resulting in bad performance.

These are things that happen, you can throw it away with no regrets

Is it that bad?

Anyway, got LuCI working :relieved:

Not as bad as snapshots, but still not as stable as the stable versions.

2 Likes

not really, in 2 or 3 days you will not be able to install other kernel related packages on a snapshot.
You will still be able to do that for a long time with a RC. that's a good thing

Two updates.

I found out that CAT5 cable works in the 5m stretch as well. It doesn't need to be CAT6. You do need to have the connectors crimped correctly,.... which I did not :blush:

I found out that the video to be streamed through wifi showed freezes as it left the SAT receiver already. I may falsely have blamed the wifi for this to happen and consequently the cable between router and AP :blush: :blush:

Sorry for the confusion this may have caused and thank you all for helping me out.

2 Likes

thanks for the update...

yeah... its pretty rare where cat5 wont do fine in residential settings... and even then it is usually when someone didn't bother to use solid core in the walls (long horizontal crossconnect runs)... or from some sort of localized emf...

1 Like