Poor streaming with additional AP

I have openwrt running in a Netgear R6220 router. To improve wifi signal I added a TP-LINK EAP225 wifi AP to the network and mounted it to a central spot.

The signal strength is now much better than with R6220 wifi, also due to its poor location.

The problem is however that streaming video from the wired sat receiver to a wireless device has got worse and freezes every minute or so when it used to be perfect. Changing EAP225 QoS settings just makes it worse.

The EAP225 is connected to a LAN port of the R6220. Do I need to change its switch settings? Would creating an extra VLAN solve this?

Do I understand correctly that the connection is:
sat -cable- R6220 -cable- EAP225 -wireless- client for streaming


Sorry for not explaining clearly.

1 Like

Is the EAP225 running OpenWrt as well? Is it a dumbAP or running router mode?
Are you certain that the client is not scanning and connecting to the wifi of R6220?
Have you measured the throughput from the client either to the internet or to the R6620 with iperf?

1 Like

Also is the access point on a separate as wifi channel

Thanks for your reply and help.

The EAP225 is running the (updated) original firmware. I haven't tried openwrt firmware yet because I'll have to return it if this issue (and maybe others) can't be solved. Do you think that the openwrt firmware would solve this?

I don't see any option to switch its mode. I would say the EAP225 is working as a dumb AP, but it does do routing between wireless and cable, doesn't it?

I disabled the wifi of R6220 completely after installing the EAP225 so that answers your third question.

I did test with iperf3 between the SAT box and a laptop, connected as a wireless station of the EAP225:

[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec  51.4 MBytes  43.1 Mbits/sec    1             sender
[  4]   0.00-10.00  sec  50.4 MBytes  42.3 Mbits/sec                  receiver

More than enough for a DVB-S channel.

I think you will only want to run QoS on the R6220 WAN interface.

Edit: I can't count how many times I've set up QoS on my gateway lan - I know that doesn't work well.

Thanks for your reply and help.

I'm not sure I understand your question. I disabled the wifi of R6220 completely after installing the EAP225. Is that what you mean?

1 Like

If the R6220 and EAP225 are using the same wifi channel they will compete and interfere with each other. But since you have wifi off on the R6220...shouldn't be a problem unless you have a close neighbor using the same channel.

If you are using 2.4GHz WiFi, stick with channels 1, 6 and 11 and check to see what neighbors are using with a wifi scan. From your description, this probably won't fix your problem, but its a good optimization nonetheless that will help a little.

Thanks for your reply and help.

I agree. But then, what can I try to solve this?

40 Mbps is fast enough for streaming...but, if you're streaming fairly close to the EAP225, I'm guessing this is a 2.4 GHz link from the low speed. Have you tried 5GHz?

Also, make sure you try QoS on the R6220 WAN interface.

Sorry - can't be much more help. Only other thing I can think of is to put OpenWrt on the EAP225 so you can be sure its in dumb AP mode, but I understand you don't want to do that yet.

Done that. There are more APs visible with e.g. WiFiAnalyzer but the EAP225 is nearer and produces a much stronger wifi signal. Much stronger than the R6220 when I used its wifi and video streaming was flawless then.

You are right, it is a 2.4 GHz channel. I haven't tried 5 GHz yet. I will try that and different 2.4 GHz channels too.

If this is the first time you've set up QoS on the R6220, could be something up with that too? I'm just guessing blindly at this point of course. But if you have not, start with a DSL Reports speed test on the R6220 (preferably wired to it) with SQM off to get a clean reading of your ISP speed, set the ingress and egress to ~85-90% of what you are getting on the speed report, etc. There's a guide in the OpenWrt wiki that is really quite good, so I won't repeat it, and you may very well have tried all this already.

Here is the link to QoS setup: https://openwrt.org/docs/guide-user/network/traffic-shaping/sqm-details?s[]=sqm

The SAT box is wired to the LAN and the wireless device is connected to the EAP225. Kindly quoting from @trendy:

So do you think QoS on the R6220 matters? That works with WAN, right? This is a LAN only issue.

I was assuming your satellite box was effectively a modem that provides you a wan interface. I got you now - the satellite box is a gateway router too, so it's giving you a lan connection.

Huh. In that case...can you wire the EAP225 direct to the satellite gateway if it has an extra port?

Aside, if you have an option to put the satellite box into bridge mode so it just functions like a modem and gives you a wan interface for your R6220, that would give you a lot more control over your network.

Edit: If the satellite box is your gateway, that's where you'd want to run QoS/SQM if it has it. It may not be cake, but FQ_CODEL is not too shabby either.

Yes, it should be enough. However you can measure it with the help of iptraf.

If it is a dumbAP it should have bridged the wifi with the wired port, which is less stressful for the cpu.
I would also suggest to turn off QoS or any other fancy feature the EAP may offer, like stp, igmp, roaming, etc. Keep it to the bare minimum.

1 Like

It's not even that. It is just a LAN client. It is a linux based SAT receiver with a LAN interface. Nothing more than that.

Well...there you go. now we know how much experience I have with satellite boxes...zero LOL....

Hey, good luck with it. I'm out of ideas, but you sound like you've got more than enough grasp of this networking stuff to get it sorted out.

Eap has high gain antenna

How high above the streaming device is it and how far.

Think of it as a torch that is bright at one spot in the distance where a normal access point is like bulb in a small room