Poor network performance vm OpenWrt on KVM (proxmox)

I installed openwrt and debian vm in proxmox with the same hardware.
Hardisk worked on logical volumes and virtio network.
Passing a 1.2 Gb file with ssh protocol I get the following results:
Debian 45 MB / s
Openwrt 13 MB / s
Maybe Openwrt needs to install some additional kernel module so that virtio works well?
Thanks and best regards.


1 Like

Openwrt is guest of Proxmox. I installed kmod-kvm-intel and kmod-kvm-x86 in guest openwrt but it does not solve the problem.

Loaded the modules.
Make sure they are in use by your network adapter.

1 Like

Just to be clear, you did assign the virtio NIC to the OpenWrt VM, correct?

1 Like

It is strange that openwrt recognizes the virtio network device but does not appear with dmesg

On Debian:

root@debian:/home/amado# dmesg | grep virtio
[    2.217507] virtio_net virtio2 ens18: renamed from eth0

On openwrt:

root@OpenWrt:~# dmesg | grep eth0
[    2.950280] 8021q: adding VLAN 0 to HW filter on device eth0
[    9.822277] 8021q: adding VLAN 0 to HW filter on device eth0

dmesg | grep virtio -> nothing

grep DRIVER /sys/class/net/*/device/uevent

I see.

I use OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.046.40869-30d9bc0)

root@OpenWrt:~# grep DRIVER /sys/class/net/*/device/uevent

In Debian lsmod

virtio_pci             24576  0
virtio_ring            24576  4 virtio_blk,virtio_net,virtio_console,virtio_pci
virtio                 16384  4 virtio_blk,virtio_net,virtio_console,virtio_pci

No output in Openwrt

¿Maybe I have to compile a kernel with virtio support?


I have the same issue. I have trie to compile the drivers, but a I have and error when I load it (This is the first time I compile a driver in linux, may be I make something wrong).

I also tried with kvm_guest image, and it work very-well, but it's an old release and this release doesn't support aesni that I need to.

Does you have find an solution for the drivers probleme ?

Best Regards