Policy Based Routing problems: Strict enforcement not working, and the routing intermittently stops requiring a manual restart

Hi, I recently installed the pbr package on my router in order to send all traffic from a virtual machine that runs sonarr through my VPN. I'm using the wireguard package to connect to the VPN, and have had a few problems with the pbr package.

First of all, the "strict enforcement" option never seemed to work. Often, I would find that the machine would end up connecting through my normal wan interface, i.e. through my ISP, despite "strict enforcement" being enabled. This would be accompanied by a few things like, "Unknown error" messages, and also messages about pbr not being able to resolve the machine name (torrentbox). Well, I created a firewall rule to deny any attempt of that machine to go through the wan interface, and also changed the pbr policy from referring to the machine by domain name, or device name, and instead just by its ipv4 IP address which has a static lease on the DHCP server.

That took care of it ending up connecting through wan, or there being any error message but it now seems like the pbr routing just intermittently stops without any error message indicating why and with the service reporting it's still running. So that machine will be unable to connect to the internet at that point since it will be trying to connect through the wan interface, but the firewall will be blocking it. I will then have to manually restart the pbr service, and it will again properly route it through the wireguard interface.

I changed pbr's logging verbosity to level 2, but will have to wait for the issue to occur again.

In the meantime, here are the results of the other commands suggested by the "how to ask for help" section of pbr's readme:

ubus call system board
{
         "kernel": "5.15.134",
         "hostname": "OpenWrt",
         "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
         "model": "TP-Link Archer A7 v5",
         "board_name": "tplink,archer-a7-v5",
         "rootfs_type": "squashfs",
         "release": {
                 "distribution": "OpenWrt",
                 "version": "23.05.0",
                 "revision": "r23497-6637af95aa",
                 "target": "ath79/generic",
                 "description": "OpenWrt 23.05.0 r23497-6637af95aa"
         }
 }
uci export dhcp
package dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        list rebind_domain 'plex.direct'
        option serversfile '/var/run/adblock-fast/dnsmasq.servers'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option mac '70:85:C2:7C:FB:AC'
        option ip '192.168.1.2'
        option name 'ryzen'
        option dns '1'

config host
        option name 'raspberrypi'
        option dns '1'
        option mac 'DC:A6:32:D7:11:09'
        option ip '192.168.1.3'

config host
        option name 'IPCAM'
        option dns '1'
        option mac '54:C9:DF:E7:FC:B5'
        option ip '192.168.1.4'

config host
        option name 'torrenterbox'
        option dns '1'
        option mac '08:00:27:1C:16:41'
        option ip '192.168.1.5'

config host
        option name 'thinkpad'
        option dns '1'
        option mac '8C:70:5A:CB:18:D0'
        option ip '192.168.1.6'

config domain
        option name 'secret_address_1'
        option ip '192.168.1.2'

config host
        option name 'VizioTV'
        list mac 'A4:8D:3B:16:82:BE'
        option ip 'ignore'

config domain
        option name 'torrentbox'
        option ip '192.168.1.5'
uci export firewall
package firewall

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'SSH'
        option src 'wan'
        option src_dport '22'
        option dest_ip '192.168.1.2'
        option dest_port '22'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'HTTP'
        option src 'wan'
        option src_dport '80'
        option dest_ip '192.168.1.2'
        option dest_port '80'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'HTTPS'
        option src 'wan'
        option src_dport '443'
        option dest_ip '192.168.1.2'
        option dest_port '443'

config rule
        option name 'Restrict IPCam'
        option src 'lan'
        list src_ip '192.168.1.4'
        option dest 'wan'
        option target 'DROP'

config rule
        option name 'Restrict VizioTV'
        option src 'lan'
        list src_mac 'A4:8D:3B:16:82:BE'
        option target 'DROP'

config zone
        option name 'wgzone'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'lan'
        list network 'wg'

config forwarding
        option src 'wgzone'
        option dest 'lan'

config forwarding
        option src 'lan'
        option dest 'wgzone'

config rule
        option name 'Restrict Torrentbox'
        option src 'lan'
        list src_mac '08:00:27:1C:16:41'
        option dest 'wan'
        option target 'DROP'
uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'maybe_secret_idk'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr 'c0:c9:e3:4f:8c:1a'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'
        option disabled '1'
        option reqaddress 'try'
        option reqprefix 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config interface 'wg'
        option proto 'wireguard'
        option private_key 'secret_key_1'
        list dns '10.255.255.2'
        list addresses 'vpn_gateway_ip/32'

config wireguard_wg
        option description 'Imported peer configuration'
        option public_key 'secret_key_2'
        option preshared_key 'secret_key_3'
        list allowed_ips '0.0.0.0/0'
        list allowed_ips '::/0'
        option endpoint_host 'vpn_domain_name'
        option endpoint_port '443'

config wireguard_wg
        option description 'vpn.conf'
        option public_key 'secret_key_4'
        option preshared_key 'secret_key_5'
        list allowed_ips '0.0.0.0/0'
        list allowed_ips '::/0'
        option endpoint_host 'vpn_domain_name'
        option endpoint_port '443'
uci export pbr
package pbr

config pbr 'config'
        option enabled '1'
        option verbosity '2'
        option strict_enforcement '1'
        option resolver_set 'dnsmasq.nftset'
        option ipv6_enabled '0'
        list ignored_interface 'vpnserver'
        list ignored_interface 'wgserver'
        option boot_timeout '30'
        option rule_create_option 'add'
        option procd_reload_delay '1'
        option webui_show_ignore_target '0'
        list webui_supported_protocol 'all'
        list webui_supported_protocol 'tcp'
        list webui_supported_protocol 'udp'
        list webui_supported_protocol 'tcp udp'
        list webui_supported_protocol 'icmp'

config include
        option path '/usr/share/pbr/pbr.user.aws'
        option enabled '0'

config include
        option path '/usr/share/pbr/pbr.user.netflix'
        option enabled '0'

config policy
        option name 'Plex/Emby Local Server'
        option interface 'wan'
        option src_port '8096 8920 32400'
        option enabled '0'

config policy
        option name 'Plex/Emby Remote Servers'
        option interface 'wan'
        option dest_addr 'plex.tv my.plexapp.com emby.media app.emby.media tv.emby.media'
        option enabled '0'

config policy
        option name 'ipchicken test'
        option dest_addr 'ipchicken.com'
        option interface 'wg'

config policy
        option name 'forward torrentbox over wg'
        option src_addr '192.168.1.5'
        option interface 'wg'
/etc/init.d/pbr status
============================================================
pbr - environment
pbr 1.1.1-7 running on OpenWrt 23.05.0. WAN (IPv4): wan/eth0.2/isp_ip.
============================================================
Dnsmasq version 2.90  Copyright (c) 2000-2024 Simon Kelley
Compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack no-ipset nftset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile
============================================================
pbr chains - policies
        chain pbr_forward { # handle 40
        }
        chain pbr_input { # handle 41
        }
        chain pbr_output { # handle 42
        }
        chain pbr_prerouting { # handle 43
                ip daddr @pbr_wg_4_dst_ip_cfg066ff5 goto pbr_mark_0x020000 comment "ipchicken test" # handle 3643
                ip saddr @pbr_wg_4_src_ip_cfg076ff5 goto pbr_mark_0x020000 comment "forward torrentbox over wg" # handle 3645
        }
        chain pbr_postrouting { # handle 44
        }
============================================================
pbr chains - marking
        chain pbr_mark_0x010000 { # handle 3636
                counter packets 0 bytes 0 meta mark set meta mark & 0xff01ffff | 0x00010000 # handle 3637
                return # handle 3638
        }
        chain pbr_mark_0x020000 { # handle 3639
                counter packets 443292 bytes 263613231 meta mark set meta mark & 0xff02ffff | 0x00020000 # handle 3640
                return # handle 3641
        }
============================================================
pbr nft sets
        set pbr_wg_4_dst_ip_cfg066ff5 { # handle 3642
                type ipv4_addr
                flags interval
                counter
                auto-merge
                comment "ipchicken test"
        }
        set pbr_wg_4_src_ip_cfg076ff5 { # handle 3644
                type ipv4_addr
                flags interval
                counter
                auto-merge
                comment "forward torrentbox over wg"
                elements = { 192.168.1.5 counter packets 443292 bytes 263613231 }
        }
============================================================
dnsmasq sets
nftset=/ipchicken.com/4#inet#fw4#pbr_wg_4_dst_ip_cfg066ff5 # ipchicken test
============================================================
IPv4 table 256 route: default via isp_ip dev eth0.2
IPv4 table 256 rule(s):
30000:  from all fwmark 0x10000/0xff0000 lookup pbr_wan
IPv4 table 257 route: default via vpn_gateway_ip dev wg
IPv4 table 257 rule(s):
30001:  from all fwmark 0x20000/0xff0000 lookup pbr_wg
/etc/init.d/pbr reload
Activating traffic killswitch [✓]

Setting up routing for 'wan/eth0.2/isp_ip' [✓]
Setting up routing for 'wg/vpn_gateway_ip' [✓]
Routing 'ipchicken test' via wg [✓]
Routing 'forward torrentbox over wg' via wg [✓]
Deactivating traffic killswitch [✓]
pbr 1.1.1-7 monitoring interfaces: wan wg
pbr 1.1.1-7 (nft) started with gateways:
wan/eth0.2/isp_ip [✓]
wg/vpn_gateway_ip
/etc/init.d/pbr status
============================================================
pbr - environment
pbr 1.1.1-7 running on OpenWrt 23.05.0. WAN (IPv4): wan/eth0.2/isp_ip.
============================================================
Dnsmasq version 2.90  Copyright (c) 2000-2024 Simon Kelley
Compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack no-ipset nftset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile
============================================================
pbr chains - policies
        chain pbr_forward { # handle 40
        }
        chain pbr_input { # handle 41
        }
        chain pbr_output { # handle 42
        }
        chain pbr_prerouting { # handle 43
                ip daddr @pbr_wg_4_dst_ip_cfg066ff5 goto pbr_mark_0x020000 comment "ipchicken test" # handle 3655
                ip saddr @pbr_wg_4_src_ip_cfg076ff5 goto pbr_mark_0x020000 comment "forward torrentbox over wg" # handle 3657
        }
        chain pbr_postrouting { # handle 44
        }
============================================================
pbr chains - marking
        chain pbr_mark_0x010000 { # handle 3648
                counter packets 0 bytes 0 meta mark set meta mark & 0xff01ffff | 0x00010000 # handle 3649
                return # handle 3650
        }
        chain pbr_mark_0x020000 { # handle 3651
                counter packets 1562 bytes 908134 meta mark set meta mark & 0xff02ffff | 0x00020000 # handle 3652
                return # handle 3653
        }
============================================================
pbr nft sets
        set pbr_wg_4_dst_ip_cfg066ff5 { # handle 3654
                type ipv4_addr
                flags interval
                counter
                auto-merge
                comment "ipchicken test"
        }
        set pbr_wg_4_src_ip_cfg076ff5 { # handle 3656
                type ipv4_addr
                flags interval
                counter
                auto-merge
                comment "forward torrentbox over wg"
                elements = { 192.168.1.5 counter packets 1562 bytes 908134 }
        }
============================================================
dnsmasq sets
nftset=/ipchicken.com/4#inet#fw4#pbr_wg_4_dst_ip_cfg066ff5 # ipchicken test
============================================================
IPv4 table 256 route: default via isp_ip dev eth0.2
IPv4 table 256 rule(s):
30000:  from all fwmark 0x10000/0xff0000 lookup pbr_wan
IPv4 table 257 route: default via vpn_gateway_ip dev wg
IPv4 table 257 rule(s):
30001:  from all fwmark 0x20000/0xff0000 lookup pbr_wg

It looks like you have setup a simple WireGuard Client
If so the WG interface is treated as a WAN interface

Firewall:
Please remove list network 'lan'

Please remove:

Network:
You have two peers in your WireGuard config with both allowed IPs 0.0.0.0/0 that cannot work, remove one.

Reboot afterwards and check again.

it is possible that your DNS resolution comes late and that a WG endpoint URL is not resolved in time so using an IP address as endpoint is the safer choice

Okay, I removed the portions you specified, but have not yet tried using IPs for the endpoints as I'm not exactly sure what you mean. I'm guessing you mean in this section...


config wireguard_wg
        option description 'vpn.conf'
        option public_key 'secret_key_4'
        option preshared_key 'secret_key_5'
        list allowed_ips '0.0.0.0/0'
        list allowed_ips '::/0'
        option endpoint_host 'vpn_domain_name'
        option endpoint_port '443'

Using an IP for "option endpoint_host" instead of a hostname? Would I need to use a different option-directive or can I just put the resolved-IP into that option?

In any case, I managed to capture a log file of it happening again, but I can't really spot what's causing it. I have included the full log in case there's some other service that might be the cause of it.

So something happened where the pbr service stopped working between Fri May 10 07:07:15 and when I logged in to restart it this morning at Fri May 10 14:19:00, and the last entry from the pbr service before that was at Fri May 10 07:37:30. So I think whatever happened must be somewhere in here but there's nothing that's obviously the culprit to me...



Fri May 10 07:37:30 2024 user.notice pbr: service monitoring interfaces: wan wg
Fri May 10 07:37:30 2024 user.notice adblock-fast [9259]: service is blocking 195495 domains (with dnsmasq.servers) [✓]
Fri May 10 07:37:36 2024 daemon.info dnsmasq[1]: using nameserver isp_dns1#53
Fri May 10 07:37:36 2024 daemon.info dnsmasq[1]: using nameserver isp_dns2#53
Fri May 10 07:37:36 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 07:37:36 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzznews.ru
Fri May 10 07:37:36 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjyb.top
Fri May 10 07:37:36 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjlo.top
Fri May 10 07:37:36 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy20.top
Fri May 10 07:37:36 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy19.top
Fri May 10 07:37:36 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy18.top
Fri May 10 07:37:36 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy17.top
Fri May 10 07:37:36 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzxmcp.com
Fri May 10 07:37:37 2024 daemon.info dnsmasq[1]: using 195494 more local addresses
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using nameserver isp_dns1#53
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using nameserver isp_dns2#53
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzznews.ru
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjyb.top
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjlo.top
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy20.top
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy19.top
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy18.top
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy17.top
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzxmcp.com
Fri May 10 07:37:44 2024 daemon.info dnsmasq[1]: using 195494 more local addresses
Fri May 10 07:39:12 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 3/0
Fri May 10 07:39:13 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED 8c:70:5a:cb:18:d0
Fri May 10 07:39:13 2024 kern.info kernel: [ 1973.815371] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 07:40:46 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 07:44:29 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED dc:a6:32:d7:11:09
Fri May 10 07:44:29 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 07:44:29 2024 kern.info kernel: [ 2289.948896] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 07:44:29 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: associated (aid 5)
Fri May 10 07:44:29 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED dc:a6:32:d7:11:09 auth_alg=open
Fri May 10 07:44:29 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 WPA: pairwise key handshake completed (RSN)
Fri May 10 07:44:29 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED dc:a6:32:d7:11:09
Fri May 10 07:44:30 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.3 dc:a6:32:d7:11:09
Fri May 10 07:44:30 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.3 dc:a6:32:d7:11:09 raspberrypi
Fri May 10 07:44:40 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 07:46:18 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 07:48:18 2024 daemon.info hostapd: phy0-ap0: STA 14:22:3b:f0:f1:19 IEEE 802.11: authenticated
Fri May 10 07:48:18 2024 daemon.notice hostapd: phy0-ap0: STA-OPMODE-N_SS-CHANGED 14:22:3b:f0:f1:19 2
Fri May 10 07:48:18 2024 daemon.info hostapd: phy0-ap0: STA 14:22:3b:f0:f1:19 IEEE 802.11: associated (aid 3)
Fri May 10 07:48:18 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED 14:22:3b:f0:f1:19 auth_alg=open
Fri May 10 07:48:18 2024 daemon.info hostapd: phy0-ap0: STA 14:22:3b:f0:f1:19 WPA: pairwise key handshake completed (RSN)
Fri May 10 07:48:18 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED 14:22:3b:f0:f1:19
Fri May 10 07:48:18 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.155 14:22:3b:f0:f1:19
Fri May 10 07:48:18 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.155 14:22:3b:f0:f1:19 Pixel-5a
Fri May 10 07:48:19 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 07:49:16 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 4/0
Fri May 10 07:50:54 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 07:55:37 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 07:56:58 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 07:59:21 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 5/0
Fri May 10 07:59:52 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:05:26 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:09:25 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 6/0
Fri May 10 08:10:02 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:19:16 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:19:30 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 7/0
Fri May 10 08:24:30 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:29:34 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 8/0
Fri May 10 08:33:06 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:34:59 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:35:04 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED dc:a6:32:d7:11:09
Fri May 10 08:35:04 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 08:35:04 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: associated (aid 5)
Fri May 10 08:35:04 2024 kern.info kernel: [ 5324.886436] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 08:35:08 2024 kern.info kernel: [ 5328.911709] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 08:35:13 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: deauthenticated due to local deauth request
Fri May 10 08:35:14 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 08:35:14 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: associated (aid 4)
Fri May 10 08:35:18 2024 kern.info kernel: [ 5338.621471] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 08:35:23 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: deauthenticated due to local deauth request
Fri May 10 08:35:23 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 08:35:23 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: associated (aid 4)
Fri May 10 08:35:24 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED dc:a6:32:d7:11:09 auth_alg=open
Fri May 10 08:35:24 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 WPA: pairwise key handshake completed (RSN)
Fri May 10 08:35:24 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED dc:a6:32:d7:11:09
Fri May 10 08:35:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.3 dc:a6:32:d7:11:09
Fri May 10 08:35:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.3 dc:a6:32:d7:11:09 raspberrypi
Fri May 10 08:35:35 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:39:07 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:39:39 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 9/0
Fri May 10 08:44:55 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:49:43 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 10/0
Fri May 10 08:49:59 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:56:58 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:57:18 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 08:59:48 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 11/0
Fri May 10 09:01:31 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED dc:a6:32:d7:11:09
Fri May 10 09:01:31 2024 kern.info kernel: [ 6911.667004] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 09:01:31 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 09:01:31 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: associated (aid 4)
Fri May 10 09:01:32 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED dc:a6:32:d7:11:09 auth_alg=open
Fri May 10 09:01:32 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 WPA: pairwise key handshake completed (RSN)
Fri May 10 09:01:32 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED dc:a6:32:d7:11:09
Fri May 10 09:01:32 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.3 dc:a6:32:d7:11:09
Fri May 10 09:01:32 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.3 dc:a6:32:d7:11:09 raspberrypi
Fri May 10 09:01:36 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.3 dc:a6:32:d7:11:09
Fri May 10 09:01:36 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.3 dc:a6:32:d7:11:09 raspberrypi
Fri May 10 09:01:41 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:01:43 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:05:47 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:09:39 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:09:52 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 12/0
Fri May 10 09:15:22 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:19:57 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 13/0
Fri May 10 09:21:40 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:30:00 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:30:02 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 14/0
Fri May 10 09:34:20 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:40:06 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 15/0
Fri May 10 09:40:08 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:46:54 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:50:11 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 16/0
Fri May 10 09:51:19 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:55:35 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:55:39 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED dc:a6:32:d7:11:09
Fri May 10 09:55:39 2024 kern.info kernel: [10160.319417] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 09:55:39 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 09:55:46 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 09:55:52 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Fri May 10 09:55:52 2024 kern.info kernel: [10172.686884] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 09:55:53 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 09:55:53 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: associated (aid 4)
Fri May 10 09:55:53 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED dc:a6:32:d7:11:09 auth_alg=open
Fri May 10 09:55:53 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 WPA: pairwise key handshake completed (RSN)
Fri May 10 09:55:53 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED dc:a6:32:d7:11:09
Fri May 10 09:55:53 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.3 dc:a6:32:d7:11:09
Fri May 10 09:55:53 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.3 dc:a6:32:d7:11:09 raspberrypi
Fri May 10 09:56:04 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:56:58 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 09:58:56 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.5 08:00:27:1c:16:41
Fri May 10 09:58:56 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.5 08:00:27:1c:16:41 torrenterbox
Fri May 10 09:59:23 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 10:00:16 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 17/0
Fri May 10 10:06:49 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 10:10:20 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 18/0
Fri May 10 10:15:17 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 10:19:55 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 10:20:25 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 19/0
Fri May 10 10:23:33 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 10:30:30 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 20/0
Fri May 10 10:33:11 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 10:40:34 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 21/0
Fri May 10 10:41:42 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 10:49:44 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 10:50:39 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 22/0
Fri May 10 10:54:07 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 10:56:58 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:00:44 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 23/0
Fri May 10 11:02:08 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:09:37 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:10:48 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 24/0
Fri May 10 11:15:29 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED dc:a6:32:d7:11:09
Fri May 10 11:15:29 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 11:15:29 2024 kern.info kernel: [14949.691781] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 11:15:29 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: associated (aid 4)
Fri May 10 11:15:30 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED dc:a6:32:d7:11:09 auth_alg=open
Fri May 10 11:15:30 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 WPA: pairwise key handshake completed (RSN)
Fri May 10 11:15:30 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED dc:a6:32:d7:11:09
Fri May 10 11:15:31 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.3 dc:a6:32:d7:11:09
Fri May 10 11:15:31 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.3 dc:a6:32:d7:11:09 raspberrypi
Fri May 10 11:15:40 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:15:48 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:20:53 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 25/0
Fri May 10 11:23:09 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:30:57 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 26/0
Fri May 10 11:31:31 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:38:05 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:41:02 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 27/0
Fri May 10 11:43:12 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:46:41 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:46:46 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED dc:a6:32:d7:11:09
Fri May 10 11:46:46 2024 kern.info kernel: [16826.485263] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 11:46:46 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 11:46:46 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: associated (aid 4)
Fri May 10 11:46:46 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED dc:a6:32:d7:11:09 auth_alg=open
Fri May 10 11:46:46 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 WPA: pairwise key handshake completed (RSN)
Fri May 10 11:46:46 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED dc:a6:32:d7:11:09
Fri May 10 11:46:46 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.3 dc:a6:32:d7:11:09
Fri May 10 11:46:46 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.3 dc:a6:32:d7:11:09 raspberrypi
Fri May 10 11:46:52 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:46:56 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:51:07 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 28/0
Fri May 10 11:52:39 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:56:58 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 11:59:11 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:01:11 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 29/0
Fri May 10 12:01:38 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.4 54:c9:df:e7:fc:b5
Fri May 10 12:01:38 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.4 54:c9:df:e7:fc:b5 IPCAM
Fri May 10 12:04:16 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:08:32 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:11:16 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 30/0
Fri May 10 12:13:19 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:17:43 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:21:21 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 31/0
Fri May 10 12:27:04 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:31:25 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 32/0
Fri May 10 12:31:35 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:31:53 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:31:58 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED dc:a6:32:d7:11:09
Fri May 10 12:31:58 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 12:31:58 2024 kern.info kernel: [19538.457667] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 12:32:04 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 12:32:04 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: associated (aid 4)
Fri May 10 12:32:05 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED dc:a6:32:d7:11:09 auth_alg=open
Fri May 10 12:32:05 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 WPA: pairwise key handshake completed (RSN)
Fri May 10 12:32:05 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED dc:a6:32:d7:11:09
Fri May 10 12:32:06 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.3 dc:a6:32:d7:11:09
Fri May 10 12:32:06 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.3 dc:a6:32:d7:11:09 raspberrypi
Fri May 10 12:32:16 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:36:47 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:41:30 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 33/0
Fri May 10 12:46:38 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:51:35 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 34/0
Fri May 10 12:55:42 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 12:56:58 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:01:39 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 35/0
Fri May 10 13:05:26 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:07:36 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.112 cc:6d:a0:f3:7d:35
Fri May 10 13:07:36 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.112 cc:6d:a0:f3:7d:35 RokuStreamingStick
Fri May 10 13:07:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.198 dc:a6:32:d7:11:08
Fri May 10 13:07:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.198 dc:a6:32:d7:11:08 raspberrypi
Fri May 10 13:07:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.173 b4:b6:86:9f:70:d5
Fri May 10 13:07:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.173 b4:b6:86:9f:70:d5 HP9F70D5
Fri May 10 13:09:55 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:11:44 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 36/0
Fri May 10 13:19:22 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:21:49 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 37/0
Fri May 10 13:22:11 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED dc:a6:32:d7:11:09
Fri May 10 13:22:11 2024 kern.info kernel: [22552.154954] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 13:22:11 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 13:22:11 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: associated (aid 4)
Fri May 10 13:22:11 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED dc:a6:32:d7:11:09 auth_alg=open
Fri May 10 13:22:11 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 WPA: pairwise key handshake completed (RSN)
Fri May 10 13:22:11 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED dc:a6:32:d7:11:09
Fri May 10 13:22:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.3 dc:a6:32:d7:11:09
Fri May 10 13:22:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.3 dc:a6:32:d7:11:09 raspberrypi
Fri May 10 13:22:22 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:27:32 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:31:54 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 38/0
Fri May 10 13:33:33 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:36:59 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:41:59 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 39/0
Fri May 10 13:43:53 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:47:24 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:48:18 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.155 14:22:3b:f0:f1:19
Fri May 10 13:48:18 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.155 14:22:3b:f0:f1:19 Pixel-5a
Fri May 10 13:52:04 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 40/0
Fri May 10 13:54:19 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:56:58 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 13:59:53 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 14:02:09 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 41/0
Fri May 10 14:05:08 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 14:11:59 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!
Fri May 10 14:12:13 2024 user.warn ddns-scripts[6178]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 42/0
Fri May 10 14:19:00 2024 daemon.err uhttpd[1844]: [info] luci: accepted login on / for root from 192.168.1.155
Fri May 10 14:19:11 2024 daemon.warn odhcpd[1723]: No default route present, overriding ra_lifetime!

There are lots of entries of "No default route present, overriding ra_lifetime!" which started happening after I disabled my IPV6 interface because I was getting constant ifupdates on it and don't need IPV6 anyway, but it also seems to happen whie the routing is functioning correctly so I don't know if that would have anything to do with it. Also, not that it's related, but the ddns script claiming it couldn't work is wrong, because it's been keeping my no-ip domain name updated just fine.

I'm going to start running a script on the machine in question so I can see exactly when it loses connectivity and try to see what might correspond with that time in the system log, but in the mean time I'm wondering if there's a higher level of verbosity that I might want to enable for more information?

That has to do with IPv6
It seems you removed the whole wan6 interface but a lot of other processes are still in place e.g. odhcpd, and your dhcp 'lan' has some IPv6 stuff in it.

I think the way to disable IPv6 is actually disabling the wan6 interface and ipv6 processes, doing something like:

uci set 'network.lan.ipv6=0'
uci set 'network.wan.ipv6=0'
uci -q delete dhcp.lan.dhcpv6
uci -q delete dhcp.lan.ra
uci set network.lan.delegate="0"
uci -q delete network.globals.ula_prefix
/etc/init.d/odhcpd disable
/etc/init.d/odhcpd stop
uci commit

Reboot afterwards

Yes you can just put the resolved IP address instead of the URL for the endpoint, not sure if that is necessary

Okay I ran the commands regarding IPV6 stuff you listed, and changed the endpoint from a host-name, to the resolved-IP of that hostname.

Interestingly, when I changed the endpoint to an IP I lost connectivity on the machine again until I restarted the pbr service. I had my script set to poll ipinfo.io every minute, but I think I need to create a solution that checks connectivity ever second to better find corresponding events in the openwrt syslog, but in the meantime my script shows it could connect at 17:04:24, but then times out at 17:05:25 and then after I restar the pbr service can connect again at 17:07:53

Fri May 10 17:04:01 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Fri May 10 17:04:01 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 10 names
Fri May 10 17:04:01 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Fri May 10 17:05:00 2024 user.notice adblock-fast [1978]: Optimizing combined list [✓]
Fri May 10 17:05:05 2024 user.notice adblock-fast [1978]: Allowing domains [✓]
Fri May 10 17:05:10 2024 user.notice adblock-fast [1978]: Formatting merged file [✓]
Fri May 10 17:05:10 2024 user.notice adblock-fast [1978]: Creating dnsmasq servers file [✓]
Fri May 10 17:05:11 2024 user.notice adblock-fast [1978]: Removing temporary files [✓]
Fri May 10 17:05:11 2024 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: started, version 2.90 cachesize 1000
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: DNS service limited to local subnets
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack no-ipset nftset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Fri May 10 17:05:15 2024 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Fri May 10 17:05:15 2024 daemon.info dnsmasq-dhcp[1]: IPv6 router advertisement enabled
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using nameserver isp_dns2#53
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Fri May 10 17:05:15 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 10 names
Fri May 10 17:05:15 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Fri May 10 17:05:15 2024 user.notice adblock-fast [1978]: Restarting dnsmasq [✓]
Fri May 10 17:05:17 2024 user.notice adblock-fast [1978]: service is blocking 195495 domains (with dnsmasq.servers) [✓]
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzznews.ru
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjyb.top
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjlo.top
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy20.top
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy19.top
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy18.top
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy17.top
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzxmcp.com
Fri May 10 17:05:23 2024 daemon.info dnsmasq[1]: using 195494 more local addresses
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzznews.ru
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjyb.top
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjlo.top
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy20.top
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy19.top
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy18.top
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy17.top
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzxmcp.com
Fri May 10 17:05:30 2024 daemon.info dnsmasq[1]: using 195494 more local addresses
Fri May 10 17:06:20 2024 user.notice pbr: Activating traffic killswitch [✓]
Fri May 10 17:06:21 2024 user.notice pbr: Removing routing for 'wan/eth0.2/isp_gw' [✓]
Fri May 10 17:06:22 2024 user.notice pbr: Removing routing for 'wg/vpn_gw' [✓]
Fri May 10 17:06:22 2024 user.notice pbr: Deactivating traffic killswitch [✓]
Fri May 10 17:06:22 2024 user.notice pbr: service (nft) stopped [✓]
Fri May 10 17:06:23 2024 user.notice pbr: Activating traffic killswitch [✓]
Fri May 10 17:06:25 2024 user.notice pbr: Setting up routing for 'wan/eth0.2/isp_gw' [✓]
Fri May 10 17:06:26 2024 user.notice pbr: Setting up routing for 'wg/vpn_gw' [✓]
Fri May 10 17:06:26 2024 user.notice pbr: Routing 'ipchicken test' via wg [✓]
Fri May 10 17:06:27 2024 user.notice pbr: Routing 'forward torrentbox over wg' via wg [✓]
Fri May 10 17:06:27 2024 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Fri May 10 17:06:31 2024 user.notice pbr: Restarting dnsmasq [✓]
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: started, version 2.90 cachesize 1000
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: DNS service limited to local subnets
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack no-ipset nftset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Fri May 10 17:06:31 2024 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Fri May 10 17:06:31 2024 daemon.info dnsmasq-dhcp[1]: IPv6 router advertisement enabled
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using nameserver isp_dns1#53
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Fri May 10 17:06:31 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 10 names
Fri May 10 17:06:31 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Fri May 10 17:06:31 2024 user.notice pbr: Deactivating traffic killswitch [✓]
Fri May 10 17:06:33 2024 user.notice pbr: service monitoring interfaces: wan wg
Fri May 10 17:06:33 2024 user.notice pbr: service (nft) started with gateways: wan/eth0.2/isp_gw [✓] wg/vpn_gw
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using nameserver isp_dns1#53
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzznews.ru
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjyb.top
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjlo.top
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy20.top
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy19.top
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy18.top
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy17.top
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzxmcp.com
Fri May 10 17:06:39 2024 daemon.info dnsmasq[1]: using 195494 more local addresses
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using nameserver isp_dns1#53
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzznews.ru
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjyb.top
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjlo.top
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy20.top
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy19.top
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy18.top
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy17.top
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzxmcp.com
Fri May 10 17:06:45 2024 daemon.info dnsmasq[1]: using 195494 more local addresses
Fri May 10 17:10:46 2024 user.warn ddns-scripts[6625]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 1/0
Fri May 10 17:10:56 2024 authpriv.info dropbear[10867]: Child connection from 192.168.1.2:41818
Fri May 10 17:11:01 2024 authpriv.notice dropbear[10867]: Password auth succeeded for 'root' from 192.168.1.2:41818
Fri May 10 17:11:51 2024 authpriv.info dropbear[10867]: Exit (root) from <192.168.1.2:41818>: Disconnect received
Fri May 10 17:12:11 2024 authpriv.info dropbear[10898]: Child connection from 192.168.1.2:46312
Fri May 10 17:12:14 2024 authpriv.notice dropbear[10898]: Password auth succeeded for 'root' from 192.168.1.2:46312

Not sure if there's any smoking-gun clue in there or if it's related to why it's losing connectivity randomly, but in the meantime I'm going to change my script to poll for connectivity every second instead of every minute and wait for it to happen again.

Edit:

Okay, well, while I was writing this post, the connectivity dropped again. I then restarted the pbr service and it came back. Here's the log for that...


Fri May 10 17:28:33 2024 daemon.notice netifd: wan (2343): udhcpc: sending renew to server isp_dhcp
Fri May 10 17:28:33 2024 daemon.notice netifd: wan (2343): udhcpc: lease of isp_ip obtained from isp_dhcp, lease time 86400
Fri May 10 17:28:34 2024 user.notice firewall: Reloading firewall due to ifupdate of wan (eth0.2)
Fri May 10 17:28:38 2024 user.notice pbr: Activating traffic killswitch [✓]
Fri May 10 17:28:40 2024 user.notice pbr: Setting up routing for 'wan/eth0.2/isp_gw' [✓]
Fri May 10 17:28:42 2024 user.notice pbr: Setting up routing for 'wg/vpn_gw' [✓]
Fri May 10 17:28:42 2024 user.notice pbr: Routing 'ipchicken test' via wg [✓]
Fri May 10 17:28:43 2024 user.notice pbr: Routing 'forward torrentbox over wg' via wg [✓]
Fri May 10 17:28:43 2024 user.notice pbr: Deactivating traffic killswitch [✓]
Fri May 10 17:28:43 2024 user.notice pbr: service monitoring interfaces: wan wg
Fri May 10 17:28:44 2024 user.notice pbr: Reloading pbr wan interface routing due to ifupdate of wan (eth0.2)
Fri May 10 17:28:46 2024 user.notice adblock-fast [11931]: Restarting adblock-fast 1.1.1-11...
Fri May 10 17:28:47 2024 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Fri May 10 17:28:48 2024 user.notice pbr: Activating traffic killswitch [✓]
Fri May 10 17:28:51 2024 user.notice pbr: Setting up routing for 'wan/eth0.2/isp_gw' [✓]
Fri May 10 17:28:52 2024 user.notice pbr: Setting up routing for 'wg/vpn_gw' [✓]
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: started, version 2.90 cachesize 1000
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: DNS service limited to local subnets
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack no-ipset nftset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Fri May 10 17:28:53 2024 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Fri May 10 17:28:53 2024 daemon.info dnsmasq-dhcp[1]: IPv6 router advertisement enabled
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Fri May 10 17:28:53 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 10 names
Fri May 10 17:28:53 2024 user.notice adblock-fast [11931]: Restarting dnsmasq [✓]
Fri May 10 17:28:53 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Fri May 10 17:28:54 2024 user.notice pbr: Routing 'ipchicken test' via wg [✓]
Fri May 10 17:28:55 2024 user.notice pbr: Routing 'forward torrentbox over wg' via wg [✓]
Fri May 10 17:28:56 2024 user.notice pbr: Deactivating traffic killswitch [✓]
Fri May 10 17:28:56 2024 user.notice adblock-fast [11931]: service is blocking 195495 domains (with dnsmasq.servers) [✓]
Fri May 10 17:28:57 2024 user.notice pbr: service monitoring interfaces: wan wg
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzznews.ru
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjyb.top
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjlo.top
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy20.top
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy19.top
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy18.top
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy17.top
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzxmcp.com
Fri May 10 17:29:04 2024 daemon.info dnsmasq[1]: using 195494 more local addresses
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzznews.ru
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjyb.top
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjlo.top
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy20.top
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy19.top
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy18.top
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy17.top
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzxmcp.com
Fri May 10 17:29:11 2024 daemon.info dnsmasq[1]: using 195494 more local addresses
Fri May 10 17:30:55 2024 user.warn ddns-scripts[6625]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 3/0
Fri May 10 17:40:59 2024 user.warn ddns-scripts[6625]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 4/0
Fri May 10 17:51:04 2024 user.warn ddns-scripts[6625]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 5/0
Fri May 10 17:53:21 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED dc:a6:32:d7:11:09
Fri May 10 17:53:21 2024 kern.info kernel: [ 3335.422043] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Fri May 10 17:53:21 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: authenticated
Fri May 10 17:53:21 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 IEEE 802.11: associated (aid 3)
Fri May 10 17:53:24 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED dc:a6:32:d7:11:09 auth_alg=open
Fri May 10 17:53:24 2024 daemon.info hostapd: phy0-ap0: STA dc:a6:32:d7:11:09 WPA: pairwise key handshake completed (RSN)
Fri May 10 17:53:24 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED dc:a6:32:d7:11:09
Fri May 10 17:53:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.3 dc:a6:32:d7:11:09
Fri May 10 17:53:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.3 dc:a6:32:d7:11:09 raspberrypi
Fri May 10 17:53:29 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.3 dc:a6:32:d7:11:09
Fri May 10 17:53:29 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.3 dc:a6:32:d7:11:09 raspberrypi
Fri May 10 18:01:08 2024 user.warn ddns-scripts[6625]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 6/0
Fri May 10 18:01:41 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.4 54:c9:df:e7:fc:b5
Fri May 10 18:01:41 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.4 54:c9:df:e7:fc:b5 IPCAM
Fri May 10 18:09:11 2024 authpriv.info dropbear[14167]: Child connection from 192.168.1.2:47694
Fri May 10 18:09:15 2024 authpriv.notice dropbear[14167]: Password auth succeeded for 'root' from 192.168.1.2:47694
Fri May 10 18:09:15 2024 authpriv.info dropbear[14167]: Exit (root) from <192.168.1.2:47694>: Disconnect received
Fri May 10 18:11:13 2024 user.warn ddns-scripts[6625]: myddns_ipv4: Updating IP at DDNS provider failed - starting retry 7/0
Fri May 10 18:12:56 2024 daemon.err uhttpd[1788]: [info] luci: accepted login on /admin/status/wireguard for root from 192.168.1.2
Fri May 10 18:13:17 2024 user.notice pbr: Activating traffic killswitch [✓]
Fri May 10 18:13:18 2024 user.notice pbr: Removing routing for 'wan/eth0.2/isp_gw' [✓]
Fri May 10 18:13:19 2024 user.notice pbr: Removing routing for 'wg/vpn_gw' [✓]
Fri May 10 18:13:19 2024 user.notice pbr: Deactivating traffic killswitch [✓]
Fri May 10 18:13:19 2024 user.notice pbr: service (nft) stopped [✓]
Fri May 10 18:13:20 2024 user.notice pbr: Activating traffic killswitch [✓]
Fri May 10 18:13:22 2024 user.notice pbr: Setting up routing for 'wan/eth0.2/isp_gw' [✓]
Fri May 10 18:13:23 2024 user.notice pbr: Setting up routing for 'wg/vpn_gw' [✓]
Fri May 10 18:13:24 2024 user.notice pbr: Routing 'ipchicken test' via wg [✓]
Fri May 10 18:13:24 2024 user.notice pbr: Routing 'forward torrentbox over wg' via wg [✓]
Fri May 10 18:13:25 2024 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Fri May 10 18:13:29 2024 user.notice pbr: Restarting dnsmasq [✓]
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: started, version 2.90 cachesize 1000
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: DNS service limited to local subnets
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack no-ipset nftset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Fri May 10 18:13:29 2024 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Fri May 10 18:13:29 2024 daemon.info dnsmasq-dhcp[1]: IPv6 router advertisement enabled
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Fri May 10 18:13:29 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 10 names
Fri May 10 18:13:29 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Fri May 10 18:13:30 2024 user.notice pbr: Deactivating traffic killswitch [✓]
Fri May 10 18:13:31 2024 user.notice pbr: service monitoring interfaces: wan wg
Fri May 10 18:13:31 2024 user.notice pbr: service (nft) started with gateways: wan/eth0.2/isp_gw [✓] wg/vpn_gw
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzznews.ru
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjyb.top
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjlo.top
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy20.top
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy19.top
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy18.top
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy17.top
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzxmcp.com
Fri May 10 18:13:37 2024 daemon.info dnsmasq[1]: using 195494 more local addresses
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using nameserver isp_dns#53
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using nameserver vpn_dns#53
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzznews.ru
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjyb.top
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzzjvqzkmqjlo.top
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy20.top
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy19.top
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy18.top
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzyy17.top
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using only locally-known addresses for zzxmcp.com
Fri May 10 18:13:43 2024 daemon.info dnsmasq[1]: using 195494 more local addresses
Fri May 10 18:15:03 2024 authpriv.info dropbear[16110]: Child connection from 192.168.1.2:37810
Fri May 10 18:15:08 2024 authpriv.notice dropbear[16110]: Password auth succeeded for 'root' from 192.168.1.2:37810

Looking at this incident and the first one, it seems that it has something to do with these events:


daemon.notice netifd: wan (2403): udhcpc: sending renew to server isp_dhcp_ip
daemon.notice netifd: wan (2403): udhcpc: lease of isp_ip obtained from isp_dhcp_ip, lease time 86400
user.notice firewall: Reloading firewall due to ifupdate of wan (eth0.2)

So it seems as if every time openwrt gets a new IP from my ISP that the pbr service needs to be restarted, but why?

To recreate the routing tables.

The need to restart pbr on firewall restart has been greatly reduced in the more recent pbr builds available in my repo when used with nft_file_mode option set to 1.

PS. Despite you providing many logs, it's not obvious to me why pbr is failing to keep the routing working as intended. If you do figure out a reason, I'll try to fix it.