Plusnet one (BT HH5a) 5Ghz channel + USB SAMBA+DLNA problems

I have a Plusnet hub One running OpenWrt 21.02.2 r16495-bf0c965af0 / LuCI openwrt-21.02 branch git-22.046.85957-59c3392.

Basic functions are running well, but I have a few difficulties. Support is appreciated;

5Ghz WIFI Channel;
The device works when Ch36 is selected. Unfortunately ch36 is congested in my area. Selecting other channels doesn't work.:

 Qualcomm Atheros QCA9880 802.11nac
 Channel: 36 (5.180 GHz) | Bitrate: 412.4 Mbit/s
 SSID: XYZ | Mode: Master
 BSSID: XYZ | Encryption: mixed WPA/WPA2 PSK (CCMP)

 Qualcomm Atheros QCA9880 802.11nac
 Device is not active
 SSID: XYZ | Mode: Master
 Wireless is not associated

Reverting to ch36 resolves the problem.

The device has a USB port that I want to use as storage for a DLNA server, and put files there e.g. using SAMBA.
The USB storage is formatted as NTFS & is mounted and recognised by the device & I can browse the files via SSH.
I'm unable to get the DLNA server & SAMBA to access the USB storage. See attached screenshots.

Even though SAMBA should give guest access, I'm prompted for user/pass.

Thanks for your assistance!!

  • What does this mean?
  • Do you get an error on the web GUI?
  • Did you pick a DFS channel?
    • If so, did you wait for it to scan and come up?

Well, Channel 36 is a non-DFS, so this sounds like DFS might be the issue.


Since using 21.x snapshots 5ghz apparently shuts down and doesn't retry if it thinks it has detected a radar on DFS channels. I've got three in a mesh, and quite often one will go down, I think it might even be mistaking the other/s for radar.

Adding "option channels" to the 5ghz wifi-device in /etc/config/wireless, with a list of channels to switch to will cause it to switch channels to another, instead of staying down.


config wifi-device 'radio0'

        option channels '36-173'

Also in the UK, channels 149, 153, 157, 161 and 165 are no longer DFS channels, but that may not have been updated in the version you have. "iw list" will show which channels have radar detection.

Thanks for the replies so far. It seems stable on ch40 which I believe is a non-DFS channel, but if I use ch64 (DFS) then the interface shows; Device is not active / wireless is not associated.

Unfortunately, I don't think the browser UI currently provides a way to set which channels auto channel selection mode uses, you need to ssh into the router to add option channels.

Without it set if your chosen channel is not available due to a radar detected, auto mode kicks in and doesn't have any channels to switch to, hence the device becomes not active. option channels '36-173' would allow it to select any available channel, although it would probably be better to be more selective.


channels list no (regulatory domain specific) Use specific channels, when channel is in “auto” mode. This option allows hostapd to select one of the provided channels when a channel should be automatically selected. Channels can be provided as range using hyphen ('-') or individual channels can be specified by space (' ') separated values.

You may also want to untick "Disassociate On Low Acknowledgement" if enabled in the wireless devices advanced settings tab.

Thanks very much for all the help with the Wireless configuration.

I'm still unable to share the USB storage via samba / dlna.

The samba server is running and accessable to guests (confirmed by sharing an onboard directory). But the USB share isn't accessable via samba even though it's available via ssh. (see screenshots).

How long did you wait? For DFS channels the router IIRC needs to do a certain period (1 minute?) of passive channel scanning before transmitting anything, so a DFS channel might appear non-functional for some time, before it actually starts operating (as long as it does not think it detecs radar signatures on the channel).

Hi again,
Setting the country code to GB rather than driver default seems to work well. Thanks for your help with this.

Still unable to get samba / Dlna server up and running though. Any support/ comments appreciated on that topic too. Thanks.