Plusnet hub one setup

I am going to try my old plusnet hub one to se if it can gain higher speeds even if its just used as an STA or AP

I have soldered serial communication and a lose wire to short to ground for UART boot, but can not work out have to load the bootcode from windows

should I be able to type commands as I currently can not

I worked it out using linux but I have a usb as the ground of the serial
I need a usb stick for the firmware
if I use a usb hub it reset to UART mode startup

I take it nobody likes me anymore,
I honestly didn’t realise I created similar threads 14 times, and I am sorry for that
anyway I will solve this issue by adding a ground wire.

Could I just wrap a cable around the 12 volt barrel connector, if negative is on the outside and positive on the inside, like they normally are

https://openwrt.org/toh/bt/homehub_v5a has all the information you need.

I know, thats what I was having issues with, there are no instructions for windows that I could find so had to use linux for the bootcode

anyway solution for my original issues is use linux

I shouldn't need any more assistance now
I know what needs doing and how to do it

just hope when I add that ground cable, I don't rip the solder pad from the board like I did with the TX, good job the resistor is linked to it

I run the prepare command and erase the stock firmware after backing it up

I can not flash openwrt or restore to stock

With error command not found when flashing openwrt

Edit:
at the minute basically its bricked
it won't boot stock and won't boot openwrt
but it should be on the flash

I feel like nobody cares to help me here now
why does nobody like me here now

I just want wireless at the front of the house

It's not that "nobody likes you". It's that you keep saying "I did this and it didn't work".

You have to provide detail. The exact commands, the output, and how that differed to what you expected.

Remember that this is a community forum. Nobody gets paid for helping anyone, and if people try but just keep getting THAT DIDN'T WORK WHY DO YOU HATE ME back then... They're not going to try to help you again. It's not personal.

1 Like

like I said I booted the u-boot ramdisk over serial

cat lede-lantiq-bthomehubv5a_ram-u-boot.asc > /dev/ttyUSB0

tftp the lede install image

tftpboot 0x81000000 lede-lantiq-xrx200-BTHOMEHUBV5A-installimage.bin; bootm 0x81000000

when loaded I backed up the plusnet firmware and ran the prepare command
then proceded to run sysupgrade which failed

sysupgrade -n -f /tmp/openwrt-22.03.5-lantiq-xrx200-bt_homehub-v5a-squashfs-sysupgrade.bin

failed with error command not found, so I reboot, it will not boot anything, the custom u-boot just says no boot device and give a shell

did it all again, run restore to try and get the plusnet firmware back

restore /tmp/hh5a.nanddump

the was successful but with an error about something(can't remember the details here, but it said sysupgrade successful or was that one of my openwrt flash attempts)

anyway now I just get the plusnet bootloader saysing starting booting
and red led

I have tried different things a few times

nothing happens no output to serial nothing just the red led
this is as much detail as I can remember, Sorry I should have put all this in the first place

well from my last thread where @LilRedDog made a deal that I never talk about throughput ever again, I though that was why nobody was answering me

I get told 1000 times, I know, but I still have no patience

1 Like

When you're ready to reply - be sure to provide details. It may also help to use full sentences and punctuation (e.g. if asking a question - using a question mark).

Using bootloaders and flashing via serial is one of those tasks where exact details are necessary.

  • Different things?
  • A few times?
  • Do you still get the output in Serial Step No. 3?
ROM VER: 1.1.4
CFG 04
UART

These are very important questions to answer - using as must verbosity and detail as you can.

3 Likes

I did provide details now
Full sentences and punctuation, is not really something I use, except commas
In my case a new paragraph is normally a new sentence

I did try the migrate command but got nothing from it, so issue with no boot device
But I did run prepare that time so maybe that went wrong, I can’t remember exact details without doing it again, I will not be doing this again for a while, the setup is crazy
Raspberry pi for serial console as putty in windows was useless and can not transfer the boot code
Windows laptop running tiny pxe server, as I could not get it working on Linux
My windows laptop also keeps making everything go to not responding

Yes, maybe more like 5 times

Yes, I can do everything, except get a successful flash it seems

What would command not found be referring to
I could work that out

Thats probably why nobody responded. It took me a few times reading to understand you still wanted assistance after saying you didn't. IJS - no big deal.

Do everything?

Are you willing to provide more details here?

Can you show it, please?

This is why I asked about the Step 3 - but we still need clarity.

Maybe screenshots or pasting the serial output?

It's not clear - are you asking for help setting up Windows TFTP?

To be clear, you created this thread after you already successfully entered bootloader commands and booted the device - then you experienced an issue on the sysupgrade step, correct?

Lastly, I'm wondering if you possibly experienced the hardware damage described in the Wiki. Did you disconnect the serial cable at the time described in the Wiki?

To be clear, need to know if you did this or something else?

What serial adapter did you use?

I assume you tried to ground your serial connector using -12V?

I fixed my first problem(not being able to send u-boot boot code over serial) but ran into another problem(the flashing)

I can do everything within lede even write to the nand but can not flash the firmware without an error

I will send screenshots at some point

no, just I was having issues were tiny PXE server would say "the system can not find the file specified", turns out my windows installation was corrupt

that was before I got into the bootloader, the plusnet version of u-boot or whatever it is does not allow you to enter anything

that part is correct yes

I did notice that, but doesn't that say I would be stuck at CFG 04
UART
I disconnect boot_sel2 as soon as there is a output on the serial

all the ground connections should be linked together, so I just wrapped a wire around the 12V barrel connection, seems to work fine

USB to TTL Serial Cable for Raspberry Pi | The Pi Hut
I never connect the 5V power anywhere

I am grounding the serial connection with the 12V input ground, as I said they should all be linked

Since your sentence doesn't have punctuation, I'm not sure what you mean.

I hope I'm identifying where we seem to be having confusion. What command(s) are you typing at this exact moment and where?

Thanks, perhaps they'll provide clarification. We await your screenshots.

I did notice that, but doesn't that say I would be stuck at

CFG 04
UART

I disconnect boot_sel2 as soon as there is a output on the serial

I do get the output in step 3, yes
how can I do verbosity
I get exactly what you say

ROM VER: 1.1.4
CFG 04
UART

when running sysupgrade in lede with the openwrt image at the end I get command on found or straight from the ISB flash drive I get nand flash failed

I will get you them screenshots

Combined with your comments about would you be stuck on a serial output and this - I assume this means you can still boot the device via serial/TFTP. It's still not clear.

If so, try flashing version 18 (or whatever stable version was available for the device at that time - e.g. version 19). Then try version 23.

yes its just sysupgrade that failed, leaving no OS installed

1 Like

And what occurs when flashing the stable version when the Wiki was written?

Yea, screenshots - this part is confusing and seems like a syntax error maybe.