Plex Media Server for OpenWrt

It has other nice features like accesing your media being away from home (via browser or dedicated app) vs kodi (btw using both at home)

1 Like

Yes, but for example I have the Film catalog in the cloud, so I can always access my content wherever I am and not just from Kodi. :grin:

Hello, for some reason that I still don't understand, installing Plex Media Server in an extroot configuration now works.

I can confirm that the Plex Media Server installation does work in an extroot configuration, for which I followed the extroot configuration guide found here.

For the installation itself, I followed the OLD VERSION - INSTALL INSTRUCTIONS.

I don't know if I could have done it with just the init.d script. (please confirm me if this is possible).

I also confirm that the operation with Rclone is very good, as long as it is configured with the vfs-cache-mode full parameter which means there are no buffer problems when playing a movie.

The only weird thing I've noticed is that Plex time is UTC, so the Scheduled Tasks don't start at local time (-5 GMT), so I have to schedule the tasks at 5:00 am to run at the midnight. I haven't seen any option in settings to allow Plex to use local time (-5 GMT).

Good to hear that extroot is working! Did you by chance use the newest version of the init.d script? About a week ago I updated it to be (hopefully) less stubborn about accepting non-standard configurations...I was hoping this would fix extroot.

The only weird thing I've noticed is that Plex time is UTC, so the Scheduled Tasks don't start at local time (-5 GMT)Z

On my plex it is showing my correct local time.

Any chance your openwrt system time is set to UTC (which is the default)?

If so, you can change it through LUCI (system --> system --> timezone). For example, for USA eastern time zone (with standard daylight savings) youd want the "America/New York" time zone. Im guessing you want either this one or central time, which is "America/Chicago" (for standard daylight savings). There are a few more options for those handful of places that have decided to do daylight savings time differently.

If you dont have luci, you can set it manually via UCI. For eastern time this is

uci set system.@system[0].zonename='America/New York'
uci set system.@system[0].timezone='EST5EDT,M3.2.0,M11.1.0'
uci commit system

You'll have to look up the time zone code though if you need central time though.

That's right, I'm using the latest version of the init.d script

This is not the case, I have the local time correctly set in openwrt.

root@OpenWrt:~# uci export system
package system

config system
        option hostname 'OpenWrt'
        option zonename 'America/Bogota'
        option timezone '<-05>5'
        option ttylogin '0'
        option log_size '128'
        option urandom_seed '0'
        option description 'Dynalink DL-WRX36'
        option notes ''
        option conloglevel '7'
        option cronloglevel '9'
        option log_proto 'udp'

Have you verified that the tasks scheduled by PMS really start at local time?

Because one thing is the time that appears in the alerts section...

...and another thing is the time that appears in the console.

Ill have to pay attention and check tonight after the nightly schedules task starts, but I manually started a library scan and stuff from that is showing the correct time in the console.

It wouldnt surprise me is plex just doesnt like the <-05>5 timezone code. Looking online, COT5 appears to be the timezone code for America/Bogota...perhaps try changing it to COT5 and see if it works?

uci set system.@system[0].timezone='COT5'
uci commit system
reboot

I applied the change and restarted OpenWrt, but Plex refuses to take the change, still showing UTC time in the console.

It's like there's a missing variable that explicitly tells Plex to use local time.