Please provide OpenWrt 21.02.0-rc1 /etc/config/uhttpd

i think there is a refactor in v21 uhttd, but after i revert my configs it is using the old configs. could anyone give me the latest uhttpd config on v21?

thanks

config uhttpd 'main'
        list listen_http '0.0.0.0:88'
        list listen_http '[::]:88'
        list listen_https '0.0.0.0:8443'
        list listen_https '[::]:8443'
        option redirect_https '1'
        option home '/www'
        option rfc1918_filter '1'
        option max_requests '3'
        option max_connections '100'
        option cert '/SECURE/fullchain.cer'
        option key '/SECURE/domain.com.key'
        option cgi_prefix '/cgi-bin'
        option lua_prefix '/luci'
        option lua_handler '/usr/lib/lua/luci/sgi/uhttpd.lua'
        option script_timeout '60'
        option network_timeout '30'
        option http_keepalive '20'
        option tcp_keepalive '1'
        option ubus_prefix '/ubus'

config cert 'defaults'
        option days '730'
        option bits '2048'
        option country 'ZZ'
        option state 'Somewhere'
        option location 'Unknown'
        option commonname 'OpenWrt'

i think probably the lua_handler changed, not sure.

config uhttpd 'main'
	list listen_http '0.0.0.0:80'
	list listen_http '[::]:80'
	list listen_https '0.0.0.0:443'
	list listen_https '[::]:443'
	option redirect_https '0'
	option home '/www'
	option rfc1918_filter '1'
	option max_requests '3'
	option max_connections '100'
	option cert '/etc/uhttpd.crt'
	option key '/etc/uhttpd.key'
	option cgi_prefix '/cgi-bin'
	list lua_prefix '/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua'
	option script_timeout '60'
	option network_timeout '30'
	option http_keepalive '20'
	option tcp_keepalive '1'
	option ubus_prefix '/ubus'

config cert 'defaults'
	option days '730'
	option key_type 'ec'
	option bits '2048'
	option ec_curve 'P-256'
	option country 'ZZ'
	option state 'Somewhere'
	option location 'Unknown'
	option commonname 'OpenWrt'

https://github.com/openwrt/openwrt/blob/openwrt-21.02/package/network/services/uhttpd/files/uhttpd.config

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.