Please help wrong firmware update

first I'm not a router programming expert, but a beginner
I installed the firmware version of the OpenWRT for my device WL-WN570HA1 (AC600), after the installation I took a copy of the mtd 6 files and I decided to go back to my device orginal firmware version but I uploaded another file on my device from WL-WN572HP3 (AC1200)
the problem is that The device lights up but nothing is working
I tried to install the correct orginal firmware or OpenWRT firmware not work
can anyone please help me to fix this problem from mtd files
here is my file mtd

Thanks in advance

Hello, welcome to this community.

You can try tftp upload method to recover it. According to the guide here

Factory U-boot launches a TFTP client if reset button is pressed during power-on.

Rename the `…sysupgrade.bin` file to `firmware.bin` and configure TFTP as follows:

* Client (WL-WN570HA1) IP:

* Server IP:

* Filename: `firmware.bin`

If nothing works, then you'll have to use jtag or programmer to recover it.

1 Like

Sorry not works :frowning:
is the jtag easy ?

No, jtag is really not easy.

Before jumping to that though you should see if the device is accessible via the onboard serial port. Disassemble it, look for a serial header or pins and connect a usb to ttl adapter to it.

If you can access uboot via serial the device should be recoverable.

1 Like

How "beginner" :slight_smile: ?

For example, would it make sense if we said...

Connect just the device and a laptop / PC with an ethernet cable (no other components) and fire up Wireshark to see what traffic the device sends while trying to boot?

If you can do that you may see that the device is trying to find a TFTP server at or other address that it is hard coded to look for. If your then able to set that up (set static IP on laptop and install TFTP service) you'll be able to discover the filename it is looking for.

If that doesn't help then serial interface is the best way to see what is happening.

1 Like

I hope you followed all the steps correctly. Anyway, before jtag or programmer, we have to confirm if serial works or not, if it does, then you maybe able to recover it.

I'm assuming you don't have USB serial adapter or cable. You should watch this video,, this is just an example of how things works by serial.

You'll have to buy a similar USB serial adapter, and connect that with router using it's serial interface. It may or may not require soldering on the router PCB board

1 Like

36 2.861400 TFTP 73 Read Request, File: update.bin, Transfer type: octet, timeout=3

i have upload file over TFTP but in other name update.bin and working again
thanks for this program (Wireshark )

Very pleased that it worked. The details above were almost right then, except the filename.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.