Please Help with meraki mx60w, accidentally the whole thing

clearly i'm not a programmer, :\ though i have a software engineering degree lol...
but i got it working, super duper hacky, but i dont want to spend the energy deciphering all the scripts, so for me there was a bunch of different things going on, first if i boot to initramfs then do that stupid trick to get lan working, then go to the http gui, and click sysupgrade and give it the tar file, it fails saying not a valid image, which is really stupid to begin with. so then i went into the serial console, wget the tar image to /tmp, then tried sysupgrade with -F and it still failed saying could not create ubi partition with size 0... i dont know what the hell is going on there. so i went into /lib/upgrade/ then scrolled way down to where it was doing ubimkvol -N rootfs then if you look a few lines above that theres a condition for the size, either "-m" or "-s blabla" i changed the blabla variable to 16MiB , so that it can successfully get through that portion of the sysupgrade script, then it failed to find the image because apparently it was looking for mx60/root in the tar file whereas in my image its mx60w/root so i downloaded 7zip, opened the tar file, renamed the folder from mx60w to mx60 then wget again to the box. then now this time ran the sysupgrade -F -n -v /tmp/lede-blabla.tar worked! then once done, plug in the network to port one of the switch side and not the wan anymore, and .. suprisingly everything seems working! i didn't try the wireless yet though. but shrugs. thats enough nonsense for a week for me.

so recap:
step 1. follow most of this guide Up until step 7.
step 2. network broken so do fix above, ie delete switch and rename interfaces without vlan from /etc/config/network for the time being when booted from initramfs image. then restart network /etc/init.d/network restart
step 3. if you are on mx60w like me, open the sysupgrade.tar file in 7-zip and rename the mx60w folder to mx60. exit.
step 4. copy the modified tar from above into /tmp of the device using a http or whatever method you can do.
step 5. go edit /lib/upgrade/ scroll down to where it creates ubimkvol -N rootfs $sizewhatever , a few lines above theres an if statement saying that variable is either -m or "-s $1" replace the $1 or wahtever is there with 16MiB (i just randomly chose this number) since its larger than the image so "-s 16MiB" save the file. exit.
step 6. go to /tmp and run sysupgrade -F -n -v lede-blabla.tar
should reboot in a few seconds. then you're done.
step 7 plug in network to lan1 port now everything should work :expressionless:

hi. i have booted and upgraded all the firmware settings. but i can only see one interface eth0. what happened to other four interfaces. do you have any idea? and help me to activate other interfaces.. Thank you

so which steps did you do? were you able to do the sysupgrade successfully?

yes i was able do sys-upgrade properly using gui. it went well. but i can see only one interface eth0 not others. where you able to make your work? . if it is working do you see all the interfaces ?

which version of the image did you use? I used 17.01.4, when I tried the dev snapshot, the other ports wouldn't even light up. so I conclude that the dev snapshot for our box is just completely broken. if you only see eth0 and it upgraded properly, try a factory reset on the settings, it should set everything back to the vlan/switch stuff which is required for all the ports to work properly.


EDIT: That file appears to say "meraki_mx60 600-16010" ...mine reads "meraki_MX60W 600-16015."

guys, any1 can help me with this MX60?

I also deleted whole ubi partitions and one and only way I can reach mx60 is via tftp.
after that i cant flash tar file etc.
I need board-config of MX60 and lil help of some1 from this thread :slight_smile:

can some1?

Sure...if you Private Message me...and provide the:

  • Model (MX60, right?)
  • Serial Number
  • and MAC address

I'll recreate the board-config.img for you.

  • You should be able to reach the router after booting it via TFTP.
  • At this point, you login to LuCI or the command line in order to flash the sysupgrade.

You might have an issue though, since you deleted board-config. This also means you may not have created the recovery partition. Start with fixing board-config, first.

buddy I can't pm you because I'm too young on this forum :frowning:

Pls pm me :slight_smile:

With much thanks

1 Like

@lleachii otherwise i can post mac&sn here but also i need some help with flashing board-config bcs i've never done this by myself.

I just PMed you. Also, have you seen the Booting and Flashing instructions here?

You follow the commands line-for-line, until you verify the partition number of board config (I guess this is the step you missed), and creation of the recovery partition (the instructions say 5MiB, you'll need to make it 10.

Hi again,

i followed all of theese steps but also i've deleted ubi partitions bcs i though i'll be able to do this process again but i think ive deleted board config as i mentioned in pm to u :slight_smile:

1 Like

OK, I PMed you a link to a board-config.img that contains the MAC address and Serial number on your device's sticker.

  • Follow the Flashing section
  • At step 5 you will do the following:
# Create board config
cd /tmp
ubirmvol /dev/ubi0 -N board-config
ubimkvol /dev/ubi0 -s 126KiB -N board-config
ubiupdatevol /dev/ubi0_0 /tmp/board-config-radziasty.img

Step 6, making the recovery partition (use 18.06 as 17.04 does not work):

cd /tmp

##verify the sha256sum
sha256sum openwrt-18.06.0-rc1-apm821xx-nand-meraki_mx60-initramfs-kernel.bin

##I increased the recovery partition to 10 MiB, 5 is too small for version 18.06
ubimkvol /dev/ubi0 -s 10MiB -N recovery
ubiupdatevol /dev/ubi0_1 /tmp/openwrt-18.06.0-rc1-apm821xx-nand-meraki_mx60-initramfs-kernel.bin

From this point, you can proceed to use the command line to flash the TAR, use LuCI to flash the TAR file, or reboot into recovery to do so.

  • Download the Sysupgrade TAR file and perform a normal OpenWrt flash upgrade.
cd /tmp
sha256sum openwrt-18.06.0-rc1-apm821xx-nand-meraki_mx60-squashfs-sysupgrade.tar
sysupgrade -n openwrt-18.06.0-rc1-apm821xx-nand-meraki_mx60-squashfs-sysupgrade.tar
  • Done!


I'm during hardening. Everything went well.

Thanks a lot buddy :slight_smile:

1 Like

i have tried to boot my mx60 but get "no filesystem"

when i change the bootargs to "rootfstype=ramfs" it can find the partitions
but i get this error:

From your picture, it didn't work.

  • What version of OpenWrt are you using?
  • Does your MX60 have a Cisco logo or Meraki logo?

setenv meraki_loadaddr_ramfs 0xbffc00

did the trick
now it can find its ramdisk and boot

1 Like

HI, I have lost my board-config for MX60W. I can see that "lleachii" can recreate it, Can you please help me recreate it for me?

I am also new joiner here, so I wont be able to PM you. I can share my MAC and Serial no of device.

I will be very grateful to you.

Sent to your private messages.