Please help me i have no idea what im doing

I have the Tp-Link Archer C7 AC1750 v5
I plugged router into pc with ethernet cord then went to the website for it: like or something like that. Then set up with password and default settings. I then unplugged etherenet cable so my pc would use my wifi adapter so i could get files. Then i went to and downloaded then renamed it to firmware.bin after this i plugged etherenet cable back into router and went to the firmware and upgrade section of the website 198... and put in the firmware.bin file and then pressed update. It started loading and after 4 minutes or so the webpage said could not connect and now i can't find my routers website. How do i use my router and wrt im a big noob.

Edit: So after about 30 minutes when i go to it loaded openwrt and said that i don't have password what are steps that i need to do to make this router turn into a wifi adapter. i think the firmware finally got going and running.

EDIT: Just saw you managed to access the web UI now. Good news.


  1. Make sure your cable is in a LAN port, not the WAN. On TP-Link LAN ports would usually be coloured in yellow.
  2. Are you using Windows, Linux or MacOS? On Windows, press ctrl+R, type cmd then hit enter. Now try ping Any replies? If not what is the output of ipconfig /all or arp -a. On Linux open terminal, try ping and if no response, try ip a and see what the output is. Steps on macOS would be very similar to Linux.

I am running windows and i believe i plugged it into the wan port it is orange and their are 4 orange ports and one blue one. I updated the password on the openwrt web interface i just recently was able to access. i believe the next step is to download the [Firmware OpenWrt Upgrade URL]
then navigate to the firmware upgrade somewhere on the openwrt webface and install it.

But i still don't know what i would do after that to actually have this router work as a adapter if i do this.

So i think i have flashed the openwrt interface correctly with the second file called upgrade on openwrt website now my open wrt status looks like this:
does this look correct? and how do i get this to connect to my other router plugged into modem?

If you used archer-c7-v5-squashfs-factory.bin then there's no need too flash the openwrt-18.06.4-ar71xx-generic-archer-c7-v5-squashfs-sysupgrade.bin image.

On Windows - download PuTTy, can be dowloaded from I recommend getting just the binary under the " Alternative binary files":

SSH into the router:

Use root for username, by default there is no password. Once logged in, type passwd and configure the password on your router to add more security.

I dont have a hands-on experience with your router model, but a quick google search showed this guide, which seems to cover the basics:

Good luck!

Do i need to do anything to my main router plugged into my modem or can i just set this router to connect to the other router and enter in its password and then connect this openwrt router to my pc using ethernet cord like wifi usb adapter? I tried going into the network and then under wireless overview i clicked scan on my qualcom atheros chip thingy and then i saw my main wifi network like 3 of the same thing. so i just tried clicking on one and then entered in my password for that network but it didn't do anything and had 0% traffic as a client?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.