Plans for OpenWrt to support TP-Link TL-WR902AC?


#64

Any reason why the binary firmware is no longer available in the snapshots folder?

https://downloads.lede-project.org/snapshots/targets/ar71xx/generic/


#65

See some postings above: Plans for LEDE to support TP-Link TL-WR902AC?


#66

If I understand correctly, the problem to support the TL-WR902AC is, the too small partition for the kernel. Is it possible to change the size of it?


#67

Of course, it is possible. There is already a fix https://github.com/lede-project/source/pull/1464
You have to wait for some time untill it will be merged into main source tree.


#68

phew! disaster averted .... :slight_smile:


#69

And if it's done, a new image for the WR902AC will be published? That would be great news.


#70

Hi,

Looking at getting a couple of these after a nightmare with RE450 V2... The binary is back in snapshots... Can anyone confirm if this works before I commit to buy and have to return again! :slight_smile:

Thanks!


#71

@alxscott - Hopefully someone can answer this for you sooner, but if I have some time tonight, I'll give it a shot and report back. I haven't updated my snapshot version in a long time (i.e. last updated when the device was initially supported, but not since it was excluded and re-included).


#72

Much obliged! :slight_smile:


#73

@alxscott -Seems to be working properly :slight_smile:

I neglected to check which snapshot I had been running, but I downloaded the sysupgrade version of the latest snapshot (SNAPSHOT, r5442-b0b289e) and applied it -- no apparent issues.

FWIW, I used the command line to do the upgrade, and used the following flags:
sysupgrade -n -v /tmp/lede-ar71xx-generic-tl-wr902ac-v1-squashfs-sysupgrade.bin

I used -n because I didn't want to save the config, just in case something might have conflicted. The other option (-v) sets verbose mode, but the ssh session was terminated immediately so it didn't give me any additional info. Just to be on the safe side, I let it sit for 5-10 mins since I had no other feedback about the status. When I power cycled the unit, it came up as expected (wifi off, eth0 as LAN with address 192.168.1.1 and the DHCP server enabled). Remember that LuCI is not installed in the snapshot builds, so if you want it, it must be manually installed (which requires either setting up a WAN on the device or using scp (or similar) to copy files over to the 902AC for installation).


#74

Ah brilliant! Not new to Linux but new to LEDE so thanks for all that info...

Quick one... my understanding is the reason the firmware dropped off was because of kernel size. Am I worth just bypassing Luci (if space is tight ) and learning from the CLI side??

Thanks again!


#75

The kernel size issue was, if I understood it properly, a function of one of the other partitions, but that is resolved.

Depends on what you’re doing with the device. There is enough room for LuCI, for sure. But if you will be installing lots of other packages, leave LuCI out to save space, or run extroot to give lots more space.


#76

No, all is good once again. You could do everything CLI fashion, but LUCI
is that good it'd be a shame not to ..... It's a far cry from using CLI
versus Gnome in Linux (where I prefer the CLI!) - I prefer to use LUCI in
LEDE though!


#77

Just a quick update to say successfully flashed latest snapshot; and configured 2 for 802.11s mesh backhaul (5Ghz) and Wireless (2.4Ghz) / Wired AP's!

Very happy!

:slight_smile:

Alex


#78

I bought one of these last week and ... it's terrible. I can't get the 5.0GHz to connect to my home wifi so bandwidth is just bad.

Anyway, I tried to install LEDE and when I use the browser I get the 18001 Error message.

I've setup an tftp server, set my machine to fixed IP 192.168.0.68/24 and verified that I can get the file using tftp. I hold the reset down while plugging in power to the WR902AC and wait until the WPS LED turns on, then ... nothing happens. It boots normally every time.

Is there another method to get the firmware installed? Could I be doing something wrong. I"ve tripple checked the file name, the IP address and even downloaded the data multiple times.

TIA.


#79

Where did you buy your device (what country)? Is it version v1? Eventually, try to rename firmware file to something shorter, like firmware.bin. And make sure you are using factory image.


#80

Thanks for the quick reply. I bought it from Newegg.com and it's the US version. I have factory original firmware installed and running. I tried shortening the file name but I still get:

Error code: 18001
Upgrade unsuccessfully because the length of the upgraded file is incorrect. Please check the file name.

Anything else I can try?


#81

Looks like factory image is corrupted, I will look at the issue today.


#82

I flashed snapshot on one purchased in Australia (EU country code, V1 hardware) and it worked fine.
This was only 2-3 days ago


#83

Brian,

I notice you don't state if yours is V1 hardware - this could be an issue (or I could be barking up the wrong tree!)

There's a possibility you bought the V3 hardware which hasn't been supported yet.

That said, rather than using tftp, you can install LEDE straight from the factory image's web gui using the firmware upgrade functionality. Just point the LEDE image at it instead. Use factory.bin not sysupgrade.bin.