Ping Error, Miscompare at Offset

I use Jumbo Packets, hence, I use the maximum allowed for my LAN. My eth0+eth1 interfaces have 2 extra bytes due to DSA, so ignore that.

My problem:

Whenever I ping my router with 8162 bytes (the maximum data payload I can do), it returns that the packets were successfully sent, albeit with following error:

What do I need to change to fix this? If I change br-lan to go any higher than 1500, my router soft bricks and I have to hit the reset button.

Please paste text as text.

You're an odd one, Brada. GUI text is the same as file text; the information is the same. Nevertheless, here:

	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'x'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	list ipaddr '10.0.0.1/24'
	list dns '10.0.0.1'
	option delegate '0'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option hostname '*'
	option peerdns '0'
	list dns '10.0.0.1'
	option delegate '0'

config device
	option name 'eth0'
	option ipv6 '0'

config device
	option name 'lan1'
	option ipv6 '0'
	option mtu '8190'

config device
	option name 'eth1'
	option ipv6 '0'

config device
	option name 'wlan0'
	option ipv6 '0'

config device
	option name 'lan4'
	option ipv6 '0'
	option mtu '8190'

config device
	option name 'lan2'
	option ipv6 '0'
	option mtu '8190'

config device
	option name 'lan3'
	option mtu '8190'

config device
	option name 'wan'
	option ipv6 '0'

I assume interface mtu is 1500

image

Yep. But I can't change br-lan to go any higher than 1500, or the router soft bricks.

Will not work without it, try with command line ifconfig br-lan mtu 2000 and so on

Ahh also tick away lan3 ip6, not the root of problem though.

Thank you for pointing out the ip6 portion.

Anyway, setting it with that command worked. It now says offset at 1970, which means it scaled up a bit. I wonder what the issue is.

Trying ifconfig br-lan mtu 5000 causes it to soft brick, but setting it to ifconfig br-lan mtu 4000 works. Hm. I'll narrow it down to the highest number.

1 Like

4096 or 4070?

Okay. 4148 seems to be the highest number possible for br-lan before it causes reboot issues. Why is this number the highest it can go if br-lan is just a bridge?

4148 is the highest before it causes issues.

Interesting. If I try to ping at 4122, it replies "timed out". If I try:

4121 or 4123 (+1 or -1) it does the same thing. 4120 and below works, 4124 and above works.


The miscompare error at 1474 makes me to think that the packets actually get fragmented and sent in pieces.

4148 and 4122 in the error message makes me to think this:
4096 + 26 = 4122
4122 + 26 = 4148

Likely there is a 4096 byte buffer in the drivers somewhere.
And somehow a 26 bytes packet header gets applied into the process twice.

Strange.

You might install fping and test fragmentation like

root@router6000:~# fping -M -b 1500 192.168.1.5
192.168.1.5: error while sending ping: Message too large
192.168.1.5 is unreachable
root@router6000:~# fping -M -b 1473 192.168.1.5
192.168.1.5: error while sending ping: Message too large
192.168.1.5 is unreachable
root@router6000:~# fping -M -b 1472 192.168.1.5
192.168.1.5 is alive

(Busybox default ping does not have the fragmentation flag "-M" typical in Linux pings. Windows ping would have the flag "-f" for preventing fragmentation)

I've actually been doing ping 10.0.0.1 -F -L 4148

And it has been sending the packets, reporting no fragmenting even though it says miscompare at offset. So I am unsure what this even actually means.

Hm. Maybe this error is saying, "The router internally has an MTU mismatch, but the LAN is still accepting the packets that the client sends."

I don't think this would affect performance any, since br-lan is just a bridge and not a physical path, right?

At least your AI isn't hallucinating.

(Please be mindful posting AI replies in the forum.)

So lan1 thru lan4 are hallucinations?

(Have you tested actual traffic?)

1 Like

LAN 1-4 are not, but br-lan is a bridge. I thought that meant it is not physical.

My tests are all over the place. Sometimes things work, sometimes they don't. Now that I set the MTU under br-lan in the config file to be 4148, I cannot ping any higher than 2000 for the payload. Trying 2001+ fails whilst everything below it works.

This is incredibly confusing. I am using an XR500.

It's a bridge that connects 4 physical ports - unsure why you're failing to considering that.

What is the use case for these jumbo frames?

Are SRC and DST both Ethernet?

1 Like

Still as abrasive as you were 7 years ago, eh?

Both the SRC and DST are over ethernet, yes. My devices connected via ethernet are set to 8190 to match the LAN1-4 MTUs.