Ping: bad address

I think I understand what you are saying..
thanks for helping. thank you very much
I'll try to fix it.

if i need to guess, i am almost 100% sure that you attached 2 cables to ISP modem/router
or you placed all of your interfaces in one dumb switch
or similar not normal setup
:slight_smile:

you need to have only ONE cable going in ISP modem/router
and then from OpenWRT you could downstream on dumb switch if you wish

but not every interface on same L2 switch

I tried to unplug the 2.5G port from ISP router, but nothing changed.

Please

  1. move your 2.5G to BR-LAN
  2. reboot your OpenWRT
  3. Draw your network topology, ISP router, OWRT, NAS, other devices


the network topology's like this

About IPv6
looks like we are chasing ghosts
Who know what IPv6 address will provide main ASUS router? Is is valid? is it working?
maybe best solution is to turn off IPv6 on OpenWRT? delete wan6 device?

busybox which is shipped with OpenWRT (wget, ping, etc) has no proper fallback and will always start with IPv6 if available, but could not fallback to IPv4

and about OpenWRT use in this topology
if i get it right, you want to isolate devices behind OpenWRT from wireless devices ?

I can access the ASUS router console, but how can I check whether the IPv6 address is valid? before updating OWRT from 21.02 to 22.03, it worked fine.

I want to access NAS from all wireless devices, so I didn't connect any devices to OWRT LAN

on android phone, or laptop attached to wifi, try to open

as i see from your schematic, wifi is directly connected to asus


android client screenshot