Pine rockpro64 fail to boot


Used Balena Etcher to flash pine64_rockpro64-ext4-sysupgrade.img.gz to eMMC.

I noticed the filename contained "sysupgrade", is it supposed to be possible to install OpenWrt using this file? Or do I have to build an installation image?

I tried 7zip to uncompress the .gz, but in it complained about at the end "There are some data after the end of the payload data” mean?" Balena Etcher supports flashing gz. compressed files, and it did not complain, but since I'm having issues, something may be wrong anyways.

I'm using the USB adaptyer for eMMC module + eMMC from

- which should work for this device.

Also tried to ping it, but no reply.

Found but couldn't find a solution there.

Attaching boot message.

UPDATE-1: After a night's sleep my current working hypothesis is that Openwrt currently only can boot SD-cards for this device (and not what I use, eMMC)

UPDATE-2: Flashed SD-card (SanDisk ultra 200gb). Same behavior. Next try will be a Linux distro known to be bootable, and/or flash SPI w/ u-boot using

Seems that is related to this. Please consider joining the dev and testing efforts there.

Thank you!