Thank you also for your confidence
I want to use my router LINK MR 3020 as a server so that I can contact him from outside, I have an openwrt (Barrier Breaker 14.07), so far I've tried the pptp and openvpn protocols but unfortunately the pptp can not connect, and the openvpn protocol give me this message:

Tue Jan 22 20:16:00 2019 OpenVPN 2.3.6 mips-openwrt-linux-gnu [SSL (OpenSSL)] [L                                                      ZO] [EPOLL] [MH] [IPv6] built on Jan  6 2015
Tue Jan 22 20:16:00 2019 library versions: OpenSSL 1.0.2f  28 Jan 2016, LZO 2.08
Tue Jan 22 20:16:00 2019 WARNING: file 'authuser' is group or others accessible
Tue Jan 22 20:16:00 2019 UDPv4 link local: [undef]
Tue Jan 22 20:16:00 2019 UDPv4 link remote: [AF_INET]
Tue Jan 22 20:16:00 2019 CRL: cannot read: [[INLINE]]
Tue Jan 22 20:16:00 2019 TLS_ERROR: BIO read tls_read_plaintext error: error:140                                                      90086:lib(20):func(144):reason(134)
Tue Jan 22 20:16:00 2019 TLS Error: TLS object -> incoming plaintext read error
Tue Jan 22 20:16:00 2019 TLS Error: TLS handshake failed
Tue Jan 22 20:16:00 2019 SIGUSR1[soft,tls-error] received, process restarting
Tue Jan 22 20:16:02 2019 UDPv4 link local: [undef]
Tue Jan 22 20:16:02 2019 UDPv4 link remote: [AF_INET]

After this procedure:

Read that thread:

@hafid -

A few things:

  1. you should run a more recent version of OpenWrt -- BB is very old and has lots of security issues, and implementation details may be different than current versions. It is tight, but you can use 17.01.6 safely on the MR3020.
  2. You should use the extroot process (described well in Logan's blog)
  3. It is not clear if you are trying to create an OpenVPN server (i.e. the 'remote' system relative to wherever you are at the moment), or if you are looking to make an OpenVPN client (i.e. the device you have with you that connects to a remote [personal or commercial] VPN server). Most of the basic configuration is similar, but there are important differences that you need to take into account (and also, you may want your server device to be more powerful -- the MR3020 is not a stellar performer in terms of speed, but it is fantastic as a travel router with OpenVPN client configurations; I wouldn't recommend it as your OpenVPN server).

Updating to a recent OpenWrt build should be your starting point... from there we can help you troubleshoot the specific issues as you bring up the OpenVPN server and/or client.

Not sure whether you want to use the MR3020 as client or server.

  • To use the MR3020 as a openvpn server, you need to have a public/external IP address configured with ddns.

  • The link you posted, has configurations for client setup.

  • The openvpn log shows that its not able to connect to at the port 1198, make sure the IP is reachable and no firewall is blocking the port 1198.

And as @psherman stated, BB is very old and has security issues, you can always move to latest OpenWrt or LEDE, but a better option would be to upgrade the device.

I've read the title


So, i guess its probably the client setup you want to use. The link you posted has old PIA configurations, use latest ovpn config files. And make use your ISP isn't blocking the port you plan on using.

There is a newer version of TP-Link's travel router called the TL-WR902AC. It is only 8/64, but that is sufficient to get stuff going, and with extroot, you can do quite well with it. Still not nearly as powerful as non-travel router, so it is best to get a normal home router if you're setting up a server. But if you're traveling with this thing, it is a good product, and there are also other travel routers you could consider such as the ones from GLi net.

The ambiguity of your request (about setting up an OpenVPN server vs a client device) comes from this:

combined with the title -- so it's not really clear what you're trying to do.

i think what he means is

He wants to use the MR3020 to act as a server to run OpenVPN client for the LAN.

It's like an ESXi server, but the server is the OpenWrt device itself.

newbies are complicated.:sweat_smile:

1 Like

:rofl::rofl::rofl::rofl: hhhhhhhhhhh

I want to create my own free VPN server in my openwrt router.

Oh, so you want a VPN server on your router for external clients to connect to your local network?
It's a completely different approach then, make sure you have an external(public) IP on your WAN interface.

Follow this tutorial : https://loganmarchione.com/2015/08/openwrt-with-openvpn-server-on-tp-link-archer-c7/

The MR3020 only has 4 MB of flash memory. After the installation of OpenWrt CHAOS CALMER, there is only about 344 KB left, which will not be enough for the 600 KB + libraries openvpn-openssl and luci-app-openvpn. also ExtRoot does not work how I can solve this problem.

With 4mb, you should maybe think to use uci/cli only and remove anything about luci. Like people said BB and CC are old. Not only security is an issue here, but you will probably hit on problems because of stoneage old OpenVPN client.

You need to build a custom image that has the extroot related packages pre-installed (and LuCI omitted) in order to have enough space to run extroot. Once you've got extroot operational, you can install LuCI and other packages.

This thread discusses the extroot image generation.

Also, please do not use OpenWrt Chaos Calmer (too old, many security issues, not supported/maintained, etc.). You should use LEDE 17.01.6. (OpenWrt 18.06.1 is current, but, and while possible, not recommended to run on the MR3020 because it is too big for a 4/32 device).

1 Like

when I ping my domain DDNS I received this msg please how to solve this problem:
Ping Statistics for XXX.XXX.XXX.XXX:
Packages: sent = 4, received = 0, lost = 4 (lost 100%),

That means the ping was unsuccessful.
You've provided inadequate information. Edit your comment with more useful info.
And if you're using a dynamic IP, there's no use masking it.


I would like to be able to ping my public IP address, I registered on no-ip.com and I set up my no-ip account in the openwrt interface on TPLINK MR 3020 router.

So I'm supposed to have a public ip fixed, but I can not pinger from my windows console?

How should I proceed?


Can you enable SSH on this interface and login to your router?

I am talking about public IP

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.