PHP error message no_glibc

Hi,

I have the following error when using nextcloud in RPI4(openwrt 22.03.04):

user.notice php: richdocumentscode (proxy.php) error exit, PID: 19179, Message: no_glibc

does it mean there is no glibc in the system? How to check the existence? and how to install if not existing?

OpenWrt uses musl, not glibc. AFAIK, you can't install it, that would require a rebuild of the entire system.

I think that the richdocuments PlugIn works if you use the non-alpine docker image (see here).

1 Like

thanks for the info.