Phillips hue and bcp38

so i have a phillips hue, well bcp38 works great obviously because its constantly unlinking me from their servers. Does anyone have any idea to get around this? or just link the device locally rather than have it contact a remote server? my first step is going to be contacting phillips hue to address the issue and see if they can setup some kind of dynamic dns or create a specific bridge device just for the phillips hue controller.

i think i figured it out, ill let ya know.

please do, because ... WAT?????

i think you just have to allow that 1 address for your device...that hue control feature no longer works i guess, i tried setting a username for it and its a no go, idk im just coming back to a fresh flash with openwrt, ill let you know. did you not have that problem?

well anyways i thought it was bcp38 causing the issue but it could have just been how my device was flashed possibly, so i went to dd-wrt then back to the stock firmware then back to the image i was on before, It hasnt disconnected the bridge as of yet. so maybe it was just a bug. as for the hue control post, that no longer applies, you cant set a username on the api anymore locally, so it really cant be controlled by the api anymore unless you have your bridge linked with phillips hues server. i had tried using the api with the bridge unlinked and factory restore and it didnt work at all. would have been nice to be able to control it locally rather than exposing it to the internet. im gonna contact phillip hues about this.

I also found this little diddy so if its possible its on here.