PHICOMM K3C Router


#21

Have you checked out your Phicomm K3C version?
Remember that the only that works are the "oldies": A1, B1, B1G
If you have a B2 or C1 it won't work :frowning:


#23

A1 version here. I read through a lot of those threads on chinese sites and I'm confused as to the flash method. I saw some doing a telnet mod but that requires a cn firmware, which I cannot flash on my US/EU A1 version.


#24

about overclocking
1000MHz is OK
http://k3c.paldier.com/uboot/beta/k/
then you need to make overclocking firmware for yourself,



change xrx550_800_cpuclocks to xrx550_1000_cpuclocks
NOTE temperature and ventilation


#25

about flash firmware
need TTL and TFTP
execute "run update_fullimage" in TTL
If the production date of your device is after 2018/05,follow below
execute "ubi part system_sw"
execute "ubi remove data_vol"

now erverything is ok
execute "reset"

and this way can solve the firmware problem too,
In most cases, the problem is that the partition is missing
execute "nand erase 1340000 06c00000"
execute "run update_fullimage"
execute "run update_bootcore"
In a few cases, the problem is that mtd3/mtd4/mtd6/mtd7 partition is missing or damage
flash backup of mtd3/mtd4/mtd6/mtd7
then flash stock firmware


#26

Thanks!!!
Which version of the stock firmware should we flash after the TTL?
I have a TTL and will solder leads this week.


#27

Edit: had the wrong fullimage.img
Used the one here ( http://k3c.paldier.com/openwrt/ ) and it works I am in openwrt.. dhcp is default off so need 192.168.1.100 255.255.255.0 manually connect to http://192.168.1.1
Login password is admin

TO CHANGE LANGUAGE.
Go to second button after "K3C" on the top of the page.
Click that, pick the first option on drop down.
Then pick the third tab, you will see chinese and change it to Auto. scroll down and hit the left most blue button to save+apply.
Click something in the menu on top and you can see language changes to your locale/english.

Iw reg list shows 2 interfaces both 5ghz. Not working however.
And the 2.4ghz not listed there.

Current issue: both wireless interfaces are not starting.
Iw reg list shows 2 interfaces both 5ghz. Not working however.
And the 2.4ghz not listed there.

iwinfo
root@K3C:~# iwinfo
wlan0     ESSID: unknown
          Access Point: 00:00:00:00:00:00
          Mode: Master  Channel: 36 (5.180 GHz)
          Tx-Power: 19 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -256 dBm
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 1BEF:0810 1BEF:0810 [Lantiq Wave5xx]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

wlan1     ESSID: unknown
          Access Point: 00:00:00:00:00:00
          Mode: Client  Channel: unknown (unknown)
          Tx-Power: 0 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 1BEF:0810 1BEF:0810 [Lantiq Wave5xx]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: no  PHY name: phy2

#28

Ok I got the wireless working.
Deleted /etc/config/wireless and rebooted. It was recreated properly.

But can't set txpower. I tried all devices phy0 phy1 phy2 phy3
It's always at 30 and iw command to set it says:

root@K3C:/# iw phy phy1 set txpower fixed 25
command failed: Operation not supported (-122)
root@K3C:/# iw phy phy1 set txpower limit 25
command failed: Operation not supported (-122)


#29

yes, you can not set txpower,and you can change county code
CN: 2.4:30 5:30
US: 2.4:30 5:30
others:default
wlan1 and wlan3 are client mode,and luci can not work well,add these to /etc/config/wireless and add wifi to wan network,it is like wisp,do not add to lan, not working

    config wifi-device 'wlan1'
            option type 'mtlk'
            option macaddr '2C:B2:1A:54:32:C2' #wlan0 mac+2
            option hwmode '11a'
            option country 'CN'
            option beacon_int '100'
            option htmode 'VHT80'
            option txpower '30'
            option channel 'auto'
            option disabled '1'

    config wifi-iface 'default_wlan1'
            option device 'wlan1'
            option ssid 'DreamBox' #要中继的ssid
            option mode 'sta'
            option wds '1'
            option encryption 'psk2' #要中继的加密类型
            option key '12345678' #要中继的密码
            option wps_pushbutton '0'
            option network 'wifi'

    config wifi-device 'wlan3'
            option type 'mtlk'
            option macaddr '2C:B2:1A:54:32:C6' #wlan2 mac+2
            option hwmode '11g'
            option country 'CN'
            option beacon_int '100'
            option htmode 'HT40'
            option txpower '30'
            option channel 'auto'
            option disabled '1'

    config wifi-iface 'default_wlan3'
            option device 'wlan3'
            option ssid 'DreamBox' #要中继的ssid
            option mode 'sta'
            option wds '1'
            option encryption 'psk2' #要中继的加密类型
            option key '12345678' #要中继的密码
            option wps_pushbutton '0'
            option network 'wifi'

BTW:do not boot wifi when you connected TTL,hardware is defective,2.4G chip and PA are easily damaged


#30

Thanks. So power is always maximum but works very good!

Is there uboot recovery update I can flash that gives me the telnet recovery of openwrt? I was looking at your files but not sure which mtd# to flash ubootnand or image or env to. If I hold button and put power, it goes to the factory recovery menu webpage, no telnet console.

I have wifi on lan working. But sometimes dhcp fails. I will try adding to wan, since this is just access point.
Where is network wifi? In /etc/config/network there is lan (eth0_1,2,3,4) wan (eth1)
You mean to add wifi under wan?

config interface 'wan'
	option ifname 'eth1 wifi'    <---- add wifi here? 
        option type 'bridge'   <should I add this to bridge wan and wifi?

What is the wlan1 and wlan 3 for?


#31


#32

do you reset to factory default?i guess NO


#33

Found a bug. rc.d was not being run... I put touch /tmp/executedLED for example and no file was in temp. Looked inside rc.d and there was a wrong file put in there: config.sh symlinked. Weird. Anyway... still strange things.

Factory reset yes, when I started to configure. I am using B10, your image is B7. I see more information on your wireless page than in B10 just shows ssid/mac/host and bitrate/signal. No MCS shown. Where can I try B7?

One other issue...
Using LAN with static on my network. Gateway 192.168.1.1 and can ping others on network from router, but I cannot ping my router 192.168.1.1??? Router can ping k3c, and others can ping router. It's a very confusing thing.


#34

i can not solve the problem of non-firmware
run first script, if you get any error message,run second script,then run first script after rebooting
http://k3c.paldier.com/tools/k3cop.sh
http://k3c.paldier.com/tools/k3cfix.sh


#35

k3cop.sh Script fails because I don't have DNS working, so download fails...
If I use by IP of k3c.paldier.com, it fails even in browser due to cloudflare safety.

Gateway is set to router and dns set to router.. even tried 8.8.8.8 for DNS - same problem

Anyway I checked conditions in the script.
-data_vol is 16, so less than 166 GOOD
-imem is 94364, 95352, 512 which is greater than 60000 GOOD
-icount is 0, GOOD
uver is 1.0.0.0 GOOD condition

my existing md5 matches:
system.@system[0].vermd5='b3ed234cc1981fdc78fae1c79d4a6edb'

You have network on LAN and can use dns lookup?
For me, it seems like routing issue. I disabled and stopped firewall and dnsmasq, no change.
On my other openwrt access points, DNS works fine and they can ping 192.168.81.1 router. K3c can not ping 192.168.81.1 but pings other in network fine.


#36

nothing is good


#37

What you mean nothing is good? I'm going by the conditions below:

icount=`ps -w|grep upgrade|grep -v grep|wc -l`
imem=`df |grep tmpfs |awk  '{print $4}'`
uver=`/usr/sbin/uboot_env --get --name PHI_UBOOT_VER`
data_vol=`ubinfo -d 0 -n 6 |grep Size |awk  '{print $2}'`
[ $data_vol -gt 166 ] && echo "No space left on device !!!!!! data_vol too big" && exit
[ $imem -lt 60000 ] && echo "reboot and try again !!!!!!" && exit
[ "$icount" -gt 0 ] && echo "reboot and try again !!!!!!" && exit
[ "$uver" != "1.0.0.0" -a "$uver" != "1.0.0.1" -a "$uver" != "1.0.0.2" ] && echo "uboot verify failed !!!!!!" && exit


Running those commands manually to get the values, I don't trigger any of those error messages.

My wifi works fine and clients can connect.  Just sometimes dhcp will not get address- same happened with stock firmware- so I think it is switch bridge issue with this hardware.

Here's my ping issue with ifconfig. I'm using 192.168.81.0 network 255.255.255.0 gateway 192.168.81.1 dns 192.168.81.1 OR 8.8.8.8 (same issue no dns work)

root@K3C:~# ping yahoo.com
^C(just waiting)
root@K3C:~# ping 192.168.81.1
PING 192.168.81.1 (192.168.81.1): 56 data bytes
--- 192.168.81.1 ping statistics ---
24 packets transmitted, 0 packets received, 100% packet loss
root@K3C:~# ping 192.168.81.11
PING 192.168.81.11 (192.168.81.11): 56 data bytes
64 bytes from 192.168.81.11: seq=0 ttl=64 time=3.544 ms
64 bytes from 192.168.81.11: seq=1 ttl=64 time=0.784 ms
^C
--- 192.168.81.11 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 0.784/2.164/3.544 ms
root@K3C:~# ping 192.168.81.12
PING 192.168.81.12 (192.168.81.12): 56 data bytes
64 bytes from 192.168.81.12: seq=0 ttl=64 time=0.821 ms
^C
--- 192.168.81.12 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 0.821/0.821/0.821 ms
root@K3C:~#ifconfig

br-lan    Link encap:Ethernet  HWaddr 00:20:DA:86:23:75
          inet addr:192.168.81.13  Bcast:192.168.81.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:221 errors:0 dropped:0 overruns:0 frame:0
          TX packets:133 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:16994 (16.5 KiB)  TX bytes:42600 (41.6 KiB)

eth0_1    Link encap:Ethernet  HWaddr 00:20:DA:86:23:75
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0_2    Link encap:Ethernet  HWaddr 00:20:DA:86:23:76
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0_3    Link encap:Ethernet  HWaddr 00:20:DA:86:23:77
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0_4    Link encap:Ethernet  HWaddr 00:20:DA:86:23:78
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:156249 errors:0 dropped:1030 overruns:0 frame:0
          TX packets:152572 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:22052744 (21.0 MiB)  TX bytes:38358779 (36.5 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:81730 errors:0 dropped:0 overruns:0 frame:0
          TX packets:81730 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:9111398 (8.6 MiB)  TX bytes:9111398 (8.6 MiB)

wlan0     Link encap:Ethernet  HWaddr 2C:B2:1A:54:3C:C4
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16203 errors:0 dropped:0 overruns:0 frame:0
          TX packets:194161 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:16386048 (15.6 MiB)  TX bytes:17432143 (16.6 MiB)

wlan2     Link encap:Ethernet  HWaddr 2C:B2:1A:54:3C:C8
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:841 errors:0 dropped:0 overruns:0 frame:0
          TX packets:129323 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:180068 (175.8 KiB)  TX bytes:7262862 (6.9 MiB)


#38

i can not solve the problem of non-firmware


#39

Oh I understand. Sorry must be hard with translation. Thank you for helping me install the firmware.


#40

Hello!
I have k3c c1 version with Firmware Version:34.1.7.30.
Successfuly activate telnet.then install dropbear.so i have full access to firmware.Is your firmware compatible with C1?
And what OS you recomended for compile firmware from your github repo,on Buster - fail,on Ubuntu 14.04.5 many errors.nfs server,uboot etc
P.S. On original firmware K3C redirect http://k3c.paldier.com to router interface.....Interesting.....


#41

i need all partition backups and /proc/config.gz

kernel and rootfs depend on uboot,don't change anything