Phicomm K2P / MT7615DN WiFi 2.4GHz max tx power issue

Hello, I'm struggling with the WiFi, especially the 2.4 GHz one. This router's WiFi 2.4 GHz transmit power can't be set higher than 11 dBm (sometimes 8dBm). The same goes for the WiFi 5 GHz, the maximum transmit power can't be set higher than 8dBm. I don't know what I should do, since I'm not a developer.

configs

SYSTEM BOARD

{
	"kernel": "6.6.73",
	"hostname": "OpenWrt",
	"system": "MediaTek MT7621 ver:1 eco:3",
	"model": "Phicomm K2P",
	"board_name": "phicomm,k2p",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "24.10.0",
		"revision": "r28427-6df0e3d02a",
		"target": "ramips/mt7621",
		"description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
		"builddate": "1738624177"
	}
}

NETWORK

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde3:bf2b:c2b6::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

WIRELESS

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '2g'
	option channel '1'
	option htmode 'HT20'
	option disabled '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option disabled '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
	option band '5g'
	option channel '36'
	option htmode 'VHT80'
	option disabled '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option disabled '0'

DHCP

config dnsmasq
	option domainneeded	1
	option boguspriv	1
	option filterwin2k	0  # enable for dial on demand
	option localise_queries	1
	option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
	option rebind_localhost 1  # enable for RBL checking and similar services
	#list rebind_domain example.lan  # whitelist RFC1918 responses for domains
	option local	'/lan/'
	option domain	'lan'
	option expandhosts	1
	option nonegcache	0
	option cachesize	1000
	option authoritative	1
	option readethers	1
	option leasefile	'/tmp/dhcp.leases'
	option resolvfile	'/tmp/resolv.conf.d/resolv.conf.auto'
	#list server		'/mycompany.local/1.2.3.4'
	option nonwildcard	1 # bind to & keep track of interfaces
	#list interface		br-lan
	#list notinterface	lo
	#list bogusnxdomain     '64.94.110.11'
	option localservice	1  # disable to allow DNS requests from non-local subnets
	option ednspacket_max	1232
	option filter_aaaa	0
	option filter_a		0
	#list addnmount		/some/path # read-only mount path to expose it to dnsmasq

config dhcp lan
	option interface	lan
	option start 	100
	option limit	150
	option leasetime	12h

config dhcp wan
	option interface	wan
	option ignore	1

FIREWALL

config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

99-defaults

wlan_name="OpenWrt"
lan_ip_address="192.168.1.1"


## LAN
if [ -n "$lan_ip_address" ]; then
	uci set network.lan.ipaddr="$lan_ip_address"
	uci commit network
fi


## WIFI
if [ -n "$wlan_name" ]; then
	for i in radio0 radio1; do
		uci set wireless."$i".disabled='0'
		uci set wireless.default_"$i".disabled='0'
		uci set wireless.default_"$i".ssid="$wlan_name"
	done
	uci commit wireless
fi

if [ -n "$wlan_password" -a ${#wlan_password} -ge 8 ]; then
	for i in radio0 radio1; do
		uci set wireless.default_"$i".encryption='psk2'
		uci set wireless.default_"$i".key="$wlan_password"
	done
	uci commit wireless
fi
boot-log via serial
...
[    0.000000] Linux version 6.6.73 (builder@buildhost) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 13.3.0 r28427-6df0e3d02a) 13.3.0, GNU ld (GNU Binutils) 2.42) #0 SMP Mon Feb  3 23:09:37 2025
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is Phicomm K2P
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] percpu: Embedded 12 pages/cpu s19136 r8192 d21824 u49152
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Writing ErrCtl register=00010007
[    0.000000] Readback ErrCtl register=00010007
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32480
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 117996K/131072K available (8363K kernel code, 653K rwdata, 1016K rodata, 1284K init, 229K bss, 13076K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] rcu: Hierarchical RCU implementation.
[    0.000000] 	Tracing variant of Tasks RCU enabled.
[    0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 10 jiffies.
[    0.000000] NR_IRQS: 256
[    0.000000] rcu: srcu_init: Setting srcu_struct sizes based on contention.
[    0.000000] clocksource: GIC: mask: 0xffffffffffffffff max_cycles: 0xcaf478abb4, max_idle_ns: 440795247997 ns
[    0.000004] sched_clock: 64 bits at 880MHz, resolution 1ns, wraps every 4398046511103ns
[    0.016054] Calibrating delay loop... 586.13 BogoMIPS (lpj=2930688)
[    0.088324] pid_max: default: 32768 minimum: 301
[    0.106342] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.120762] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.145044] RCU Tasks Trace: Setting shift to 2 and lim to 1 rcu_task_cb_adjust=1 rcu_task_cpu_ids=4.
[    0.163954] rcu: Hierarchical SRCU implementation.
[    0.173371] rcu: 	Max phase no-delay instances is 1000.
[    0.184544] smp: Bringing up secondary CPUs ...
[    0.194457] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.194488] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.194504] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.194552] CPU1 revision is: 0001992f (MIPS 1004Kc)
[    0.254033] Synchronize counters for CPU 1: done.
[    0.316304] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.316327] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.316339] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.316371] CPU2 revision is: 0001992f (MIPS 1004Kc)
[    0.375288] Synchronize counters for CPU 2: done.
[    0.435732] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.435756] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.435769] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.435803] CPU3 revision is: 0001992f (MIPS 1004Kc)
[    0.494881] Synchronize counters for CPU 3: done.
[    0.554488] smp: Brought up 1 node, 4 CPUs
[    0.569409] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.588911] futex hash table entries: 1024 (order: 3, 32768 bytes, linear)
[    0.606493] pinctrl core: initialized pinctrl subsystem
[    0.620011] NET: Registered PF_NETLINK/PF_ROUTE protocol family
[    0.632533] thermal_sys: Registered thermal governor 'step_wise'
[    0.634652] /pinctrl: Fixed dependency cycle(s) with /pinctrl/pinctrl0
[    0.674378] clocksource: Switched to clocksource GIC
[    0.694136] NET: Registered PF_INET protocol family
[    0.703976] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.719802] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
[    0.736346] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
[    0.751690] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.766902] TCP bind hash table entries: 1024 (order: 2, 16384 bytes, linear)
[    0.781126] TCP: Hash tables configured (established 1024 bind 1024)
[    0.794752] MPTCP token hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.809341] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.822232] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.837037] NET: Registered PF_UNIX/PF_LOCAL protocol family
[    0.848245] PCI: CLS 0 bytes, default 32
[    0.859709] workingset: timestamp_bits=14 max_order=15 bucket_order=1
[    0.873606] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.885095] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.910544] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
[    0.928742] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.940255] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.951738] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.963336] mt7621-pci 1e140000.pcie: host bridge /pcie@1e140000 ranges:
[    0.976596] mt7621-pci 1e140000.pcie:   No bus range found for /pcie@1e140000, using [bus 00-ff]
[    0.994054] mt7621-pci 1e140000.pcie:      MEM 0x0060000000..0x006fffffff -> 0x0060000000
[    1.010289] mt7621-pci 1e140000.pcie:       IO 0x001e160000..0x001e16ffff -> 0x0000000000
[    1.384374] mt7621-pci 1e140000.pcie: pcie1 no card, disable it (RST & CLK)
[    1.398161] mt7621-pci 1e140000.pcie: pcie2 no card, disable it (RST & CLK)
[    1.411960] mt7621-pci 1e140000.pcie: PCIE0 enabled
[    1.421805] PCI coherence region base: 0x60000000, mask/settings: 0xf0000002
[    1.435938] mt7621-pci 1e140000.pcie: PCI host bridge to bus 0000:00
[    1.448505] pci_bus 0000:00: root bus resource [bus 00-ff]
[    1.459344] pci_bus 0000:00: root bus resource [mem 0x60000000-0x6fffffff]
[    1.472990] pci_bus 0000:00: root bus resource [io  0x0000-0xffff]
[    1.485331] pci 0000:00:00.0: [0e8d:0801] type 01 class 0x060400
[    1.497203] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.509640] pci 0000:00:00.0: reg 0x14: [mem 0x00000000-0x0000ffff]
[    1.522187] pci 0000:00:00.0: supports D1
[    1.530033] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    1.543343] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    1.559499] pci 0000:01:00.0: [14c3:7615] type 00 class 0x000280
[    1.571429] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit]
[    1.585005] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    1.614806] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
[    1.625142] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.637186] pci 0000:00:00.0:   bridge window [mem 0x00000000-0x000fffff]
[    1.650664] pci 0000:00:00.0:   bridge window [mem 0x00000000-0x000fffff pref]
[    1.665013] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    1.678183] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    1.691282] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    1.705107] pci 0000:00:00.0: BAR 8: assigned [mem 0x60000000-0x600fffff]
[    1.718576] pci 0000:00:00.0: BAR 9: assigned [mem 0x60100000-0x601fffff pref]
[    1.732918] pci 0000:00:00.0: BAR 1: assigned [mem 0x60200000-0x6020ffff]
[    1.746415] pci 0000:00:00.0: BAR 7: assigned [io  0x0000-0x0fff]
[    1.758504] pci 0000:01:00.0: BAR 0: assigned [mem 0x60000000-0x600fffff 64bit]
[    1.773021] pci 0000:00:00.0: PCI bridge to [bus 01]
[    1.782856] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.794953] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    1.808441] pci 0000:00:00.0:   bridge window [mem 0x60100000-0x601fffff pref]
[    1.822773] pci_bus 0000:00: Some PCI device resources are unassigned, try booting with pci=realloc
[    1.840744] pci_bus 0000:00: resource 4 [mem 0x60000000-0x6fffffff]
[    1.853183] pci_bus 0000:00: resource 5 [io  0x0000-0xffff]
[    1.864242] pci_bus 0000:01: resource 0 [io  0x0000-0x0fff]
[    1.875313] pci_bus 0000:01: resource 1 [mem 0x60000000-0x600fffff]
[    1.887745] pci_bus 0000:01: resource 2 [mem 0x60100000-0x601fffff pref]
[    1.902720] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    1.925062] printk: console [ttyS0] disabled
[    1.934221] 1e000c00.uartlite: ttyS0 at MMIO 0x1e000c00 (irq = 18, base_baud = 3125000) is a 16550A
[    1.952229] printk: console [ttyS0] enabled
[    1.952229] printk: console [ttyS0] enabled
[    1.968762] printk: bootconsole [early0] disabled
[    1.968762] printk: bootconsole [early0] disabled
[    1.992786] spi-mt7621 1e000b00.spi: sys_freq: 220000000
[    2.004974] spi-nor spi0.0: gd25q128 (16384 Kbytes)
[    2.014882] 5 fixed-partitions partitions found on MTD device spi0.0
[    2.027591] OF: Bad cell count for /palmbus@1e000000/spi@b00/flash@0/partitions
[    2.042185] OF: Bad cell count for /palmbus@1e000000/spi@b00/flash@0/partitions
[    2.057125] Creating 5 MTD partitions on "spi0.0":
[    2.066720] 0x000000000000-0x000000030000 : "u-boot"
[    2.078318] 0x000000030000-0x000000040000 : "u-boot-env"
[    2.090340] 0x000000040000-0x000000050000 : "factory"
[    2.101849] OF: Bad cell count for /palmbus@1e000000/spi@b00/flash@0/partitions
[    2.116979] 0x000000050000-0x0000000a0000 : "permanent_config"
[    2.129831] 0x0000000a0000-0x000001000000 : "firmware"
[    2.141762] 2 uimage-fw partitions found on MTD device firmware
[    2.153642] Creating 2 MTD partitions on "firmware":
[    2.163548] 0x000000000000-0x0000003072b2 : "kernel"
[    2.173442] mtd: partition "kernel" doesn't end on an erase/write block -- force read-only
[    2.191266] 0x0000003072b2-0x000000f60000 : "rootfs"
[    2.201219] mtd: partition "rootfs" doesn't start on an erase/write block boundary -- force read-only
[    2.220693] mtd: setting mtd6 (rootfs) as root device
[    2.230890] 1 squashfs-split partitions found on MTD device rootfs
[    2.243210] 0x000000750000-0x000000f60000 : "rootfs_data"
[    2.397723] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    2.419108] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 19
[    2.438957] mtk_soc_eth 1e100000.ethernet eth1: mediatek frame engine at 0xbe100000, irq 19
[    2.457301] i2c_dev: i2c /dev entries driver
[    2.469890] NET: Registered PF_INET6 protocol family
[    2.482816] Segment Routing with IPv6
[    2.490240] In-situ OAM (IOAM) with IPv6
[    2.498192] NET: Registered PF_PACKET protocol family
[    2.508385] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    2.534744] 8021q: 802.1Q VLAN Support v1.8
[    2.573880] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    2.614567] mt7530-mdio mdio-bus:1f: configuring for fixed/rgmii link mode
[    2.629705] mt7530-mdio mdio-bus:1f lan1 (uninitialized): PHY [mt7530-0:00] driver [MediaTek MT7530 PHY] (irq=21)
[    2.651984] mt7530-mdio mdio-bus:1f: Link is Up - 1Gbps/Full - flow control rx/tx
[    2.653698] mt7530-mdio mdio-bus:1f lan2 (uninitialized): PHY [mt7530-0:01] driver [MediaTek MT7530 PHY] (irq=22)
[    2.690536] mt7530-mdio mdio-bus:1f lan3 (uninitialized): PHY [mt7530-0:02] driver [MediaTek MT7530 PHY] (irq=23)
[    2.713778] mt7530-mdio mdio-bus:1f lan4 (uninitialized): PHY [mt7530-0:03] driver [MediaTek MT7530 PHY] (irq=24)
[    2.736924] mtk_soc_eth 1e100000.ethernet eth0: entered promiscuous mode
[    2.750481] DSA: tree 0 setup
[    2.757341] clk: Disabling unused clocks
[    2.771114] VFS: Mounted root (squashfs filesystem) readonly on device 31:6.
[    2.789165] Freeing unused kernel image (initmem) memory: 1284K
[    2.801027] This architecture does not have kernel memory protection.
[    2.813871] Run /sbin/init as init process
[    3.291652] init: Console is alive
[    3.298839] init: - watchdog -
[    4.159345] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.229931] usbcore: registered new interface driver usbfs
[    4.241188] usbcore: registered new interface driver hub
[    4.251961] usbcore: registered new device driver usb
[    4.263715] gpio_button_hotplug: loading out-of-tree module taints kernel.
[    4.288177] xhci-mtk 1e1c0000.xhci: supply vbus not found, using dummy regulator
[    4.303308] xhci-mtk 1e1c0000.xhci: supply vusb33 not found, using dummy regulator
[    4.318947] xhci-mtk 1e1c0000.xhci: xHCI Host Controller
[    4.329642] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 1
[    4.349705] xhci-mtk 1e1c0000.xhci: hcc params 0x01401198 hci version 0x96 quirks 0x0000000000280010
[    4.368020] xhci-mtk 1e1c0000.xhci: irq 26, io mem 0x1e1c0000
[    4.379733] xhci-mtk 1e1c0000.xhci: xHCI Host Controller
[    4.390353] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 2
[    4.405289] xhci-mtk 1e1c0000.xhci: Host supports USB 3.0 SuperSpeed
[    4.419186] hub 1-0:1.0: USB hub found
[    4.426852] hub 1-0:1.0: 2 ports detected
[    4.436215] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[    4.453642] hub 2-0:1.0: USB hub found
[    4.461298] hub 2-0:1.0: 1 port detected
[    4.478322] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.499456] init: - preinit -
[    5.259333] mtk_soc_eth 1e100000.ethernet wan: renamed from eth1
[    6.674386] random: crng init done
[    7.111903] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[    7.132327] mt7530-mdio mdio-bus:1f lan1: configuring for phy/gmii link mode
[    7.146659] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[   11.563847] jffs2: notice: (615) jffs2_build_xattr_subsystem: complete building xattr subsystem, 47 of xdatum (13 unchecked, 34 orphan) and 56 of xref (14 dead, 26 orphan) found.
[   11.597726] mount_root: switching to jffs2 overlay
[   11.612138] overlayfs: upper fs does not support tmpfile.
[   11.631873] urandom-seed: Seeding with /etc/urandom.seed
[   11.741263] procd: - early -
[   11.747335] procd: - watchdog -
[   12.367980] procd: - watchdog -
[   12.375413] procd: - ubus -
[   12.541616] procd: - init -
Please press Enter to activate this console.
[   13.266409] kmodloader: loading kernel modules from /etc/modules.d/*
[   13.340120] mtk-eip93 1e004000.crypto: EIP93 Crypto Engine Initialized.
[   13.723062] jitterentropy: Initialization failed with host not compliant with requirements: 9
[   13.846673] Loading modules backported from Linux version v6.12.6-0-ge9d65b48ce1a
[   13.861632] Backport generated by backports.git v6.1.110-1-35-g410656ef04d2
[   13.892514] usbcore: registered new interface driver cdc_ether
[   14.103013] pci 0000:00:00.0: enabling device (0000 -> 0003)
[   14.114366] mt7615e 0000:01:00.0: enabling device (0000 -> 0002)
[   14.137474] mt7615e 0000:01:00.0: registering led 'mt76-phy0'
[   14.238957] mt7615e 0000:01:00.0: registering led 'mt76-phy1'
[   14.265953] mt7615e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20180518100604a
[   14.265953] 
[   14.431171] urngd: v1.0.2 started.
[   14.435112] usbcore: registered new interface driver rndis_host
[   14.557578] mt7615e 0000:01:00.0: N9 Firmware Version: _reserved_, Build Time: 20200814163649
[   14.583395] mt7615e 0000:01:00.0: CR4 Firmware Version: _reserved_, Build Time: 20190415154149
[   14.970277] kmodloader: done loading kernel modules from /etc/modules.d/*
[   22.894170] mtk_soc_eth 1e100000.ethernet eth0: Link is Down
[   22.928771] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[   22.944895] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   22.956398] mt7530-mdio mdio-bus:1f lan1: configuring for phy/gmii link mode
[   22.978665] br-lan: port 1(lan1) entered blocking state
[   22.989282] br-lan: port 1(lan1) entered disabled state
[   23.000052] mt7530-mdio mdio-bus:1f lan1: entered allmulticast mode
[   23.012789] mtk_soc_eth 1e100000.ethernet eth0: entered allmulticast mode
[   23.029251] mt7530-mdio mdio-bus:1f lan1: entered promiscuous mode
[   23.070301] mt7530-mdio mdio-bus:1f lan2: configuring for phy/gmii link mode
[   23.086509] br-lan: port 2(lan2) entered blocking state
[   23.097261] br-lan: port 2(lan2) entered disabled state
[   23.107965] mt7530-mdio mdio-bus:1f lan2: entered allmulticast mode
[   23.122722] mt7530-mdio mdio-bus:1f lan2: entered promiscuous mode
[   23.148495] mt7530-mdio mdio-bus:1f lan3: configuring for phy/gmii link mode
[   23.164273] br-lan: port 3(lan3) entered blocking state
[   23.174946] br-lan: port 3(lan3) entered disabled state
[   23.185617] mt7530-mdio mdio-bus:1f lan3: entered allmulticast mode
[   23.200262] mt7530-mdio mdio-bus:1f lan3: entered promiscuous mode
[   23.228330] mt7530-mdio mdio-bus:1f lan4: configuring for phy/gmii link mode
[   23.244265] br-lan: port 4(lan4) entered blocking state
[   23.254879] br-lan: port 4(lan4) entered disabled state
[   23.265571] mt7530-mdio mdio-bus:1f lan4: entered allmulticast mode
[   23.280562] mt7530-mdio mdio-bus:1f lan4: entered promiscuous mode
[   23.315161] mtk_soc_eth 1e100000.ethernet wan: PHY [mt7530-0:04] driver [MediaTek MT7530 PHY] (irq=POLL)
[   23.334397] mtk_soc_eth 1e100000.ethernet wan: configuring for phy/rgmii link mode
[   32.673058] br-lan: port 5(phy0-ap0) entered blocking state
[   32.684263] br-lan: port 5(phy0-ap0) entered disabled state
[   32.695505] mt7615e 0000:01:00.0 phy0-ap0: entered allmulticast mode
[   32.708614] mt7615e 0000:01:00.0 phy0-ap0: entered promiscuous mode
[   32.721446] br-lan: port 5(phy0-ap0) entered blocking state
[   32.732620] br-lan: port 5(phy0-ap0) entered forwarding state
[   32.745191] br-lan: port 5(phy0-ap0) entered disabled state
[   32.769801] br-lan: port 5(phy0-ap0) entered blocking state
[   32.781000] br-lan: port 5(phy0-ap0) entered forwarding state
[   32.971233] br-lan: port 6(phy1-ap0) entered blocking state
[   32.982582] br-lan: port 6(phy1-ap0) entered disabled state
[   32.994122] mt7615e 0000:01:00.0 phy1-ap0: entered allmulticast mode
[   33.007701] mt7615e 0000:01:00.0 phy1-ap0: entered promiscuous mode
[   33.020816] br-lan: port 6(phy1-ap0) entered blocking state
[   33.032035] br-lan: port 6(phy1-ap0) entered forwarding state
output of iwinfo txpower
root@OpenWrt:~# iwinfo phy0 txpower
   0 dBm (   1 mW)
   1 dBm (   1 mW)
   2 dBm (   1 mW)
   3 dBm (   1 mW)
   4 dBm (   2 mW)
   5 dBm (   3 mW)
   6 dBm (   3 mW)
   7 dBm (   5 mW)
   8 dBm (   6 mW)
   9 dBm (   7 mW)
  10 dBm (  10 mW)
* 11 dBm (  12 mW)
root@OpenWrt:~# iwinfo phy1 txpower
   0 dBm (   1 mW)
   1 dBm (   1 mW)
   2 dBm (   1 mW)
   3 dBm (   1 mW)
   4 dBm (   2 mW)
   5 dBm (   3 mW)
   6 dBm (   3 mW)
   7 dBm (   5 mW)
*  8 dBm (   6 mW)
output of iw phy0 info
root@OpenWrt:~# iw phy0 info
Wiphy phy0
	wiphy index: 0
	max # scan SSIDs: 4
	max scan IEs length: 2304 bytes
	max # sched scan SSIDs: 0
	max # match sets: 0
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Device supports AP-side u-APSD.
	Device supports T-DLS.
	Available Antennas: TX 0x3 RX 0x3
	Configured Antennas: TX 0x3 RX 0x3
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor
		 * mesh point
		 * P2P-client
		 * P2P-GO
	Band 1:
		Capabilities: 0x1ff
			RX LDPC
			HT20/HT40
			SM Power Save disabled
			RX Greenfield
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 1-stream
			Max AMSDU length: 3839 bytes
			No DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: No restriction (0x00)
		HT TX/RX MCS rate indexes supported: 0-15
		Frequencies:
			* 2412.0 MHz [1] (11.0 dBm)
			* 2417.0 MHz [2] (11.0 dBm)
			* 2422.0 MHz [3] (11.0 dBm)
			* 2427.0 MHz [4] (11.0 dBm)
			* 2432.0 MHz [5] (11.0 dBm)
			* 2437.0 MHz [6] (11.0 dBm)
			* 2442.0 MHz [7] (11.0 dBm)
			* 2447.0 MHz [8] (11.0 dBm)
			* 2452.0 MHz [9] (11.0 dBm)
			* 2457.0 MHz [10] (11.0 dBm)
			* 2462.0 MHz [11] (11.0 dBm)
			* 2467.0 MHz [12] (11.0 dBm) (no IR)
			* 2472.0 MHz [13] (11.0 dBm) (no IR)
			* 2484.0 MHz [14] (11.0 dBm) (no IR)
	valid interface combinations:
		 * #{ IBSS } <= 1, #{ managed, AP, mesh point, P2P-client, P2P-GO } <= 16,
		   total <= 16, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 80+80 MHz, 160 MHz }

	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing
	max # scan plans: 1
	max scan plan interval: 0
	max scan plan iterations: 0
	Supported extended features:
		* [ VHT_IBSS ]: VHT-IBSS
		* [ RRM ]: RRM
		* [ MU_MIMO_AIR_SNIFFER ]: MU-MIMO sniffer
		* [ SET_SCAN_DWELL ]: scan dwell setting
		* [ FILS_STA ]: STA FILS (Fast Initial Link Setup)
		* [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
		* [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
		* [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
		* [ CAN_REPLACE_PTK0 ]: can safely replace PTK 0 when rekeying
		* [ AIRTIME_FAIRNESS ]: airtime fairness scheduling
		* [ AQL ]: Airtime Queue Limits (AQL)
		* [ CONTROL_PORT_NO_PREAUTH ]: disable pre-auth over nl80211 control port support
		* [ DEL_IBSS_STA ]: deletion of IBSS station support
		* [ SCAN_FREQ_KHZ ]: scan on kHz frequency support
		* [ CONTROL_PORT_OVER_NL80211_TX_STATUS ]: tx status for nl80211 control port support
		* [ POWERED_ADDR_CHANGE ]: can change MAC address while up
output of /proc/mtd
root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00030000 00010000 "u-boot"
mtd1: 00010000 00010000 "u-boot-env"
mtd2: 00010000 00010000 "factory"
mtd3: 00050000 00010000 "permanent_config"
mtd4: 00f60000 00010000 "firmware"
mtd5: 003072b2 00010000 "kernel"
mtd6: 00c58d4e 00010000 "rootfs"
mtd7: 00810000 00010000 "rootfs_data"

In case you want to look into the router is EEPROM/factory partition in order to analyze it, you tell me.

Update: 4/10/2025

  • Reseting openwrt into default state by reset menu in webui.
  • No more AI, sorry for my english.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Check configs dropdown in the post.

Why?

Turn your radios on (both of them) and please repost with the configs you are having trouble with.

configs update per request (click to open)
root@OpenWrt:~# ubus call system board
{
        "kernel": "6.6.73",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "Phicomm K2P",
        "board_name": "phicomm,k2p",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0",
                "revision": "r28427-6df0e3d02a",
                "target": "ramips/mt7621",
                "description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
                "builddate": "1738624177"
        }
}


root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdea:449b:1af::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'


root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '2g'
        option channel '5'
        option htmode 'HT40'
        option cell_density '0'
        option noscan '1'
        option country 'US'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
        option cell_density '0'
        option htmode 'VHT40'
        option band '5g'
        option channel 'auto'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'


root@OpenWrt:~# cat /etc/config/dhcp
config dnsmasq
        option domainneeded     1
        option boguspriv        1
        option filterwin2k      0  # enable for dial on demand
        option localise_queries 1
        option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
        option rebind_localhost 1  # enable for RBL checking and similar services
        #list rebind_domain example.lan  # whitelist RFC1918 responses for domains
        option local    '/lan/'
        option domain   'lan'
        option expandhosts      1
        option nonegcache       0
        option cachesize        1000
        option authoritative    1
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.d/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
        option nonwildcard      1 # bind to & keep track of interfaces
        #list interface         br-lan
        #list notinterface      lo
        #list bogusnxdomain     '64.94.110.11'
        option localservice     1  # disable to allow DNS requests from non-local subnets
        option ednspacket_max   1232
        option filter_aaaa      0
        option filter_a         0
        #list addnmount         /some/path # read-only mount path to expose it to dnsmasq

config dhcp lan
        option interface        lan
        option start    100
        option limit    150
        option leasetime        12h

config dhcp wan
        option interface        wan
        option ignore   1


root@OpenWrt:~# cat /etc/config/firewall
config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'
        option family 'ipv4'

config forwarding
        option src 'wan'
        option dest 'lan'
root@OpenWrt:~# iwinfo phy0 txpower
   0 dBm (   1 mW)
   1 dBm (   1 mW)
   2 dBm (   1 mW)
   3 dBm (   1 mW)
   4 dBm (   2 mW)
   5 dBm (   3 mW)
   6 dBm (   3 mW)
   7 dBm (   5 mW)
*  8 dBm (   6 mW)
root@OpenWrt:~# iwinfo phy1 txpower
   0 dBm (   1 mW)
   1 dBm (   1 mW)
   2 dBm (   1 mW)
   3 dBm (   1 mW)
   4 dBm (   2 mW)
   5 dBm (   3 mW)
   6 dBm (   3 mW)
   7 dBm (   5 mW)
*  8 dBm (   6 mW)

Why? Because I want it. (double bandwidth speed)

Flippant.

Okay:
it's illegal and we won't support it.

2 Likes

Are you connecting to the router using two radios at the same time, from one client ?

set frequency back to vht80 and set up correct country code for 5ghz band

No, only the 2.4GHz radio. I even tried to disable the 5GHz radio and only enable the 2.4GHz radio on the router, but someone above you instructed me to enable both radios on the router.

Guys, the main problem is that the most affected aspect for me is that the 2.4GHz radio can't set the maximum tx power to more than 8dBm. I don't really care if the 5GHz radio is unable to run at the same time as the 2.4GHz radio because the phones here do not have 5GHz capability.

We understand the problem as described.

We also see AI.
If your config had not been tampered with
Save, whatever this is, and go back to defaults and see what happens.

Which one?

Already done it multiple times, even switching to the SNAPSHOT build. I don't know how many erase cycles of the SPI Flash are left because of that.

Please show the boot log with default settings.

Changing settings is not going to wear that out.

Here you go
===================================================================
     		MT7621   stage1 code 10:33:55 (ASIC)
     		CPU=500000000 HZ BUS=166666666 HZ
==================================================================
Change MPLL source from XTAL to CR...
do MEMPLL setting..
MEMPLL Config : 0x11100000
3PLL mode + External loopback
=== XTAL-40Mhz === DDR-1200Mhz ===
PLL3 FB_DL: 0xa, 1/0 = 688/336 29000000
PLL4 FB_DL: 0xe, 1/0 = 601/423 39000000
PLL2 FB_DL: 0x12, 1/0 = 608/416 49000000
do DDR setting..[01F40000]
Apply DDR3 Setting...(use customer AC)
          0    8   16   24   32   40   48   56   64   72   80   88   96  104  112  120
      --------------------------------------------------------------------------------
0000:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0001:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0002:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0003:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0004:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0005:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0006:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0007:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0008:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0009:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000A:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000B:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000C:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000D:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    1
000E:|    0    0    0    0    0    0    0    0    0    1    1    1    1    1    1    1
000F:|    0    0    0    0    1    1    1    1    1    1    1    1    1    1    1    0
0010:|    1    1    1    1    1    1    1    1    1    0    0    0    0    0    0    0
0011:|    1    1    1    1    0    0    0    0    0    0    0    0    0    0    0    0
0012:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0013:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0014:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0015:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0016:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0017:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0018:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0019:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001A:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001B:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001C:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001D:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001E:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001F:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
rank 0 coarse = 15
rank 0 fine = 72
B:|    0    0    0    0    0    0    0    0    1    1    1    0    0    0    0    0
opt_dle value:9
DRAMC_R0DELDLY[018]=00001F21
==================================================================
		RX	DQS perbit delay software calibration 
==================================================================
1.0-15 bit dq delay value
==================================================================
bit|     0  1  2  3  4  5  6  7  8  9
--------------------------------------
0 |    9 7 8 10 7 6 9 6 5 7 
10 |    7 9 6 10 7 9 
--------------------------------------

==================================================================
2.dqs window
x=pass dqs delay value (min~max)center 
y=0-7bit DQ of every group
input delay:DQS0 =33 DQS1 = 31
==================================================================
bit	DQS0	 bit      DQS1
0  (1~60)30  8  (1~60)30
1  (1~60)30  9  (1~58)29
2  (1~62)31  10  (1~60)30
3  (1~65)33  11  (1~61)31
4  (1~62)31  12  (1~61)31
5  (1~62)31  13  (1~60)30
6  (1~63)32  14  (1~60)30
7  (1~63)32  15  (1~60)30
==================================================================
3.dq delay value last
==================================================================
bit|    0  1  2  3  4  5  6  7  8   9
--------------------------------------
0 |    12 10 10 10 9 8 10 7 6 9 
10 |    8 9 6 11 8 10 
==================================================================
==================================================================
     TX  perbyte calibration 
==================================================================
DQS loop = 15, cmp_err_1 = ffff0000 
dqs_perbyte_dly.last_dqsdly_pass[0]=15,  finish count=1 
dqs_perbyte_dly.last_dqsdly_pass[1]=15,  finish count=2 
DQ loop=15, cmp_err_1 = ffff0000
dqs_perbyte_dly.last_dqdly_pass[0]=15,  finish count=1 
dqs_perbyte_dly.last_dqdly_pass[1]=15,  finish count=2 
byte:0, (DQS,DQ)=(8,8)
byte:1, (DQS,DQ)=(8,8)
20,data:88
[EMI] DRAMC calibration passed

===================================================================
     		MT7621   stage1 code done 
     		CPU=500000000 HZ BUS=166666666 HZ
===================================================================


U-Boot 1.1.3 ( - )

Board: Ralink APSoC DRAM:  128 MB
uboot gpio init : WPS / RESET pin
relocate_code Pointer at: 87fa4000

Config XHCI 40M PLL 
flash manufacture id: c8, device id 40 18
find flash: GD25Q128C
ra_spi_flash_size:0x1000000
*** Warning - bad CRC, using default environment

default load_addr 0x84000000
============================================ 
Ralink UBoot Version: 5.0.0.0
-------------------------------------------- 
ASIC MT7621A DualCore (MAC to MT7530 Mode)
DRAM_CONF_FROM: Auto-Detection 
DRAM_TYPE: DDR3 
DRAM bus: 16 bit
Xtal Mode=3 OCP Ratio=1/3
Flash component: SPI Flash
Date:  Time:
============================================ 
icache: sets:256, ways:4, linesz:32 ,total:32768
dcache: sets:256, ways:4, linesz:32 ,total:32768 

 ##### The CPU freq = 880 MHZ #### 
 estimate memory size =128 Mbytes
#Reset_MT7530
set LAN/WAN LLLLW

Press press hardware button for more than 4 seconds to run web failsafe mode



Catution: hardware button wasn't pressed or not long enough!
Continuing normal boot...


Please choose the operation: 
   1: Load system code to SDRAM via TFTP. 
   2: Load system code then write to Flash via TFTP. 
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   6: Load all then write to Flash via TFTP. 
   7: Load Boot Loader code then write to Flash via Serial. 
   9: Load Boot Loader code then write to Flash via TFTP. 
default: 3

   
3: System Boot system code via Flash.
## Booting image at bc0a0000 ...
   Image Name:   MIPS OpenWrt Linux-6.6.73
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    3175026 Bytes =  3 MB
   Load Address: 80001000
   Entry Point:  80001000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80001000) ...
## Giving linux memsize in MB, 128

Starting kernel ...

[    0.000000] Linux version 6.6.73 (builder@buildhost) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 13.3.0 r28427-6df0e3d02a) 13.3.0, GNU ld (GNU Binutils) 2.42) #0 SMP Mon Feb  3 23:09:37 2025
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is Phicomm K2P
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] percpu: Embedded 12 pages/cpu s19136 r8192 d21824 u49152
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Writing ErrCtl register=00018002
[    0.000000] Readback ErrCtl register=00018002
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32480
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 117996K/131072K available (8363K kernel code, 653K rwdata, 1016K rodata, 1284K init, 229K bss, 13076K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] rcu: Hierarchical RCU implementation.
[    0.000000] 	Tracing variant of Tasks RCU enabled.
[    0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 10 jiffies.
[    0.000000] NR_IRQS: 256
[    0.000000] rcu: srcu_init: Setting srcu_struct sizes based on contention.
[    0.000000] clocksource: GIC: mask: 0xffffffffffffffff max_cycles: 0xcaf478abb4, max_idle_ns: 440795247997 ns
[    0.000004] sched_clock: 64 bits at 880MHz, resolution 1ns, wraps every 4398046511103ns
[    0.016056] Calibrating delay loop... 586.13 BogoMIPS (lpj=2930688)
[    0.088325] pid_max: default: 32768 minimum: 301
[    0.106346] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.120765] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.145046] RCU Tasks Trace: Setting shift to 2 and lim to 1 rcu_task_cb_adjust=1 rcu_task_cpu_ids=4.
[    0.163951] rcu: Hierarchical SRCU implementation.
[    0.173370] rcu: 	Max phase no-delay instances is 1000.
[    0.184560] smp: Bringing up secondary CPUs ...
[    0.194470] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.194500] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.194515] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.194563] CPU1 revision is: 0001992f (MIPS 1004Kc)
[    0.254034] Synchronize counters for CPU 1: done.
[    0.316305] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.316329] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.316341] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.316373] CPU2 revision is: 0001992f (MIPS 1004Kc)
[    0.375294] Synchronize counters for CPU 2: done.
[    0.435739] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.435762] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.435775] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.435809] CPU3 revision is: 0001992f (MIPS 1004Kc)
[    0.494888] Synchronize counters for CPU 3: done.
[    0.554495] smp: Brought up 1 node, 4 CPUs
[    0.569419] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.588922] futex hash table entries: 1024 (order: 3, 32768 bytes, linear)
[    0.606505] pinctrl core: initialized pinctrl subsystem
[    0.620023] NET: Registered PF_NETLINK/PF_ROUTE protocol family
[    0.632549] thermal_sys: Registered thermal governor 'step_wise'
[    0.634671] /pinctrl: Fixed dependency cycle(s) with /pinctrl/pinctrl0
[    0.674825] clocksource: Switched to clocksource GIC
[    0.694590] NET: Registered PF_INET protocol family
[    0.704432] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.720258] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
[    0.736790] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
[    0.752156] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.767362] TCP bind hash table entries: 1024 (order: 2, 16384 bytes, linear)
[    0.781582] TCP: Hash tables configured (established 1024 bind 1024)
[    0.795199] MPTCP token hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.809794] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.822687] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.837500] NET: Registered PF_UNIX/PF_LOCAL protocol family
[    0.848701] PCI: CLS 0 bytes, default 32
[    0.860135] workingset: timestamp_bits=14 max_order=15 bucket_order=1
[    0.874033] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.885529] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.910978] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
[    0.929155] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.940675] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.952171] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.963777] mt7621-pci 1e140000.pcie: host bridge /pcie@1e140000 ranges:
[    0.977025] mt7621-pci 1e140000.pcie:   No bus range found for /pcie@1e140000, using [bus 00-ff]
[    0.994490] mt7621-pci 1e140000.pcie:      MEM 0x0060000000..0x006fffffff -> 0x0060000000
[    1.010726] mt7621-pci 1e140000.pcie:       IO 0x001e160000..0x001e16ffff -> 0x0000000000
[    1.384815] mt7621-pci 1e140000.pcie: pcie1 no card, disable it (RST & CLK)
[    1.398602] mt7621-pci 1e140000.pcie: pcie2 no card, disable it (RST & CLK)
[    1.412400] mt7621-pci 1e140000.pcie: PCIE0 enabled
[    1.422246] PCI coherence region base: 0x60000000, mask/settings: 0xf0000002
[    1.436380] mt7621-pci 1e140000.pcie: PCI host bridge to bus 0000:00
[    1.448945] pci_bus 0000:00: root bus resource [bus 00-ff]
[    1.459786] pci_bus 0000:00: root bus resource [mem 0x60000000-0x6fffffff]
[    1.473432] pci_bus 0000:00: root bus resource [io  0x0000-0xffff]
[    1.485773] pci 0000:00:00.0: [0e8d:0801] type 01 class 0x060400
[    1.497645] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.510083] pci 0000:00:00.0: reg 0x14: [mem 0x00000000-0x0000ffff]
[    1.522631] pci 0000:00:00.0: supports D1
[    1.530477] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    1.543792] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    1.559948] pci 0000:01:00.0: [14c3:7615] type 00 class 0x000280
[    1.571877] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit]
[    1.585452] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    1.615258] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
[    1.625590] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.637638] pci 0000:00:00.0:   bridge window [mem 0x00000000-0x000fffff]
[    1.651116] pci 0000:00:00.0:   bridge window [mem 0x00000000-0x000fffff pref]
[    1.665464] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    1.678636] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    1.691734] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    1.705559] pci 0000:00:00.0: BAR 8: assigned [mem 0x60000000-0x600fffff]
[    1.719029] pci 0000:00:00.0: BAR 9: assigned [mem 0x60100000-0x601fffff pref]
[    1.733370] pci 0000:00:00.0: BAR 1: assigned [mem 0x60200000-0x6020ffff]
[    1.746868] pci 0000:00:00.0: BAR 7: assigned [io  0x0000-0x0fff]
[    1.758958] pci 0000:01:00.0: BAR 0: assigned [mem 0x60000000-0x600fffff 64bit]
[    1.773473] pci 0000:00:00.0: PCI bridge to [bus 01]
[    1.783308] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.795405] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    1.808893] pci 0000:00:00.0:   bridge window [mem 0x60100000-0x601fffff pref]
[    1.823226] pci_bus 0000:00: Some PCI device resources are unassigned, try booting with pci=realloc
[    1.841196] pci_bus 0000:00: resource 4 [mem 0x60000000-0x6fffffff]
[    1.853635] pci_bus 0000:00: resource 5 [io  0x0000-0xffff]
[    1.864694] pci_bus 0000:01: resource 0 [io  0x0000-0x0fff]
[    1.875765] pci_bus 0000:01: resource 1 [mem 0x60000000-0x600fffff]
[    1.888197] pci_bus 0000:01: resource 2 [mem 0x60100000-0x601fffff pref]
[    1.903181] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    1.925124] printk: console [ttyS0] disabled
[    1.934341] 1e000c00.uartlite: ttyS0 at MMIO 0x1e000c00 (irq = 18, base_baud = 3125000) is a 16550A
[    1.952353] printk: console [ttyS0] enabled
[    1.952353] printk: console [ttyS0] enabled
[    1.968889] printk: bootconsole [early0] disabled
[    1.968889] printk: bootconsole [early0] disabled
[    1.992773] spi-mt7621 1e000b00.spi: sys_freq: 220000000
[    2.004973] spi-nor spi0.0: gd25q128 (16384 Kbytes)
[    2.014905] 5 fixed-partitions partitions found on MTD device spi0.0
[    2.027613] OF: Bad cell count for /palmbus@1e000000/spi@b00/flash@0/partitions
[    2.042206] OF: Bad cell count for /palmbus@1e000000/spi@b00/flash@0/partitions
[    2.057153] Creating 5 MTD partitions on "spi0.0":
[    2.066747] 0x000000000000-0x000000030000 : "u-boot"
[    2.078446] 0x000000030000-0x000000040000 : "u-boot-env"
[    2.090478] 0x000000040000-0x000000050000 : "factory"
[    2.102068] OF: Bad cell count for /palmbus@1e000000/spi@b00/flash@0/partitions
[    2.117174] 0x000000050000-0x0000000a0000 : "permanent_config"
[    2.130052] 0x0000000a0000-0x000001000000 : "firmware"
[    2.142008] 2 uimage-fw partitions found on MTD device firmware
[    2.153899] Creating 2 MTD partitions on "firmware":
[    2.163806] 0x000000000000-0x0000003072b2 : "kernel"
[    2.173698] mtd: partition "kernel" doesn't end on an erase/write block -- force read-only
[    2.191529] 0x0000003072b2-0x000000f60000 : "rootfs"
[    2.201487] mtd: partition "rootfs" doesn't start on an erase/write block boundary -- force read-only
[    2.220956] mtd: setting mtd6 (rootfs) as root device
[    2.231154] 1 squashfs-split partitions found on MTD device rootfs
[    2.243535] 0x000000750000-0x000000f60000 : "rootfs_data"
[    2.398179] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    2.420186] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 19
[    2.439828] mtk_soc_eth 1e100000.ethernet eth1: mediatek frame engine at 0xbe100000, irq 19
[    2.458182] i2c_dev: i2c /dev entries driver
[    2.470857] NET: Registered PF_INET6 protocol family
[    2.483864] Segment Routing with IPv6
[    2.491359] In-situ OAM (IOAM) with IPv6
[    2.499356] NET: Registered PF_PACKET protocol family
[    2.509562] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    2.535970] 8021q: 802.1Q VLAN Support v1.8
[    2.577145] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    2.617462] mt7530-mdio mdio-bus:1f: configuring for fixed/rgmii link mode
[    2.632636] mt7530-mdio mdio-bus:1f lan1 (uninitialized): PHY [mt7530-0:00] driver [MediaTek MT7530 PHY] (irq=21)
[    2.655803] mt7530-mdio mdio-bus:1f: Link is Up - 1Gbps/Full - flow control rx/tx
[    2.665849] mt7530-mdio mdio-bus:1f lan2 (uninitialized): PHY [mt7530-0:01] driver [MediaTek MT7530 PHY] (irq=22)
[    2.694007] mt7530-mdio mdio-bus:1f lan3 (uninitialized): PHY [mt7530-0:02] driver [MediaTek MT7530 PHY] (irq=23)
[    2.717326] mt7530-mdio mdio-bus:1f lan4 (uninitialized): PHY [mt7530-0:03] driver [MediaTek MT7530 PHY] (irq=24)
[    2.740281] mtk_soc_eth 1e100000.ethernet eth0: entered promiscuous mode
[    2.753827] DSA: tree 0 setup
[    2.760698] clk: Disabling unused clocks
[    2.774253] VFS: Mounted root (squashfs filesystem) readonly on device 31:6.
[    2.792276] Freeing unused kernel image (initmem) memory: 1284K
[    2.804134] This architecture does not have kernel memory protection.
[    2.816990] Run /sbin/init as init process
[    3.295033] init: Console is alive
[    3.302128] init: - watchdog -
[    4.162331] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.233094] usbcore: registered new interface driver usbfs
[    4.244266] usbcore: registered new interface driver hub
[    4.255042] usbcore: registered new device driver usb
[    4.266838] gpio_button_hotplug: loading out-of-tree module taints kernel.
[    4.291299] xhci-mtk 1e1c0000.xhci: supply vbus not found, using dummy regulator
[    4.306510] xhci-mtk 1e1c0000.xhci: supply vusb33 not found, using dummy regulator
[    4.322208] xhci-mtk 1e1c0000.xhci: xHCI Host Controller
[    4.332911] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 1
[    4.352971] xhci-mtk 1e1c0000.xhci: hcc params 0x01401198 hci version 0x96 quirks 0x0000000000280010
[    4.371289] xhci-mtk 1e1c0000.xhci: irq 26, io mem 0x1e1c0000
[    4.383024] xhci-mtk 1e1c0000.xhci: xHCI Host Controller
[    4.393656] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 2
[    4.408594] xhci-mtk 1e1c0000.xhci: Host supports USB 3.0 SuperSpeed
[    4.422559] hub 1-0:1.0: USB hub found
[    4.430205] hub 1-0:1.0: 2 ports detected
[    4.439470] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[    4.456867] hub 2-0:1.0: USB hub found
[    4.464489] hub 2-0:1.0: 1 port detected
[    4.481462] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.502729] init: - preinit -
[    5.263066] mtk_soc_eth 1e100000.ethernet wan: renamed from eth1
[    6.764826] random: crng init done
[    7.203964] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[    7.224329] mt7530-mdio mdio-bus:1f lan1: configuring for phy/gmii link mode
[    7.238538] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[   11.669818] jffs2: notice: (619) jffs2_build_xattr_subsystem: complete building xattr subsystem, 43 of xdatum (0 unchecked, 30 orphan) and 52 of xref (10 dead, 26 orphan) found.
[   11.703472] mount_root: switching to jffs2 overlay
[   11.719449] overlayfs: upper fs does not support tmpfile.
[   11.767224] urandom-seed: Seeding with /etc/urandom.seed
[   11.876833] procd: - early -
[   11.882792] procd: - watchdog -
[   12.498545] procd: - watchdog -
[   12.505954] procd: - ubus -
[   12.670616] procd: - init -
Please press Enter to activate this console.
[   13.399947] kmodloader: loading kernel modules from /etc/modules.d/*
[   13.473351] mtk-eip93 1e004000.crypto: EIP93 Crypto Engine Initialized.
[   13.859370] jitterentropy: Initialization failed with host not compliant with requirements: 9
[   13.996770] Loading modules backported from Linux version v6.12.6-0-ge9d65b48ce1a
[   14.011722] Backport generated by backports.git v6.1.110-1-35-g410656ef04d2
[   14.042473] usbcore: registered new interface driver cdc_ether
[   14.249066] pci 0000:00:00.0: enabling device (0000 -> 0003)
[   14.260418] mt7615e 0000:01:00.0: enabling device (0000 -> 0002)
[   14.283417] mt7615e 0000:01:00.0: registering led 'mt76-phy0'
[   14.349022] mt7615e 0000:01:00.0: registering led 'mt76-phy1'
[   14.376299] mt7615e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20180518100604a
[   14.376299] 
[   14.548339] urngd: v1.0.2 started.
[   14.607840] usbcore: registered new interface driver rndis_host
[   14.643914] mt7615e 0000:01:00.0: N9 Firmware Version: _reserved_, Build Time: 20200814163649
[   14.669780] mt7615e 0000:01:00.0: CR4 Firmware Version: _reserved_, Build Time: 20190415154149
[   15.164674] kmodloader: done loading kernel modules from /etc/modules.d/*
[   23.531418] mtk_soc_eth 1e100000.ethernet eth0: Link is Down
[   23.570486] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[   23.586642] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   23.592034] mt7530-mdio mdio-bus:1f lan1: configuring for phy/gmii link mode
[   23.622009] br-lan: port 1(lan1) entered blocking state
[   23.632660] br-lan: port 1(lan1) entered disabled state
[   23.643440] mt7530-mdio mdio-bus:1f lan1: entered allmulticast mode
[   23.656070] mtk_soc_eth 1e100000.ethernet eth0: entered allmulticast mode
[   23.672335] mt7530-mdio mdio-bus:1f lan1: entered promiscuous mode
[   23.708922] mt7530-mdio mdio-bus:1f lan2: configuring for phy/gmii link mode
[   23.724955] br-lan: port 2(lan2) entered blocking state
[   23.735496] br-lan: port 2(lan2) entered disabled state
[   23.746093] mt7530-mdio mdio-bus:1f lan2: entered allmulticast mode
[   23.760560] mt7530-mdio mdio-bus:1f lan2: entered promiscuous mode
[   23.787098] mt7530-mdio mdio-bus:1f lan3: configuring for phy/gmii link mode
[   23.803305] br-lan: port 3(lan3) entered blocking state
[   23.813956] br-lan: port 3(lan3) entered disabled state
[   23.824709] mt7530-mdio mdio-bus:1f lan3: entered allmulticast mode
[   23.839464] mt7530-mdio mdio-bus:1f lan3: entered promiscuous mode
[   23.867361] mt7530-mdio mdio-bus:1f lan4: configuring for phy/gmii link mode
[   23.883189] br-lan: port 4(lan4) entered blocking state
[   23.893894] br-lan: port 4(lan4) entered disabled state
[   23.904568] mt7530-mdio mdio-bus:1f lan4: entered allmulticast mode
[   23.919511] mt7530-mdio mdio-bus:1f lan4: entered promiscuous mode
[   23.953357] mtk_soc_eth 1e100000.ethernet wan: PHY [mt7530-0:04] driver [MediaTek MT7530 PHY] (irq=POLL)
[   23.972377] mtk_soc_eth 1e100000.ethernet wan: configuring for phy/rgmii link mode
[   27.095074] mtk_soc_eth 1e100000.ethernet wan: Link is Up - 1Gbps/Full - flow control off
[   32.755407] br-lan: port 5(phy0-ap0) entered blocking state
[   32.766577] br-lan: port 5(phy0-ap0) entered disabled state
[   32.777852] mt7615e 0000:01:00.0 phy0-ap0: entered allmulticast mode
[   32.790979] mt7615e 0000:01:00.0 phy0-ap0: entered promiscuous mode
[   32.828098] br-lan: port 5(phy0-ap0) entered blocking state
[   32.839377] br-lan: port 5(phy0-ap0) entered forwarding state
[   33.092243] br-lan: port 6(phy1-ap0) entered blocking state
[   33.103542] br-lan: port 6(phy1-ap0) entered disabled state
[   33.114981] mt7615e 0000:01:00.0 phy1-ap0: entered allmulticast mode
[   33.128664] mt7615e 0000:01:00.0 phy1-ap0: entered promiscuous mode
[   33.141913] br-lan: port 6(phy1-ap0) entered blocking state
[   33.153210] br-lan: port 6(phy1-ap0) entered forwarding state


Changing firmware does.

Something is going sideways.
Beyond my skills.

1 Like

Stop using AI to process your posts. Nothing to hide between 4 possible device firmwares.


What's up with the community here? These people are cornering me about AI, the censored/hide log information and all that... They just jump right in and attack me so easily.

First, I only use AI for grammar correction because English isn't my first language and I'm living in a third-world country. Should I use my FIRST LANGUAGE here??? Ofcourse, its against the rule isn't?

Second, I don’t paste any logs or OpenWRT config into AI while I’m fixing my grammar.

Third, the logs I provided are exactly as they are, not edited or touched by AI or me manually.

Fourth, at first, I did share the download link for my EEPROM/Factory Partition file in case anyone wanted to look into my issue about txpower, but it got edited with words that put me in a bad light. I was just sending that file for review, not to trap anyone or anything bad.

Fifth, I’ve really tried to keep a good attitude from the start, even going along with what they say, even though they don’t explain why I should follow them."


I wish those words above won't get me muted or banned.

We need to see it raw.

We 'see' AI. Not worth arguing; see above.

Clean it up, see what happens.
Seriously:
Clean it up, then try it.
Then post, if you still have problems, you have cleaned it up (clean boot) and the configs.

We don't really care how it got messed up; it's messed up.

1 Like

Switching to the OpenWrt fork seems to fix it. Although there are a lot of bloatware or pre-installed packages that I don't need.