Pfsense, VLAN and MESH

Hello guys!

I decided to flash my Deco M4r with openwrt and it have been absolutly worth it so good job too all of you guys involved!

I have a small issue with my setup and I would like to see if someone could help me out, the problem I have is that I can't get the VLAN tags in my MESH on the second node. I have worked and tried to solve this issue for 7 days now and think it's time to see if there is someone out there who could push me in the right direction :smiley:

My setup is like this:
Pfsense - who owns all my networks and VLANs and act as a firewall.
Managed switch - tagged VLAN 55, 68 and 69 to my main Deco M4r.
Two Deco M4r - 1 master and the second one act as a dumb AP.

On the master node I have managed to create different interfaces for each VLAN with bridged devices who get the proper VLAN from the "Internal switch" in OpenWrt where I have tagged the 3 different VLANs. so each bridged-device has a birdged port named as eth0.55, eth068 and eth0.69.

When I create different wireless networks with the different interfaces - everything works as a charm, and I get correct IP-addresses who are owned and managed by pfsense.

I have followed OneMarcFiftys instructions on youyube to create Mesh and it works and connects good. The problem is that I can't get the VLANs on the second AP. I have tried Batman-protocol and GRE and always same problem, I never get correct IP or I get a 169 address and nothing works :smiley:

Is there a soul out there who have managed to make the MESH work with proper VLANs who are owned by pfsense or something else and make the VLAN tagging work proper on the second node who serve as an AP?

I'm really sorry if this has been discussed somewhere else but I have really tired to find some help but all the ways lead to working setup when VLAN is owned by openWrt and that seem to not work 100% with my problem and setup.

Best regards!

Please get some info from the "complex configuration" deco - obviously type over secrets, mac addresses, public IPs.

ubus call system board
cat /etc/config/network
cat /etc/config/firewall
cat /etc/config/wireless # and from other device the part connecting this one
cat /etc/config/dhcp

Mark where pfsense is connected and where the other deco.

Thank you for your reply, here you got the configs. Pfsense is connected to Deco-master eth0 and the second Deco is only connected to my master-deco using Mesh.

ubus call system board

{
	"kernel": "5.15.167",
	"hostname": "Master-Kallare",
	"system": "Qualcomm Atheros QCA956X ver 1 rev 0",
	"model": "TP-Link Deco M4R v1",
	"board_name": "tplink,deco-m4r-v1",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.5",
		"revision": "r24106-10cc5fcd00",
		"target": "ath79/generic",
		"description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
	}
}

cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd3a:6788:2230::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1' -- pfsense is connected to eth0

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.9'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.1' -- this is pfsense address
	list dns '91.231.153.2'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 3 5'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 3t'
	option vid '55'
	option description 'IOT'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '0t 3t'
	option vid '68'
	option description 'HOME'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '0t 3t'
	option vid '69'
	option description 'Work'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '99'
	option description 'MainPC'

config device
	option type 'bridge'
	option name 'br-Work'
	list ports 'eth0.69'

config device
	option type 'bridge'
	option name 'br-IOT'
	list ports 'eth0.55'

config device
	option type 'bridge'
	option name 'br-home'
	list ports 'eth0.68'
	list ports '@trunk.68'

config interface 'IOT'
	option proto 'dhcp'
	option device 'br-IOT'

config interface 'Work'
	option proto 'dhcp'
	option device 'br-Work'

config interface 'Home'
	option proto 'dhcp'
	option device 'br-home'

config interface 'trunk'
	option proto 'gretap'
	option force_link '1'
	option peeraddr '192.168.1.7'
	option ipaddr '192.168.1.9'
	option tunlink 'Work'
	option defaultroute '0'
	list dns '91.231.153.2'
	option df '0'

cat /etc/config/firewall

config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

cat /etc/config/wireless
Master-node

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option channel '40'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-iface 'wifinet1' -- connection to other Deco only through mesh
	option device 'radio0'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'mesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key 'XXXXX'
	option network 'lan'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'My_Place-new'
	option encryption 'sae'
	option key 'XXXXXXXX'
	option ieee80211r '1'
	option mobility_domain '1fa1'
	option ft_over_ds '0'
	option network 'Home'

cat /etc/config/wireless
Second node - dump AP

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option channel '40'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'sae'
	option key 'XXXXXXX'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'mesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key 'XXXXXXX'
	option network 'lan'

cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'
1 Like

Thats how ideal setup looks
Small asjustment to dhcp conf

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '10000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option ednspacket_max '1232'
        option queryport '0'
        option max_cache_ttl '86400'
        option noresolv '1'
+#optional if you ever install updates with pfsense out
+        list server '1.1.1.2'
+        list server '1.0.0.2'
+# disable dns server on network interfaces
+        list interface 'loopback'

I have managed to get correct IP through the MESH to the second AP. The struggle I get into now is that when my device is connected on the wireless on the dumb AP i don't have any internet access, and when I move closer to the master-Deco I have internet access again. Is there someone out there who might know what I have screwed up now and would need some configs from me? :smiley: