Personal findings with Archer C6 v2

Hello,
I got my hands on an Archer C6 v2 router from a guy that bricked it. Before getting it i referenced the wiki article https://openwrt.org/toh/tp-link/archer_c6_v2

I would like to point out my findings with this router, and if they are confirmed, someone please edit the wiki:

1. For me, tftp recovery worked straight from the network card, without needing a 10/100 network switch. At least on an older Lenovo T400 which has a gigabit network card.
Apparently the reason why the connection drops before the transfer also has to do with software, more exactly the modern network manager services.
The linux distro on my laptop, Artix LXDE, has "Connman" as the network manager, which allows for the same easy configuration of network without needing advanced scripts, but who still seems to respect old standards used by tftp/dnsmasq. It doesn't fail on missing connection immediately.
To sum up, you need a combination of a linux distro with network manager such as Connman (or Netifrc if you know scripts), and maybe a slightly older network card, but otherwise nothing legacy.

2. 5GHz wifi is perfectly stable on N mode. I have over a week of uptime, 0ms latency, stable 200+mb/s speed and decent range. The problems are only in AC mode.

3. Speed on PPPoE is ~650mbps if you activate software offloading, hardware offloading doesn't work (yet?)

PS: new user here, sorry in advance if i post in the wrong place, but the other threads with this router were closed.

thanks for sharing your findings, @Hitman47. I can update the device wiki but I'm not entirely sure what you're suggesting to change. see below.

this is interesting but seems to be a very specific case. what are you suggesting to change in the device's Flash using TFTP recovery procedure specifically?

which wireless interface mode (access point, client, monitoring, etc.) did you test and what is the issue with the radio's AC mode specifically? see (and post) the log messages related to the AC issues (logread or via LuCI).

in addition, please share your model version (US vs. EU, RU) and OpenWrt version.

Even though it worked for you, it's recommended to use an unmanaged switch between the router and the computer.

It avoids the link-down event, and link training.

Hardware flow offloading is currently supported for mt7621 devices only.

I'm using EU/RU/JP version of the router.
Just tested the wireless now again, it seems that with the new version of hostapd the wifi AC is now stable (and in 22.0.3-rc1, but i had to return because of bugs), but the speed is limited to ~250 mbps up and down.
On N it is ~210 mbps up and down which is pretty much as high as that standard would go.
The range is good on any device, old and new. On channels above 52 the tx power is limited to 20 dbm but the range is still decent through 2 walls. This i would like to be modified in the wiki.

About the tftp recovery process, as OldNavyGuy said it would be risky because of the link-down event?
So i would not suggest anything unless this sort of phrase will sound catchy: "Some users have managed to tftp straight from the network card in some slightly older Intel/Realtek network cards and some more exotic Linux distros such as Artix, Devuan, etc (if advertising policy allows for it, of course)"

Never said it would be "risky".

I said it is "recommended" to use an unmanaged switch, to avoid the link-down event and link training.

My english is pretty bad, sorry, i meant if that event would be risky e.g. during transfer or something.
All right, then i would like my other suggestion to be considered too.