Permission denied on first SSH from Raspberry Pi 4

Hi there,

I'm using a fresh Raspberry Pi 4 and just installed OpenWrt in the SD card with the corresponding image file. I'm trying to ssh into OpenWrt for the first time using ssh root@192.168.1.1

I was able to see this part

$ ssh root@192.168.1.1
The authenticity of host '192.168.1.1 (192.168.1.1)' can't be established.
RSA key fingerprint is SHA256:4VbDA/MOc7inPiyllF5f0r3Q6iEx89ddKdhLGBovsiY.
Are you sure you want to continue connecting (yes/no)? yes   
Warning: Permanently added '192.168.1.1' (RSA) to the list of known hosts.

However, the next prompt is

root@192.168.1.1's password:

In the documentation, it says to just press return if this is the initial set up. So I did, but I kept getting
"Permission denied. please try again" message. I've never got logged into it before and have never set the password.

However, if I ping 192.168.1.1. It listens. (Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)) But if I tried to get into 192.168.1.1 in a web browser, it keeps loading but nothing comes up. Not even a message saying connection refused or took too long to respond. It just keep loading but nothing displays.

Would you advise? Thank you in advance for any help and ideas on how to proceed.

Are you certain that 192.168.1.1 is your Pi and only your Pi? It is entirely possible you are connecting to your main router and not the Pi.

Make sure you connect via ethernet between your computer and your pi and unplug/disable any other network connections (including wifi) that the computer is using.

If my original thought was right, now you may get an error that the RSA fingerprint has changed -- if so, you'll need to remove the existing fingerprint entry... on a Mac, the command is:

ssh-keygen -R 192.168.1.1
1 Like

Hi psherman,

Thank you for your idea. However, I was able to fix this issue by

  1. I was configuring IPv4 in Windows 10 way. I currently have Windows 11 so I re-configured the IPv4 using Windows 11 way.
  2. Reinstalling OpenWrt in SD card
  3. Restarting the Pi

I'm not sure which of the 3 really fixed the issue but I'm just so glad that I got it fixed! Just wanted to share this news with you :stuck_out_tongue_closed_eyes: Hope you have a wonderful weekend. Thank you for stopping by and spend a little time with me.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.