Performance of UniFi nanoHD

For those who actually got this to work, what is the performance like?

I'm finding official firmware has have gotten slower and slower as they "upgraded" the firmware so am seriously considering this now.

1 Like

I'm interested too. Even when I think I cannot install OpenWrt in my NanoHDs. I tried a month ago and I couldn't probably because of their U-Boot version.

1 Like

I did the following:

Made sure I had ssh login enabled to the nanohd.
I had restored to factory settings so using ubnt login credentials but this should not be necessary.

Download https://dl.ubnt.com/unifi/firmware/U7NHD/3.9.27.8537/BZ.mt7621.v3.9.27.8537.180317.1220.bin and scp it to the nanoHD.

scp BZ.mt7621.v3.9.27.8537.180317.1220.bin ubnt@nanoipaddress:/tmp/

Downgrade the nanoHD:

ssh ubnt@nanoipaddress
cd /tmp
fwupdate.real -m BZ.mt7621.v3.9.27.8537.180317.1220.bin

The nanoHD rebooted.

Download OpenWRT and scp to the nanoHD:

scp openwrt-21.02.0-ramips-mt7621-ubnt_unifi-nanohd-squashfs-sysupgrade.bin ubnt@nanohdipaddress:/tmp/

Write the bootselect flag. Otherwise, the device might boot from the wrong partition. Verify the mtd partition used in the command below
is the one labled "bs" in /proc/mtd (as this might change in the future).

dd if=/dev/zero bs=1 count=1 of=/dev/mtd4

Write the OpenWrt sysupgrade to the mtd partitions labeled "kernel0" and "kernel1" then reboot the nanoHD.

dd if=/tmp/openwrt-21.02.0-ramips-mt7621-ubnt_unifi-nanohd-squashfs-sysupgrade.bin of=/dev/mtdblock6
dd if=/tmp/openwrt-21.02.0-ramips-mt7621-ubnt_unifi-nanohd-squashfs-sysupgrade.bin of=/dev/mtdblock7
reboot

Set my local ip to something in 192.168.1.x, but not 192.168.1.1, and ssh root@192.168.1.1, and change the ip in /etc/config/network to what I want it to be, and reboot.


Speed seems okay on 80Mhz but I'm having some issues with DFS channels, specifically 160Mhz wont work at all. I'm seeing 62-72MB/s copying from my NAS and it seems to authenticate with the access point much faster than stock firmware. I also seem to get a higher link rate further away from the AP.

If you're fine with channel 36 or 52, its working fine there. It feels more responsive than stock firmware to me. I had no idea the nanoHD was a quad-core CPU, never seen LuCI this fast.

This is where my installation fails, probably due to the fact that the lower version that's allowed to be installed: "required_version": "4.3.16",

Oh, well, I'm not sure what to do next. :wink:

Yeah that's a weird one as some people have successfully done it to brand new units, I can only guess they must have old stock.

I think its extremely scummy of a company to block downgrades, it should always be the end users choice unless it legitimately cannot run due to hardware changes and those hardware changes had better make the product BETTER not worse too.

I'm really thankful it worked for me as even if its slower than I could get on stock firmware, I just don't want to deal with the bloated Unifi Controller. I've always found OpenWRT rock-solid stable and easy to use.

I'm using OpenWRT on my NanoHD and performance is pretty bad to be honest.

3 Likes

Are you using 80Mhz channel width?