Performance of QMI vs Serial for Quectel EC25?

Actually I am using a Quectel EC25, as 3g-wwan, Serial. Would QMI give a significant performance boost ?
Practical experience preferred, cause I know from past, that correct configuration of QMI was (still is ?) similar to Black Magic. Besides sporadic disconnects, whereas "Legacy Technology" like Serial simply works.

Using ppp between modem and host means that both have to do hdlc framing, including escaping and unescaping of unwanted frame markers. This isn't much job for a powerful pc, but it will be noticeable of a low end host like most openwrt systems. And it's even worse for the modem, which is highly optimized to move packets between radio interface and USB without involving the application cpu at all.


hello I have two module quectel cat4 and cat12 using QMI mode. My router is Openwrt and always i have the same problem, constantly disconnects. I dont know how to solve this problem. However my old LTE modem using serial connection works perfect.

How can I connect my EC25 using serial modem in openwrt ?

You do not need the modeswitching stuff for the EC25. Not shure, whether you will need some AT-cmd to switch (back) from QMI. I did not need something like that for factory-new EC25, though.

hello I tried to use the modem like my old serial usb stick modem lte but was imposible. And right now my modem quectel died after I send an at command

it was not a good idea. Bad tech

Sorry to hear. I am using the EC25 in various projects, always PPP only, no problem at all.
BTW, I can not find "usbnet=..." in Rev. EC25&EC21_AT_Commands_Manual_V1.2
Date: 2017-11-14

Using most recent firmware for the modem is always a good idea.

May be, AT&F0 might work, to reset to factory default values.

Or to do a hardware reset of the modem.

the modem doesnt respond to AT command.

check the document Quectel_WCDMA&LTE_Linux_USB_Driver_User_Guide_V1.9_Preliminary_20190325

how you connect to PPP. Also I cant. When the modem works, appears ttyUSB0 ttyUSB1 ttyUSB2 ttyUSB3 and the PPP never worked. Now the modem is dead, only appears ttyUSB0, ttyUSB1

Looks like user xtrem set up the EC25 as MBIM&ECM (usbnet,3) . Which needs special driver(s). So his problem was NOT openwrt related, and NOT a modem issue. He simply did not know, what he did, so he has to blame himself, not to fingerpoint somewhere else. Sorry, to say.

1 Like

Yes it looks like that "simple command" did exactly what it was supposed to do, which is to change the modem to a different API than 'AT' commands.

according to my records, for EC25 "3" means RNDIS

1 Like

That would be good, as RNDIS is simple to use on OpenWrt. Install kmod-usb-net-rndis and a new virtual Ethernet-like interface (usually usb0) should be created.

I found the hidden driver for RNDIS from quectel. I solved the problem.

This is my actual state:


+QCFG: "usbnet",0



So how can I use the module without QMI or Gobinet, using the typical connection of old modems ("usb serial option")






1 Like

I did it and it doesn't work, I attached the log.

Okay now I am happy.
Finally it works after I used a second APN of the ISP. I dont know why but using the first APN of ISP was not possible to use ppp connection.


thanks for your help LOL

And how does the performance compare? The common thinking is that ppp needs a lot of router CPU time compared to later protocols.

Hi. I dont know. I read what you commented in a quectel guide. However my problem with quectel modules are the next

Often the connection is lost for a long time

if I use the same sim card in my old ZTE MF823 modem, the situation is better

Maybe the problem also is my router with openwrt from ZBT company, where the ttyUSB2 port is always asking for 4gInfo (signal,bands, imei, etc) each 5 seconds. So when I tried to use the serial connection ttyUSB2, it never works. Also if I reboot my router after I deleted or changed the interface, the firmware openwrt of the router change/create the interface to QMI always. The same happen when I set the mode of the network card to ECM, AT+QCFG="usbnet",1 -> disconnect power supply -> AT+QCFG="usbnet",0 (it is set to 0 automatically always after the boot)

I give up (ZBT company says it is not possible use ppp connection)