PD on LEDE behind cable modem


I tried for some time to get Prefix Delegation working, but I'm pretty clueless. I did try NAT for IPv6, it works for most IPv6 things, but isn't exactly what I want.


  • latest LEDE stable (tho I did test nightly as well)
  • Edit: I only setup Wifi (ESSID and password) and every other setting is untouched if not noted otherwise
  • behind cable modem/router from Kabel Deutschland
  • DS-Lite
  • DHCPv6 (see Attempts)


  • IPv4 fully working (not reachable from outside ofc)
  • LEDE router WAN gets an IPv6 (without PD it seems)
  • LEDE LAN interface doesn't get an outside IPv6 (internal IPv6 ist working)
  • no client of LEDE router gets an IPv6


  • changed MAC of WAN (workaround to get a new prefix usually)
  • tried DS-Lite protocol (not sure if correctly setup, I used the AFTR that is listed in the modem/router)
  • set modem/router to bridging mode (no IPv6 working whatsoever)
  • several different prefix masks, try/force, ipv6-hinting and such

Note: PD should actually work for my provider as I saw several posts that where saying they only got a 64-bit prefix, but I get none if I'm not mistaken. I will test another non-LEDE router when I get my hand on it, just to be save on that one.

Kind regards,


I never found an answer to this particular question and now I can give it myself. My provider does indeed support prefix delegation however their basic router does not. You have to pay them either 2€/5€ per month or buy yourself a 130€+ cable modem/router from AVM.

It is not possible to use prefix delegation for Kabel Deutschland otherwise as of yet. Maybe cheaper cable modem/router come available that work with them, but don't bet on it.

However you can get a real IPv4 (unNATed) from provider when you set the modem to bridging mode. You can do that by going into their account settings. It's German anyway, so here are the German entries:
In account settings
-> "Einstellungen"
-> "Interneteinstellungen"
-> "Bridge Mode anpassen"
-> answer 3 questions with no
-> "Bridge mode" "einschalten"

Sorry to bother you with a problem that was in the end not related to LEDE. My very first thought it was related to my provider, but after reading that some got a prefix I was stumped, not realizing they used a different router/modem.

Kind regards,


Generally, you want to avoid two routers working in routing mode and put your modem into bridge mode (as you've now done), otherwise you've got double NAT which is never good.

We're speaking of IPv6 so none of the routers should NAT6 or is set up to do that (the provider one can't actually). The only thing they do is negotiate the prefix and in the end the /128 address. But because the modem/router from the provider doesn't do prefix delegation I'm out of luck there and thought there was a way without PD and NAT6, but there seem to be none.

In the case of IPv4 the situation is actually already a double NAT from the getgo because my provider does DS-Lite. So attaching my router is triple NAT then :stuck_out_tongue:

I thought IPv4 was lost ground anyway, because it is not reachable from the outside by definition (DS-Lite). And my router got an IPv6 from the provider, but no prefix, so the clients got no IPv6 from the provider (internally IPv6 works, but that doesn't do much here).

That the bridge mode gets you a fresh IPv4 is actually non-obvious and the fact that you do not get an IPv6 is just weird.