PC Engines APU2 D4 and OpenWrt

Hi

I have a PC Engines APU1 and this is my network file.
I have my wan interface on eth0 and my lan interfaces on eth1 and eth2. I just have three intefaces.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd99:369d:09ed::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1 eth2'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth0'

Thanks.

I have done it in the same way as in your post.

Now I am able to access the console through CLI by connecting through eth1 but I couldnt access the console through browser.

If I want to do factory reset is it possible? I tried firstboot but it says

MTD partition 'rootfs_data' not found

What happens when you restart your router?
Can you past the boot log and your network config?

Since you already have IP connectivity with the box, you can copy the current sysupgrade image to /tmp using scp anf then run sysupgrade to re-install everything.

1 Like

How to do this?

I have this image downloaded. openwrt-19.07.5-x86-64-combined-ext4.img

To copy this I have to do it through winscp or putty?

I was able to access the console page. But I am not able to connect to internet. From console if I run diagnosis its working from fine. And to access the console page I have to directly connect through ethernet port in router itself. I am not able to connect through any switches or AP.

Dont know what is happening. Now I reverted back to my old router.

I managed to install again and now able to access.

Now, I need help to create vlan.

We need some more information :slight_smile:

You can create the vlan interface by adding the vlan number after the interface, vlan 100 on interface eth0 = eth0.100

But eth0 is wan right? What other information required? I am not that much good in networking. Just trying to learn :slight_smile:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb2:6000:d348::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth1 eth2 eth3'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

This is the configuration I have now.

Why do you need vlans? What shall you connect and on which interface?

Then please mark this topic as Solved

Please read the docs and start a new topic if necessary.

1 Like

i undrerstood it wrong. I thought i should create vlan. But after some reading i understood i dont need it.

Thanks for the help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.