Pandora Box & OpenWrt ... TV flux

I have tested OpenWrt ( relay mode) & PandoraBox as:

No TV functionnality :
Orange BOX LiveBox 5 -> WIFI -> WR1200JS-OpenWRT -> LAN -> Orange TV HD box

No problem:
Orange BOX LiveBox 5 -> WIFI -> WR1200JS-PandoraBox -> LAN -> Orange TV HD box

The parameters are the same , speed …

With official Orange repeater also no problem

Why ? Drivers ?

As I recall, Orange's implementation of WDS is not directly compatible with that of OpenWrt (WDS addressing is a standard, however what the OS chooses to do with it is not). I would guess that PandoraBox uses relayd or the like, rather than "pure" WDS.

I not use WDS in this two cases …

Wifi is a normal Wireless client

For PandoraBox:
Firmware Version PandoraBox 18.07 2018-07-25-git-4a7f2b2 /LuCI Master (git-18.191.64311-165cb77)
Kernel Version 3.14.79

finally i use PandoraBox ( run and not use igmpproxy )

compilation informations:
https://www.haiyun.me/archives/1287.html

i have removed chinese pages , samba4 ( no many place in flash for add minidlna , luci-app-relayd )

i can use in relay/repeater mode my 2 * WR1200JS
Orange TV decoder
USB printer
FTP
minidlna ( for read videos with my TV's connected )

Tested also with Padavan firmware and no problem with TV flux

Sure problem is with OpenWRT

  • Pause, are you trying to setup some sort of IPTV?
  • What technology does it use?

That's not clear in any post, except when you mention igmpproxy. igmpproxy is usually used to pass multicast from LAN to WAN; I do not see a WAN (or other VLAN/LAN) in your config.

Also, you never showed the config.

@lleachii

The config is exactly the same with tested Openwrt , PandoraBox
I use not WAN only LAN with relayd

network


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8c:b434:a06e::/48'

config interface 'lan'
        option type 'bridge'
        option _orig_ifname 'eth0.1'
        option _orig_bridge 'true'
        option ifname 'eth0 eth0.1 eth0.2'
        option proto 'static'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '192.168.1.1 8.8.8.8'
        option delegate '0'
        option ipaddr '192.168.2.252'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr 'd4:5f:25:ea:f9:94'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr 'd4:5f:25:ea:f9:95'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4 5 6t 7t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 7t'
	option vid '2'

config interface 'STABRIDGE'
	option proto 'relay'
	option ipaddr '192.168.1.252'
	list network 'lan'
	list network 'wwan'
	option delegate '0'

config interface 'wwan'
	option _orig_ifname 'apclii0'
	option _orig_bridge 'false'
	option proto 'static'
	option ipaddr '192.168.1.252'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option dns '192.168.1.1 8.8.8.8'
	option delegate '0'

config interface 'wan'
        option proto 'none'


Wireless

...
config wifi-device 'ra'
	option type 'rtwifi'
	option macaddr 'd4:5f:25:ea:f9:94'
	option hwmode '11g'
	option channel 'auto'
	option txpower '100'
	option htmode 'HT20'
	option txburst '1'
	option smart '1'
	option country 'FR'

config wifi-device 'rai'
	option type 'rtwifi'
	option macaddr 'd4:5f:25:ea:f9:96'
	option hwmode '11a'
	option txpower '100'
	option htmode 'VHT80'
	option txburst '1'
	option noscan '1'
	option country 'FR'
	option channel 'auto'

config wifi-iface
        option device 'rai'
        option ssid 'Livebox-6256_5GHz'
        option mode 'sta'
        option encryption 'psk2'
        option key '1234567890'
        option bssid '00:00:00:00:02:52'
        option network 'wwan'

config wifi-iface
        option device 'rai'
        option mode 'ap'
        option ssid 'PandoraBox_252 '
        option rssikick '0'
        option rssiassoc '0'
        option encryption 'psk2'
        option key '1234567890'
        option network 'wan'