Packets not going out of interface-eth0

I have trouble creating additional bridge interface with vlan tagging. By default there are 2 VLAN interfaces present eth0.1 and eth0.2. I have created a new interface eth0.20 with private IP as 192.168.99.12/24.
I have connected this interface with another linux machine which is having IP address of 192.168.99.10/24 on VLAN 20 tagged interface.
Now, when I tried to ping 192.168.99.10, the ARP packet is going upto eth0, but I am not receiving the ARP packet in remote Linux machine interface. Which makes me to believe the packet is getting dropped in eth0 interface.
Please note that, the openwrt device and remote linux machine are directly connected. There are no intermediate devices which can drop the packets.

I have another bridge interface who IP is 192.168.188.253, which is part of eth0.1 and eth0.2. When I initiate a ping from this interface. I am getting ICMP response and packet is going out.
Only when I create any new vlan interface, packets are not going out.

/etc/config/network

config interface 'loopback'         
        option ifname 'lo'  
        option proto 'static'
        option ipaddr '127.0.0.1'    
        option netmask '255.0.0.0'    

config interface 'lan'
        option ifname 'eth0.1 eth0.2'
        option type 'bridge'
        option proto 'dhcp'
        option ipaddr '192.168.188.253'
        option netmask '255.255.255.0'
              
config interface 'wan'
        option proto 'dhcp'

config mgt 'mgt'
        option mgt_port '8080'

config config 'qos'
        option disable '1'
        option up_rate '1024000'
        option down_rate '1024000'
        option rule_num '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3t'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 3t'
        option vid '2'

config interface 'lan20'
        option ifname 'eth0 eth0.20'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.99.12'
        option netmask '255.255.255.0'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '3t'
        option vid '20'

Route details

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.99.0    0.0.0.0         255.255.255.0   U     0      0        0 br-lan20
192.168.188.0   0.0.0.0         255.255.255.0   U     0      0        0 br-lan

Interface Details:

ath0      Link encap:Ethernet  HWaddr 44:D1:FA:77:E7:A8                                                                                                                              [67/1909]
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                       
          TX packets:0 errors:0 dropped:763 overruns:0 carrier:0
          collisions:0 txqueuelen:0                            
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)                 
                                     
ath1      Link encap:Ethernet  HWaddr 44:D1:FA:77:E7:A9           
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                       
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0                             
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)                    
                                      
bond0     Link encap:Ethernet  HWaddr 00:00:00:00:00:00          
          BROADCAST MASTER MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0                     
          collisions:0 txqueuelen:0                         
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)                
                                                              
br-lan    Link encap:Ethernet  HWaddr 44:D1:FA:77:E7:A7
          inet addr:192.168.188.253  Bcast:192.168.188.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2424 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2826 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:202033 (197.2 KiB)  TX bytes:825636 (806.2 KiB)

br-lan20  Link encap:Ethernet  HWaddr 44:D1:FA:77:E7:A7
          inet addr:192.168.99.12  Bcast:192.168.99.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:532 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:22584 (22.0 KiB)

eth0      Link encap:Ethernet  HWaddr 44:D1:FA:77:E7:A7
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2434 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4659 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:246271 (240.4 KiB)  TX bytes:1172693 (1.1 MiB)
          Interrupt:4
eth0.1    Link encap:Ethernet  HWaddr 44:D1:FA:77:E7:A7
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2424 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2826 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:202039 (197.3 KiB)  TX bytes:825636 (806.2 KiB)

eth0.2    Link encap:Ethernet  HWaddr 44:D1:FA:77:E7:A7
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:770 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:285491 (278.7 KiB)

eth0.20   Link encap:Ethernet  HWaddr 44:D1:FA:77:E7:A7
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:531 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:22474 (21.9 KiB)

ifb0      Link encap:Ethernet  HWaddr 12:1E:77:85:0C:38
          BROADCAST NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

ifb1      Link encap:Ethernet  HWaddr 1A:B7:D7:34:86:71
          BROADCAST NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3453 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3453 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:541138 (528.4 KiB)  TX bytes:541138 (528.4 KiB)

teql0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wifi0     Link encap:UNSPEC  HWaddr 44-D1-FA-77-E7-A8-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:36785 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21331 errors:267 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:2699
          RX bytes:10144295 (9.6 MiB)  TX bytes:5388259 (5.1 MiB)
          Interrupt:47 Memory:b8100000-b8120000

wifi1     Link encap:UNSPEC  HWaddr 44-D1-FA-77-E7-A9-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:2699
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:40

Kindly help me out in troubleshooting this problem. Do let me know if any more information is required.

You have bridged eth0 with eth0.20... that makes my head spin. Since the other box expects packets tagged on VLAN 20, I would first take eth0 out of the bridge, and see if that works.

1 Like

Thanks for the reply.
Initially my configuration was without eth0. Since it was not working, I added eth0 to the bridge. The observations were same as the one with eth0 bridged.

Do not use plain eth0 for anything when you are running VLANs on the eth0 port.

Your VLAN 20 in the switch has only one port, it's a dead end. Add 0t to it so it will switch to the CPU.

3 Likes

Thanks for the reply. Even after the change I am not getting any packet on the remote machine.

config interface 'lan20'                                                                                                                                                                      
        option ifname 'eth0.20'                                                                                                                                                               
        option type 'bridge'                                                                                                                                                                  
        option proto 'static'                                                                                                                                                                 
        option ipaddr '192.168.99.12'                                                                                                                                                         
        option netmask '255.255.255.0'                                                                                                                                                        
                                                                                                                                                                                              
config switch_vlan                                                                                                                                                                            
        option device 'switch0'                                                                                                                                                               
        option vlan '3'                                                                                                                                                                       
        option vid '20'                                                                                                                                                                       
        option ports '0t 3t'   

Stop all other traffic, do a "ping" and see if the LAN LED lights up.

Thanks a lot for all the reply guys. The ping started working after rebooting the device with the changes applied. So I believe any changes in the switch, it requires a reboot. (Atleast for my device)

1 Like

Which suggests posting which device is involved (my apologies if I missed it).

That a bond seems to be in use is “interesting” and may or may not be meaningful to the problem. Past that, most all-in-one routers don’t have enough bandwidth in the MAC-PHY or -switch channels to support a GigE bond.