Packet Loss with WRT1900ACS

Backstory. I just changed my internet service to be a higher tier (Spectrum up 400 Mbps). I was using my own modem, and was told I needed a new one to achieve the higher tier, it was capping out at around 50 Mbps. I got a new modem from Spectrum (Hiltron is the brand if it matters) and I was still having issues with slow download speeds. When on the phone with support, we took the router out of the equation and first attempt was better (around 150 Mbps) and then a few minutes later I was getting over 400 Mbps. When I went back through the router, I initially disabled the wireless radios to stop my family from streaming the entire internet while I'm trying to diagnose the problem, and still had over 400 Mbps, this is all with the stock factory firmware on the WRT1900ACS. When I turned the wireless radios back on, the speeds tanked again.

So, the whole reason I bough the WRT1900ACS 4 years ago was because I could replace the firmware again like when I was using a WRT54g years ago, but I never did, so I took the opportunity. I installed the latest version last night, and after configuring the wireless and getting everything going, I was getting the speeds I expected and all was seemingly right.

Then I tried playing an Online Game and I've been getting a lot of packet loss and dropping out of the game. Trying to diagnose things more this morning, if I do a ping -t from my PC (wired connection to the router) I get packet loss, not tons, but anywhere between 5%-15%. I've tried 4 different Ethernet cables from the cable modem to the router. I have SSH'ed into the router and still get packet loss, I also get packet loss over a wifi connection as well.

Other than setting a root password and setting the SSID and and wireless settings, I haven't changed anything from the default install.

While I am a software developer, I am NOT a network administrator. I'll admit to being a bit intimidated by all of the options and terminology in OpenWRT. Can anyone help point me in the right direction? I'm sure there is a ton of information you will want to know, I just don't know what it is you'll need to see.

EDIT: Through some more digging and running a pingpath, it looks like the packet loss is between the router and the new cable modem. I've already tried various cables, would this be a defective modem, or could there be a conflicting setting?

OK, this is messing with my work day now, causing Zoom calls to be flaky. Connected straight to the cable modem, no packet loss, so this is either hardware related on the WAN port, or could this be a setting issue?

Perhaps there is an IP conflict? What's the IP address on the modem and on the router?

Router is the typical
Modem looks to be

This is a 4 year old router, I may just head out here after a call and get a new one.

Hello have the same router plus using with a Billion BiPAC 7800N as a modem and not seeing any packet loss when testing

I think my WAN port must be going bad.

It happens to several of us that the WAN port is failing and we do not know what it is Udhcpc does not work correctly