Packages not getting installed

When trying to install the following packages

opkg update

opkg install zabbix-agentd bash nut-driver-usbhid-ups nut nut-upscmd nut-upsc wireguard-tools luci-app-wireguard luci-proto-wireguard zabbix-agentd openwisp-config

on the "ROOter" version of wrt on the router model ZBTLink WE826-T2

some packages refuse to install as shown below.

  • opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/mipsel_24kc/base/libreadline8_8.1-1_mipsel_24kc.ipk, wget returned 4.

  • opkg_download: Check your network settings and connectivity.

  • opkg_install_pkg: Failed to download libreadline8. Perhaps you need to run 'opkg update'?

  • opkg_install_cmd: Cannot install package bash.

  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.238-1-0da76fec06cd5588cee86d873eb8f04b) for kmod-crypto-lib-chacha20

  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.238-1-0da76fec06cd5588cee86d873eb8f04b) for kmod-crypto-hash

  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.238-1-0da76fec06cd5588cee86d873eb8f04b) for kmod-crypto-lib-poly1305

  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.238-1-0da76fec06cd5588cee86d873eb8f04b) for kmod-crypto-lib-chacha20poly1305

  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.238-1-0da76fec06cd5588cee86d873eb8f04b) for kmod-crypto-kpp

  • pkg_hash_fetch_best_installation_candidate: Packages for kmod-crypto-kpp found, but incompatible with the architectures configured

  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.238-1-0da76fec06cd5588cee86d873eb8f04b) for kmod-crypto-lib-curve25519

  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.238-1-0da76fec06cd5588cee86d873eb8f04b) for kmod-udptunnel4

  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.238-1-0da76fec06cd5588cee86d873eb8f04b) for kmod-udptunnel6

  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.238-1-0da76fec06cd5588cee86d873eb8f04b) for kmod-wireguard

Any help would very much be appreciated to help resolve this error.

When you get the message “Cannot satisfy the following dependencies for…” it is most likely because you installed a snapshot version of OpenWrt.
Read here for possible solutions.

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

3 Likes