Packages needed for MT7916AN

hi.

I need help with choosing correct packages to make MT7916AN working.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
lspci
lsusb
root@Studio:~# ubus call system board
{
        "kernel": "6.6.53",
        "hostname": "Studio",
        "system": "ARMv8 Processor rev 0",
        "model": "FriendlyElec NanoPi R5C",
        "board_name": "friendlyarm,nanopi-r5c",
        "rootfs_type": "ext4",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r27659-664b8ffb0a",
                "target": "rockchip/armv8",
                "description": "OpenWrt SNAPSHOT r27659-664b8ffb0a"
        }
}
root@Studio:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'eth1'

config device
        option name 'eth0'
        option macaddr '56:2d:84:e4:ec:09'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '64'
        list ipaddr '10.0.0.93/24'
        option gateway '10.0.0.1'
        list dns '10.0.0.1'

config device
        option name 'eth1'
        option macaddr '56:2d:84:e4:ec:08'
root@Studio:~# cat /etc/config/wireless

config wifi-device 'radio1'
        option type 'mac80211'
        option path '3c0000000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option channel '149'
        option htmode 'HE160'
        option country 'US'
        option cell_density '0'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/fcc00000.usb/xhci-hcd.0.auto/usb1/1-1/1-1:1.0'
        option band '5g'
        option channel '36'
        option htmode 'HE40'
        option country 'US'
        option cell_density '0'

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/fd000000.usb/xhci-hcd.1.auto/usb8/8-1/8-1:1.0'
        option band '6g'
        option channel 'auto'
        option htmode 'HE80'
        option disabled '1'
root@Studio:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
root@Studio:~# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'
root@Studio:~# lspci
0000:00:00.0 PCI bridge: Rockchip Electronics Co., Ltd RK3568 Remote Signal Processor (rev 01)
0000:01:00.0 Network controller: MEDIATEK Corp. Device 7906
0001:00:00.0 PCI bridge: Rockchip Electronics Co., Ltd RK3568 Remote Signal Processor (rev 01)
0001:01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 05)
0002:00:00.0 PCI bridge: Rockchip Electronics Co., Ltd RK3568 Remote Signal Processor (rev 01)
0002:01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 05)
root@Studio:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux 6.6.53 xhci-hcd xHCI Host Controller
Bus 001 Device 002: ID 3574:6211 MediaTek Inc. Wireless_Device
Bus 002 Device 001: ID 1d6b:0001 Linux 6.6.53 ohci_hcd Generic Platform OHCI controller
Bus 003 Device 001: ID 1d6b:0002 Linux 6.6.53 ehci_hcd EHCI Host Controller
Bus 004 Device 001: ID 1d6b:0001 Linux 6.6.53 ohci_hcd Generic Platform OHCI controller
Bus 005 Device 001: ID 1d6b:0002 Linux 6.6.53 ehci_hcd EHCI Host Controller
Bus 006 Device 001: ID 1d6b:0003 Linux 6.6.53 xhci-hcd xHCI Host Controller
Bus 007 Device 001: ID 1d6b:0002 Linux 6.6.53 xhci-hcd xHCI Host Controller
Bus 008 Device 001: ID 1d6b:0003 Linux 6.6.53 xhci-hcd xHCI Host Controller
Bus 008 Device 002: ID 0e8d:7961 MediaTek Inc. Wireless_Device
root@Studio:~#

Also, this NanoPi r5c is used as dumb AP

Oke, which of 2 mediatek wireless needs driver

0000:01:00.0 Network controller: MEDIATEK Corp. Device 7906

Bus 001 Device 002: ID 3574:6211 MediaTek Inc. Wireless_Device

Bus 008 Device 002: ID 0e8d:7961 MediaTek Inc. Wireless_Device

the MEDIATEK Corp. Device 7906 should be my m.2 MT7916AN wifi chip

and the MediaTek Inc. Wireless_Device are my MT7921AU usb sticks

I need packages for both to have wireless working

1 Like

make output of sevtion pertaining adapter from

lspci -nnv

Cannot hurt booting OEM or debian or installing everythingrhyming mt76

root@Studio:~# lspci -nnv
0000:00:00.0 PCI bridge [0604]: Rockchip Electronics Co., Ltd RK3568 Remote Signal Processor [1d87:3566] (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 22
        Bus: primary=00, secondary=01, subordinate=ff, sec-latency=0
        I/O behind bridge: [disabled] [16-bit]
        Memory behind bridge: f4200000-f42fffff [size=1M] [32-bit]
        Prefetchable memory behind bridge: f4300000-f44fffff [size=2M] [32-bit]
        Expansion ROM at f4500000 [virtual] [disabled] [size=64K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/32 Maskable- 64bit+
        Capabilities: [70] Express Root Port (Slot-), IntMsgNum 0
        Capabilities: [b0] MSI-X: Enable- Count=1 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [148] Secondary PCI Express
        Capabilities: [160] L1 PM Substates
        Capabilities: [170] Vendor Specific Information: ID=0002 Rev=4 Len=100 <?>
        Kernel driver in use: pcieport
lspci: Unable to load libkmod resources: error -2

0000:01:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:7906]
        Subsystem: MEDIATEK Corp. Device [14c3:7906]
        Flags: fast devsel
        Memory at f4300000 (64-bit, prefetchable) [disabled] [size=1M]
        Memory at f4200000 (64-bit, non-prefetchable) [disabled] [size=32K]
        Memory at f4400000 (64-bit, prefetchable) [disabled] [size=4K]
        Capabilities: [80] Express Endpoint, IntMsgNum 0
        Capabilities: [e0] MSI: Enable- Count=1/32 Maskable+ 64bit+
        Capabilities: [f8] Power Management version 3
        Capabilities: [100] Vendor Specific Information: ID=1556 Rev=1 Len=008 <?>
        Capabilities: [108] Latency Tolerance Reporting
        Capabilities: [110] L1 PM Substates
        Capabilities: [200] Advanced Error Reporting

0001:00:00.0 PCI bridge [0604]: Rockchip Electronics Co., Ltd RK3568 Remote Signal Processor [1d87:3566] (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 24
        Bus: primary=00, secondary=01, subordinate=ff, sec-latency=0
        I/O behind bridge: 100000-100fff [size=4K] [16-bit]
        Memory behind bridge: f2200000-f22fffff [size=1M] [32-bit]
        Prefetchable memory behind bridge: [disabled] [64-bit]
        Expansion ROM at f2300000 [virtual] [disabled] [size=64K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/32 Maskable- 64bit+
        Capabilities: [70] Express Root Port (Slot-), IntMsgNum 8
        Capabilities: [b0] MSI-X: Enable- Count=128 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [148] Secondary PCI Express
        Capabilities: [160] L1 PM Substates
        Capabilities: [170] Vendor Specific Information: ID=0002 Rev=4 Len=100 <?>
        Kernel driver in use: pcieport

0001:01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125] (rev 05)
        Subsystem: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125]
        Flags: bus master, fast devsel, latency 0, IRQ 24
        I/O ports at 100000 [size=256]
        Memory at f2200000 (64-bit, non-prefetchable) [size=64K]
        Memory at f2210000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
        Capabilities: [70] Express Endpoint, IntMsgNum 1
        Capabilities: [b0] MSI-X: Enable+ Count=32 Masked-
        Capabilities: [d0] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [148] Virtual Channel
        Capabilities: [168] Device Serial Number 00-00-00-00-00-00-00-00
        Capabilities: [178] Transaction Processing Hints
        Capabilities: [204] Latency Tolerance Reporting
        Capabilities: [20c] L1 PM Substates
        Capabilities: [21c] Vendor Specific Information: ID=0002 Rev=4 Len=100 <?>
        Kernel driver in use: r8169

0002:00:00.0 PCI bridge [0604]: Rockchip Electronics Co., Ltd RK3568 Remote Signal Processor [1d87:3566] (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 26
        Memory at 380000000 (32-bit, non-prefetchable) [size=1G]
        Bus: primary=00, secondary=01, subordinate=ff, sec-latency=0
        I/O behind bridge: 200000-200fff [size=4K] [16-bit]
        Memory behind bridge: f0200000-f02fffff [size=1M] [32-bit]
        Prefetchable memory behind bridge: [disabled] [64-bit]
        Expansion ROM at f0300000 [virtual] [disabled] [size=64K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/32 Maskable+ 64bit+
        Capabilities: [70] Express Root Port (Slot-), IntMsgNum 8
        Capabilities: [b0] MSI-X: Enable- Count=128 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [148] Secondary PCI Express
        Capabilities: [160] L1 PM Substates
        Capabilities: [1a0] Vendor Specific Information: ID=0002 Rev=4 Len=100 <?>
        Capabilities: [2a0] Vendor Specific Information: ID=0006 Rev=0 Len=018 <?>
        Kernel driver in use: pcieport

0002:01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125] (rev 05)
        Subsystem: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125]
        Flags: bus master, fast devsel, latency 0, IRQ 26
        I/O ports at 200000 [size=256]
        Memory at f0200000 (64-bit, non-prefetchable) [size=64K]
        Memory at f0210000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
        Capabilities: [70] Express Endpoint, IntMsgNum 1
        Capabilities: [b0] MSI-X: Enable+ Count=32 Masked-
        Capabilities: [d0] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [148] Virtual Channel
        Capabilities: [168] Device Serial Number 00-00-00-00-00-00-00-00
        Capabilities: [178] Transaction Processing Hints
        Capabilities: [204] Latency Tolerance Reporting
        Capabilities: [20c] L1 PM Substates
        Capabilities: [21c] Vendor Specific Information: ID=0002 Rev=4 Len=100 <?>
        Kernel driver in use: r8169

also weirdly enough. i used to use mt7921u package for my usb mediatek stick but the package seems to be missing now on the latest snapshot?

image

update package lists
seems this
kmod-mt7915e
it will print firmwares if needed.

i will try re-flashing

Please no more screenshots

1 Like

alright..

when i try building at firmware selector it's giving me "impossible package selection error"

Collected errors:
 * opkg_install_cmd: Cannot install package kmod-rtw88-8822ce.
 * opkg_install_cmd: Cannot install package kmod-rtw88-8822ce.
make[2]: *** [Makefile:220: package_install] Error 255
make[1]: *** [Makefile:161: _call_manifest] Error 2
make: *** [Makefile:322: manifest] Error 2

these should be base packages included for NanoPi r5c though i believe?

i think there is something wrong with package list and downloads

Use basic image for initial install
Then install luci from ssh
Then refresh software sources before complaining something is missing.

i am trying to inform really.

anyways, i flashed default snapshot, installed luci. ran opkg update in software tab but it still doesn't show alot of kmod and mt packages. especially the ones i need presumably. kmod-mt7915e and mt7921u is missing.

When i go to the repository of kmods that's linked in "opkg configure" it's missing there as well.

https://downloads.openwrt.org/snapshots/targets/rockchip/armv8/kmods/6.6.53-1-d464dcaa77b48f8831b055e74058a9e0

Try in few days, in principle auc / attendedsysupgrade can maintain software well, then for few days you will have matching packages available...