Packages missing in 19.07.7?

Today I tried to upgrade my TP-Link Archer C7 v2 ( from 19.07.6 to 19.07.7.

When trying to install the packages "openssh-sftp-server" or "mc" I get the error "Unknown package". Installing these packages had worked before, so I tried to step back to 19.07.6, but the same errors occured.

The packages flawlessly install on a Linksys WRT3200ACM ( with 19.07.6 and 19.07.7.

As far as I could figure out, these packages seem not to exist anymore in the 19.07 (neither in 19.07.6 nor in 19.07.7) package feeds of architecture mips_24kc (which I think to be my TP-Link Archer C7's architecture). But they must have existed before (at least in 19.07.6, as I formerly could install it without any issues).

According to the openssh-sftp-server package should exist for architecture mips_24kc (as well as package mc).

I wounder what has changed, since I formelry installed the packages successfully. How can I manage to install these packages again? Any advice is higly appreciated.

Maybe my request seems foolish to professionals, but I am quite confused at the moment.

18.06 != 19.07

Did you do opkg update before attempting install?

Yes, I did opkg update.

There is currently pretty massive build failure in the 19.07 buildbot. Lots of packages have failed to build.

Normally the faillogs are pretty empty. But now there is lots of stuff

@jow implemented some fixes yesterday, but the fixes have not yet trickled down to the packages builds. (And the buildbot seems to have also other problems)

To get the packages quickly, easiest is to build them by yourself.

1 Like

Same here. Had to create account to report this too, and noticed this has been reported already. Today reflashed mips_24kc and tried to restore extroot. Packages e2fsprogs fdisk missing. Checked where these packages were suppose to be, indeed, most of the packages are now gone.

1 Like

Thanks for the rapid responses. So it seems, I just have to wait until the build issues are resolved. Maybe I try to buid it myself. Never did it before, but might be worth a try.

Yup, did the same as @noobio, came here to check if anyone else is having trouble finding packages.
I also did opkg update and can't seem to find any collectd-mod, hence can't install luci-app-statistics.
This worked yesterday morning, but not in the evening.

1 Like

Same here...

It´s possible make a new package with all packages missing to correct this situation?

Same here - I thought it's something on my side, I'm trying to build a clone of an ADSL router, and a few packages mysteriously won't install, such as wireguard-tools, and https-dns-proxy (whereas wireguard and luci-app-https-dns-proxy does exist, but can't be installed because of those missing dependencies that should be there). I can't find the packages either in the packages directory, yet they are installed on the previous router.


I am experiencing the same issue. After banging various ways to figure what's wrong with my OpenWRT came to the forum for help, but happily this thread has already started. I am on the same hardware as the OP (Archer 7 v2), running 19.07.3, and getting

Cannot install package

errors when trying to install curl, or a libustream library. Those don't even show as being available by "opkg list". It all started with my trying to install SSL for DDNS update requests.

Hopefully top men are looking into fixing the package sources. Much appreciated!

tjk :slight_smile:

Same here too. I just did a fresh install on a DIR-859 because of this issue thinking that I had messed with some configuration... :frowning:

LuCI is also failing: after selecting "Update Lists", the option "Available Packages" gets stuck forever on "Loading package information…" and "Installed Packages" breaks and shows "No information available".

Then I thought it was a DIR859 issue, but I just rebooted an Archer C7 v2 (fully installed, configured, and running for a couple of weeks), and the issue is the same. Then I came here to the forum just to discover that the issues seems to be on the server side. Hopefully this issue should be resolved sooner than later.

I'm trying to install some packages that were available yesterday in the repositories ...

These packages were installed on my routers and had problems, I decided to remove them to install them again ...

In this case, the "collectd" - See:

Here the configuration of the repositories ... Apparently, they are correct because they compare with other routers:

I believe that we are facing some problem in relation to packages and repositories. Could anyone confirm?

1 Like

OK thanks!
We will wait to see if it normalizes over time.

Is it possible to copy the packages that are already installed and working on one router to another and install?

Not really, the packages aren't kept.

But you can check out the mirrors

I tried editing /etc/opkg/distfeeds.conf replacing the default OpenWRT repository by a mirror but it did not work:

root@ap1-router:/# opkg install libustream-mbedtls
Unknown package 'libustream-mbedtls'.
Collected errors:
 * opkg_conf_parse_file: /etc/opkg/distfeeds.conf:19: Ignoring config line with trailing garbage: `src/gz openwrt_kmods openwrt_base'
 * opkg_install_cmd: Cannot install package libustream-mbedtls.

I tried both France and Brazil mirror without success. So it seems that the .ipk files need to be installed individually.

EDITED: it seems that the mirror repositories are also broken, since it looks like that all mirrors rsync'ed with the master repository last night, automatically removing all missing packages also from the mirrors... :frowning:

1 Like

I was feeling very dumb for not being able to install some packages in one of my OpenWRT boxes...Iol
I even hard reset it, because I thought it was suffering from a partition corruption :man_facepalming:

I also can confirm that all the oficial mirrors are missing packages (tested all of them)...

cat .git/config  | grep url

This issue seems to be fixed, all things back to normal.


Indeed! Thanks @dsouza for the message.