Package ntfs-3g generates an error message on a mount of an ext4 formatted USB device

After I installed package ntfs-3g to my router TP-Link C7 v5 running on:


mounting an ext4 formatted USB storage device began to give me this error message:

NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

The actual mount operation has however succeeded, and I could read from and write to the USB device just fine.

By the way, this is what I do to mount the thing (if it makes any difference): install packages kmod-usb-storage and kmod-fs-ext4, create the directory /mnt/usb, and run:

# mount /dev/sda1 /mnt/usb

When I removed ntfs-3g and what appeared to be a dependency of it, i.e.

# opkg remove ntfs-3g kmod-fuse

the error message was gone, and the mount operation continued to be successful.


  1. What is the error message really telling me? (It seems as though mount now tries two things. First, try to treat the partition as an NTFS, fail, and let me know that it has failed. Second, treat the partition as ext4 and silently succeed. Could that be it?)

  2. How can I get rid of the error message (together with any underlying problem) without removing the offending packages?

1 Like

you are correct... it is an irroneous message and can be ignored
(or you could create a flyspray bug report if you are unable to devise a fix)

You can force the filesystem type that should be expected with "mount -t ext4 /dev/sda1 /mnt/usb".


Yes, I tried that, but it does not get rid of the error message. (The mount succeeds, but it has always succeeded).

I was wrong. I reinstalled ntfs-3g specifically to test -t ext4 again, and it worked. The -t option got rid of the error message. Thanks.

1 Like
sed -i 's/ntfs-3g/#ntfs-3g/g' /etc/filesystems
1 Like

When you or a script issues mount without specifying the file system type, all installed filesystem drivers are polled and the first one to recognize the filesystem will mount it.

The message just means that the ntfs-3g driver probed the partition, did not find a valid NTFS filesystem, and gave up. Which is expected since the partition is formatted ext4. You can treat it as a warning. Most of the other filesystem drivers do this silently.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.