OSCam on OpenWrt

Not sure if anyone here knows what OSCam is but should I expect to be able to install and configure it on OpenWrt

yes, it work just fine, i have working oscam on tplink 8970 and wrt 3200 acm.

1 Like

Was it easy enough to configure?

What do you connect it to it?

I ask because I'm trying to connect a MECOOL KIII Max android STB to my Server (which is running on FreeBSD at the moment) and it won't connect.

easy like enigma2 box or linux pc, for sure your problem is oscam files config, noting to do with openWRT.

Confirm: works on orange pi zero, A5V11

Hi there,

can anyone help me how to build scam for openwrt 18.6 on a tp-link 1043ND V1? I got stuck and download by streamboard is not an option anymore.

Kind regards!

Try this: http://www.satnigmo.com/2264/compile-oscam-with-simplebuild-script/

@vpont thanks for the gaat response! I tried wget ss4200.homelinux.com/oscam/simplebuild, bus got an error and wget quits.
I tried the commands straight on the OpenWrt device.
Can I run simplebuild on a Mac?

You're not suposed to build it directly on your Openwrt device, you have to use a Linux machine.
If you're on a Mac I would create a virtual machine with Linux for building.

1 Like

Latest version is here btw: http://s3.is-by.us/now.sh

Hello help who encountered this question Tp-Link Tl-MR3020 v.1 replaced the flash with 8mb installed openwrt. Now there is a task to install Oscam in it but with this task I can t cope with here I introduce these teams:

BusyBox v1.28.3 () built-in shell (ash)
Welcome to Peppy Snowdrop 2.4

root@HardD-WRT:~# cd /opt
root@HardD-WRT:/opt# mkdir simplebuild
root@HardD-WRT:/opt# cd simplebuild
root@HardD-WRT:/opt/simplebuild#  wget -O simplebuild http://s3.is-by.us/now.sh
Connecting to s3.is-by.us (
Connecting to s3.is-by.us (
root@HardD-WRT:/opt/simplebuild# chmod 777 simplebuild
root@HardD-WRT:/opt/simplebuild# ./simplebuild debinstall
-ash: ./simplebuild: not found
root@HardD-WRT:/opt/simplebuild# ./simplebuild menu
-ash: ./simplebuild: not found

You are not supposed to run that script in the router, it is a "building script", not an "installing script"; you must run it in your Linux PC.

1 Like

Tell me, is there a script for this router?

It's not about having a script for that specific router or another one. That script builds the driver, and you need a full PC for that.

It s difficult for me. Thought there was a simpler solution. Thanks