Orange pi R1 plus support

Well that was unexpected... At least for me!

router -> gateway

40 packets transmitted, 23 packets received, 42% packet loss
round-trip min/avg/max = 0.982/1.077/1.163 ms

ps: gateway is just another dummy router btw

First: I can give another report of everything working well on the LTS with a build of Tianlings latest PR without any additional patches/changes.

And I cannot reproduce the packet loss error on my side. :man_shrugging:

It is nice to know. Would you mind sharing kernel log and your builded-firmware please?

Well...

On new motorcomm driver for rj45 port

  • 1Gbit : Only green LED is active and blinks. On-board WAN-LED works.
  • 100Mbit : Only amber LED is active and blinks. On-board WAN-LED works.
  • 10Mbit : There is no LED activity. on-board WAN-LED works.

Prior to kernel 5.15 Amber light = activity LED and Green LED = link LED, Both of them are always active on any negotiated link speed when link is up.

Can anyone confirm that?

https://github.com/immortalwrt/immortalwrt/blob/master/target/linux/rockchip/patches-5.15/601-net-phy-motorcomm-add-LED-configuration-for-yt8521.patch

it's just an ugly hack and cannot be accepted by upstream

I guess my problem is related to the way phy-ethernet driver get initialized or some default behavior of network or driver. I did not test it. I will do as soon as i can. Because i have no issues with default generic phy driver on 5.15 with old hacky way(using nanopi-r2s as base).

@1715173329 Okay i made it work as it should do. Something is not right with initializing phy on 008-v6.4-arm64-dts-rockchip-Add-Xunlong-OrangePi-R1-Plus-LTS.patch. I just modified the gmac2io node. It works but i do not understand anything with these files. Any suggestion is appreciated. I will have a look when i have time. And of course if you want it, i could share dirty and embrassing gmac2io node :grimacing: .

Losses are fixed. But unable to assign or get assigned IP with hotplug event. Router needs to get rebooted to achieve that. motorcomm,auto-sleep-disabled

auto sleep should be disabled, vendor driver also does it

1 Like

image
Why is download speed from official snapshot so much slower than walmartshopper's. tested from many source.
image

I could not pin point the source of this issue. You can read my previous posts on this topic. Unfortunately I have no time to inspect it for now.

Orange Pi R1 Plus LTS seems to have official support since OpenWrt 23.05.0-rc2.

2 Likes


Jup

still same slow download speed. :smiling_face_with_tear:

2 Likes

My R1 Plus LTS version have problem with 23.05-rc2 & snapshot. It can't get ip on wan with dhcp-client protocol. Try swapping LAN/WAN eth0 & eth1 same problem.

Same problem
You Solved is?

Not yet. I'm guess the problem lies in the Motorcomm ethernet driver.

1 Like

I tried the snapshot from August 1, 2023, but problem persist. WAN port, eth0, supposely only transmit, but never receive any single packet, information from ifconfig tool. I tried Armbian, it works fine, but slow Internet performance, 40/40 Mbps.
Besides, in the constantly tries for connecting to PPPoE, it change from 1Gb to 100Mb. You can check the logs I leave on Can't connect PPPoE session: Send PPPOE Discovery V1T1 PADI session 0x0 length 12 - #26 by maximi89

I have removed all the patches related to motorcomm drivers & apply patch from xunlong, it works as expected on the latest snapshot.

diff --git a/target/linux/rockchip/patches-5.15/008-v6.4-arm64-dts-rockchip-Add-Xunlong-OrangePi-R1-Plus-LTS.patch b/target/linux/rockchip/patches-5.15/008-v6.4-arm64-dts-rockchip-Add-Xunlong-OrangePi-R1-Plus-LTS.patch
index cedf28dc79..762c42fc64 100644
--- a/target/linux/rockchip/patches-5.15/008-v6.4-arm64-dts-rockchip-Add-Xunlong-OrangePi-R1-Plus-LTS.patch
+++ b/target/linux/rockchip/patches-5.15/008-v6.4-arm64-dts-rockchip-Add-Xunlong-OrangePi-R1-Plus-LTS.patch
@@ -54,7 +54,7 @@ Signed-off-by: Heiko Stuebner <heiko@sntech.de>
 +		/delete-node/ ethernet-phy@1;
 +
 +		yt8531c: ethernet-phy@0 {
-+			compatible = "ethernet-phy-ieee802.3-c22";
++			compatible = "ethernet-phy-id4f51.e91b", "ethernet-phy-ieee802.3-c22";
 +			reg = <0>;
 +
 +			motorcomm,clk-out-frequency-hz = <125000000>;
diff --git a/target/linux/rockchip/patches-6.1/008-v6.4-arm64-dts-rockchip-Add-Xunlong-OrangePi-R1-Plus-LTS.patch b/target/linux/rockchip/patches-6.1/008-v6.4-arm64-dts-rockchip-Add-Xunlong-OrangePi-R1-Plus-LTS.patch
index 78d3d51a17..34ba2067ac 100644
--- a/target/linux/rockchip/patches-6.1/008-v6.4-arm64-dts-rockchip-Add-Xunlong-OrangePi-R1-Plus-LTS.patch
+++ b/target/linux/rockchip/patches-6.1/008-v6.4-arm64-dts-rockchip-Add-Xunlong-OrangePi-R1-Plus-LTS.patch
@@ -54,7 +54,7 @@ Signed-off-by: Heiko Stuebner <heiko@sntech.de>
 +		/delete-node/ ethernet-phy@1;
 +
 +		yt8531c: ethernet-phy@0 {
-+			compatible = "ethernet-phy-ieee802.3-c22";
++			compatible = "ethernet-phy-id4f51.e91b", "ethernet-phy-ieee802.3-c22";
 +			reg = <0>;
 +
 +			motorcomm,clk-out-frequency-hz = <125000000>;

Try to apply this patch and see if it helps

do you mean OpenWrt SNAPSHOT, r23680-64b99802a6 ?

I tried that version, but no change with the Motorcomm YT8531C in the OrangePi R1 Plus LTS, it seems can send data, but never receive any package.

eth0 Link encap:Ethernet HWaddr C0:74:2B:FF:AE:2F
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:249 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:73778 (72.0 KiB)
Interrupt:35

eth1 Link encap:Ethernet HWaddr C0:74:2B:FF:AE:30
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:19631 errors:0 dropped:0 overruns:0 frame:0
TX packets:4392 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3475489 (3.3 MiB) TX bytes:1620050 (1.5 MiB)

OpenWrt SNAPSHOT, r23680-64b99802a6

root@OpenWrt:~# dmesg|grep -i eth
[ 0.000000] psci: probing for conduit method from DT.
[ 0.202196] rk_gmac-dwmac ff540000.ethernet: IRQ eth_wake_irq not found
[ 0.202830] rk_gmac-dwmac ff540000.ethernet: IRQ eth_lpi not found
[ 0.203543] rk_gmac-dwmac ff540000.ethernet: PTP uses main clock
[ 0.409611] rk_gmac-dwmac ff540000.ethernet: IRQ eth_wake_irq not found
[ 0.410233] rk_gmac-dwmac ff540000.ethernet: IRQ eth_lpi not found
[ 0.410901] rk_gmac-dwmac ff540000.ethernet: PTP uses main clock
[ 0.411592] rk_gmac-dwmac ff540000.ethernet: clock input or output? (input).
[ 0.412220] rk_gmac-dwmac ff540000.ethernet: TX delay(0x19).
[ 0.412724] rk_gmac-dwmac ff540000.ethernet: RX delay(0x5).
[ 0.413225] rk_gmac-dwmac ff540000.ethernet: integrated PHY? (no).
[ 0.413800] rk_gmac-dwmac ff540000.ethernet: cannot get clock clk_mac_speed
[ 0.414414] rk_gmac-dwmac ff540000.ethernet: clock input from PHY
[ 0.419965] rk_gmac-dwmac ff540000.ethernet: init for RGMII
[ 0.420838] rk_gmac-dwmac ff540000.ethernet: User ID: 0x10, Synopsys ID: 0x35
[ 0.421496] rk_gmac-dwmac ff540000.ethernet: DWMAC1000
[ 0.421963] rk_gmac-dwmac ff540000.ethernet: DMA HW capability register supported
[ 0.422624] rk_gmac-dwmac ff540000.ethernet: RX Checksum Offload Engine supported
[ 0.423285] rk_gmac-dwmac ff540000.ethernet: COE Type 2
[ 0.423749] rk_gmac-dwmac ff540000.ethernet: TX Checksum insertion supported
[ 0.424371] rk_gmac-dwmac ff540000.ethernet: Wake-Up On Lan supported
[ 0.424940] rk_gmac-dwmac ff540000.ethernet: Normal descriptors
[ 0.425465] rk_gmac-dwmac ff540000.ethernet: Ring mode enabled
[ 0.425981] rk_gmac-dwmac ff540000.ethernet: Enable RX Mitigation via HW Watchdog Timer
[ 4.574837] usbcore: registered new interface driver cdc_ether
[ 4.837557] r8152 4-1:1.0 eth1: v1.12.13
[ 6.580030] br-lan: port 1(eth1) entered blocking state
[ 6.580552] br-lan: port 1(eth1) entered disabled state
[ 6.581426] device eth1 entered promiscuous mode
[ 6.584610] br-lan: port 1(eth1) entered blocking state
[ 6.585140] br-lan: port 1(eth1) entered forwarding state
[ 6.605257] rk_gmac-dwmac ff540000.ethernet eth0: Register MEM_TYPE_PAGE_POOL RxQ-0
[ 6.679341] rk_gmac-dwmac ff540000.ethernet eth0: PHY [stmmac-0:00] driver [YT8531 Gigabit Ethernet] (irq=POLL)
[ 6.686232] rk_gmac-dwmac ff540000.ethernet eth0: No Safety Features support found
[ 6.686989] rk_gmac-dwmac ff540000.ethernet eth0: PTP not supported by HW
[ 6.688184] rk_gmac-dwmac ff540000.ethernet eth0: configuring for phy/rgmii link mode
[ 7.606554] br-lan: port 1(eth1) entered disabled state
[ 20.370985] r8152 4-1:1.0 eth1: Promiscuous mode enabled
[ 20.372144] r8152 4-1:1.0 eth1: carrier on
[ 20.372961] br-lan: port 1(eth1) entered blocking state
[ 20.373439] br-lan: port 1(eth1) entered forwarding state