Orange light with Linksys e8450 while restoring the vendor/official firmware

Dear Guys,
Again I am on same issue, for now i was following procedure to back on stock firmware.
I copied stock FW_E8450_1.0.01.101415_prod.img file in /tmp location and reboot router, hold reset button,
after bilking power led continuously, i run restore commands and reboot.
Run commands are:

ubidetach -d 0
insmod mtd-rw i_want_a_brick=1
mtd -p 0x200000 write /tmp/FW_E8450_1.0.01.101415_prod.img /dev/mtd3

i have tried to restore recovery using SolarWinds TFTP but its not working now. error: Dropped because peer didn't respond.

Please do the needful.


same error as last time, before you switched off your wifi card ?

at least you can see the request for the image, coming in to the TFTP server ?

1 Like

Try increasing the timeout value.

Guys, i have applied both you suggested, I am getting below response

only thing I can recommend, is to try putting a switch between your computer and the E8450.

Yes @frollic , Router has a switch to on off it, i am using it

a network switch.

Or just set the max speed of the network adapter on the computer to 100 Mbps.

Currently I don't have it, is it possible to recover it without switch?

how, can you please suggest where the option to set it in windows 10?

Settings > Network & Internet > Change adapter options

Right-click on the Ethernet adapter and select Properties.

Click Configure.

Click on the Advanced tab.

Scroll down and look for entry like "Speed & Duplex".

Set it there.

Where did you get the instructions for using a TFTP server to go back to stock firmware?

1 Like

I have set 100 MBPS full duplex.
now, please suggest next step

Run the TFTP server again.

You didn't answer the question above about the TFTP server instructions to go back to stock firmware.

Same issue.. no progress.

Same issue.. no progress.

Sorry, I missed it. Getting from below

Looks like it times out after 5 seconds.

Up the timeout to 10 seconds.

If that isn't it, I suspect something is not configured correctly...either on the TFTP server, or on your network adapter.

Those instructions are for a TP-Link router, not a Linksys...

So of course it's not working.

You need to find instructions "specific" to a Linksys, and possibly even specific to the E8450.

... and those instructions were in your other thread.

1 Like

Same instruction i have applied yesterday, on my side and remain same worked for me. but not today. might be i yesterday its due to snapshot update and today it happens due to restore firmware.img.