Optimized build for the TP-Link C2600 / Netgear R7x00 / Linksys EA8500 / Zyxel Armor Z2

I've rebased on latest master so ipq806x is now on 4.14 with softflow included by default. r5977 is available from the download area :slight_smile:

Enable it like this:

uci set firewall.@defaults[0].flow_offloading=1 ; uci commit firewall ; fw3 restart

ea8500 (partitioning unchanged) and archer c2600 (kernel partition resized to 4 MB) should sysupgrade transparently, the netgear r7x00 devices must be flashed via tftp, due to the changed partitioning (2-->4 MB kernel partition) on nand/ ubi.

1 Like

By the way, just as a suggestion, luci-app-advanced-reboot does make sense on the ea8500 (and the nbg6817), this can be added easily just for the affected devices by enabling TARGET_PER_DEVICE_ROOTFS.

As you seem to build for most ipq806x devices anyways, the nbg6817 (almost identical to the r7800, just with 4 GB eMMC instead of 128 MB NAND and no SATA port) could be enabled easily (the only additional package that needs to be built would be losetup (enabled by DEVICE_PACKAGES), but thanks to TARGET_PER_DEVICE_ROOTFS, it doesn't clutter the other images).

From 9b50231750ba7412c474b1ea190a1e7a7c369765 Mon Sep 17 00:00:00 2001
From: Stefan Lippers-Hollmann <s.l-h@gmx.de>
Date: Fri, 25 May 2018 22:15:22 +0200
Subject: [PATCH] ipq806x: enable TARGET_PER_DEVICE_ROOTFS and nbg6817 images

Also include luci-app-advanced-reboot for the ea8500 and nbg6817.

Drop a duplicate config symbol:
* CONFIG_TARGET_DEVICE_ipq806x_DEVICE_linksys_ea8500

Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
 profiles/ipq806x | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

diff --git a/profiles/ipq806x b/profiles/ipq806x
index 5579b36cbf..cf73953454 100644
--- a/profiles/ipq806x
+++ b/profiles/ipq806x
@@ -1,11 +1,18 @@
@@ -154,6 +161,7 @@ CONFIG_PACKAGE_libuuid=y
1 Like

@escalade, does the new build work for you?
There were some reports of a serious bug causing the wired network not to show up.
This: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=7e664b7c2dc00006ba29bf947cf177b5bccdc47d
is needed to fix the bug.

Yes, it worked fine for me. Perhaps it didn't affect ipq soc?

Hnyman's R7800-build suffered from it.

Maybe you're openwrt-version is old: r5977 and the bug was not introduced yet.
rmaster r7035 had the issue, in r7044 it was solved.

Probably shouldn't look at the revision number my tree is based on latest git.

Latest build doesn't work for me. TpLink AC2600 v 1.0. After upgrade (without/with keep backup) I can't get IP adress (via LAN and WiFi). WiFi appears but without Ip adress too. I had to back to previous build (TFTP recovery mode).

I've rebased again to get the fix and done a clean rebuild (revision is now in line with what's expected as well). Runs well here, check out r7040.

Thanks for including the nbg6817 image, btw. the second hunk with "CONFIG_PACKAGE_luci-app-advanced-reboot=m" seems to have gone missing (CONFIG_TARGET_DEVICE_PACKAGES_*="luci-app-advanced-reboot" can only include packages that have been built (at least in a modular fashion), it doesn't select a package on its own and doesn't really complain about a missing package either).

Thanks, now works fine

Can you make a build for wdr4900?


Fixed in latest build.


Done :slight_smile:

Excelent job. I use your builds for years and never have a problem. The OpenVpn (whitch is very well integrated) it's a must for me, I use it with all my mobile devices. It will be nice to have adblock out-of-box, but no problem, took me 5 minute to install and running adblock.

I may have a new look at the available adblock solutions and see if they are worth including. Happy to hear my quick and dirty VPN scripts prove useful :slight_smile:

@escalade, I was checking your github, you are doing this for kernel 4.9:
"target/linux/generic/config-4.9: enable multicast routing through CONFIG_IP_MROUTE"
Is this change not also needed for kernel 4.14=R7800, etc.?

It was the default for 4.14 so no change needed.

On your github, in config-4.14, it reads: # CONFIG_IP_MROUTE is not set
In config-4.9, it reads: CONFIG_IP_MROUTE=y
So, it's not set as default

It gets enabled through CONFIG_KERNEL_IP_MROUTE defined by the kernel package. I believe this was not the case before, so the hard config should not be necessary for 4.9 either anymore.

Didn't know about that one, thanks! :slight_smile:

Edit: found it. This option was changed on Jan 11, 2018