Optimized build for the TP-Link C2600 / Netgear R7x00 / Linksys EA8500 / Zyxel Armor Z2


Thanks @escalade !!!

Hi @escalade, are there plans for a 18.6 version of this fine build?

It should be easy to rebase on a stable branch but I don't care much to maintain too many these days.

understood. I thought it might be on your list of favorite routers since you own one. The last build is working nicely.

What do you mean, you asked for a release version not a router? :slight_smile:

I've uploaded a new build.

- compile with gcc 8.x
- switch from dnscrypt to dns over https (doh) using https-dns-proxy
- update openssl 1.1.1
- update kernel to 4.14.69
- add nfs-kernel-server with v4 support
- add curl

Note that I have now made the move from dnscrypt to DoH (dns over https). For anyone sysupgrading from a previous release you will edit /etc/config/dhcp and change to in order to have working DNS.


I have an EA-8500 and i am on DD-WRT Kong Builds, lately for some strange reason DD-WRT builds have become extreme buggy and i am thinking to move here, i am using it for Samba with 4 HDD on it, WDS AP (need maximum TX power (30 on DD-wrt) on it because its on remote area) SQM QOS (extreme buggy on DD-WRT K 4.4, B is the best reasult lately) i am expecting Samba transfer speeds of 34MB/sec stable (this is what i have now on Kong Builds) i remember that when i tried 18.06 main build samba was ridicolosly slow and TX powers very low to be operational on my network scenario, thats why i switched back to DD-WRT, i would like to help me by telling me which of those you have on your builds (samba speed, sqm Qos stability, Tx power) so i can get an idea if i can move to your builds, which seems very interesting!! Thank you very much!

PS is package installing possible in your builds since they are based on developement firmwares...because i want to use transmission and some other packages too!

I don’t use samba or sqm myself. Don’t see why file transfers would perform much different from other builds. Sure you can install packages same as on a snapshot build.

on a typical 18.06.1 firmware isnallation samba transfers were just 14-21 MB/sec (from 34) sqm was superb A+ but TX power was just 20dbm (from 30) , the last i am sure was WIP because region changer was buggy (could choose 30 but it was going just till 20) i know that samba on k4.4 had some issues but not so huge difference from 34 to 17 . Anyway ia going to try your build and will inform you asap how is it going!

1 Like

Cannot change root password, says uknown arror, passwork didnt changed. Any idea how to make it work?

Strange, works for me.

worked finally but reseted gui to bootstrap without dropdown access to put it back to material, another very strange where is ssh configuration? it supposed to be on administration tab, but there is only password changer, Wifi works as should, maxed TX power to 30dbm ,didnt checked samba speed yet!

ps ssh no access, doesnt accept any password, not even root

I use openssh afaik luci only supports dropbear. As stated in OP password is changemenow. I can change it just fine when testing here.

i cant change it without reseting theme already theme has stuck to default and the dropdown changer on system tab is bugged, i am afraid to reflash firmware because i need the second partition set to factory till i finish testing the build, but i need from you to tell me how to access the opessh server inside the router (EA-8500) i cannot find a way to do it.

Log in through ssh user root with password changemenow and change it with the command passwd.

tried not accepting it,whatever combination of user and password i put its not accepting it, only with drophbear i can have access i am installing dropbear to fix it,enable openssh and then uninstalling . To be honest i dont need openssh so much but i dont want to spare the ram their packages are using, maybe would be better next time to use dropbear when you are building the firmware and let users to install if they need the packages of openssh (they are quite big!!), i think even if someone wants openssh needs dropbear first to create the certificates.i am not expert, maybe i am wrong but all articles i read about openssh installation are starting with dropbear!

Like I said it works fine here, don't know what's going on with your router as I can't replicate. Did you do a clean install?

OpenSSH does much faster file transfers than Dropbear, and has lots more features. There's no reason to go with Dropbear, but if you want it just clone my repo and build yourself with the package set you want.

From your description it sounds like a problem with the "material" CSS theme for luci, which wouldn't be overly surprising (bootstrap and openwrt are the only ones that get real attention, material is mostly maintained on a patches welcome basis).

Are there configuration options for dns over https (doh) such as the dns provider?