Optimized build for the D-Link DIR-860L


#745

Nope, it's default 00-World.


#746

Which explains why those other channels aren't available. The default world country only allows channels which are allowed everywhere in the entire world, which there are only a few.


#747

Is there any country that dont have any restrictions on what channels to use?
I vote put that one as default.
If there is not such a country, there should be a developer mode that lets you do this. Restrictions bug me.


#748

Which would be illegal. And would make sure OpenWRT would be shutdown. Not going to happen.


#749

Auto selection worked after i set the right country code, thanks !


#750

I did not know this build represented OpenWRT. We do include packages that are not included be default, right? Obviously that is not illegal, but I think you get my point. For a specialized build it may very well be an option to consider. I did not mean for OpenWRT to change anything.

I still want to know if there is a country without restrictions though. I do not mind setting the "best" country regardless of where I live.


#751

Here is a list - https://en.wikipedia.org/wiki/List_of_WLAN_channels#5_GHz_(802.11a/h/j/n/ac/ax)
You can change countries until you find the channel you want but that would be illegal because for example that channel can be used by gov/mil/police in your country. Also phones sold for specific market may not see that channel.
I've had this issue with a phone from USA not seeing my router.


#752

I think something is broken when it comes to "allowed tx power" @18.06RC1...
I've set the correct country code and i can select DFS channels now but the Tx Power doesn't fit the allowed maximum for my country.

root@860L-AP1:~# iw list | grep -i dbm
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm)
                        * 2472 MHz [13] (20.0 dBm)
                        * 5180 MHz [36] (20.0 dBm)
                        * 5200 MHz [40] (20.0 dBm)
                        * 5220 MHz [44] (20.0 dBm)
                        * 5240 MHz [48] (20.0 dBm)
                        * 5260 MHz [52] (20.0 dBm) (radar detection)
                        * 5280 MHz [56] (20.0 dBm) (radar detection)
                        * 5300 MHz [60] (20.0 dBm) (radar detection)
                        * 5320 MHz [64] (20.0 dBm) (radar detection)
                        * 5500 MHz [100] (26.0 dBm) (radar detection)
                        * 5520 MHz [104] (26.0 dBm) (radar detection)
                        * 5540 MHz [108] (26.0 dBm) (radar detection)
                        * 5560 MHz [112] (26.0 dBm) (radar detection)
                        * 5580 MHz [116] (26.0 dBm) (radar detection)
                        * 5600 MHz [120] (26.0 dBm) (radar detection)
                        * 5620 MHz [124] (26.0 dBm) (radar detection)
                        * 5640 MHz [128] (26.0 dBm) (radar detection)
                        * 5660 MHz [132] (26.0 dBm) (radar detection)
                        * 5680 MHz [136] (26.0 dBm) (radar detection)
                        * 5700 MHz [140] (26.0 dBm) (radar detection)
                        * 5745 MHz [149] (13.0 dBm)
                        * 5765 MHz [153] (13.0 dBm)
                        * 5785 MHz [157] (13.0 dBm)
                        * 5805 MHz [161] (13.0 dBm)
                        * 5825 MHz [165] (13.0 dBm)

It should be 27dBm for channel 100-140 in my country.
And im using channel 100 right now and Tx-Power is only shown at 20dBm at Luci and manually setting it to 26dBm doesn't work either !
Does it work for you guys ?

Well it seems to be a known problem: https://github.com/openwrt/mt76/issues/172


#753

Finally I found a D-Link DIR-860L B1 revision at eBay, it will arrive late this week.

Which version of OpenWRT are you guys recommend for daily usage? BTW, I have a 1Gbps fiber connection, I would like to use this product as main router, and as AP, hope it's strong enough to handle 1Gbps speed.

Is there anything else special that I need to know of the OpenWRT on this router?


#754

At the moment 18.06RC1, there is something wrong with my latest build and I haven't figured out what that is due to time constraints.
With hw flow offload enabled you should be able to hit those fibre speeds. As for the rest it is bog standard OpenWRT stuff. Flash factory image from webinterface or if that does not work from recovery mode, update opkg package lists and install what you want.


#755

With 18.06RC1 i had a problem where i couldn't access the GUI anymore and a few times i couldn't connect via Wifi anymore.
But this might be related to my specific config...

So I reverted back to the latest 17.01-Snapshot build and haven't experienced a problem since than!
Only the max power output for DFS channels are not working but for the moment i can live with that...


#756

@all, there is a new version of mt76. So normally I would compile a new test build but due to a Dutch ISP replacing a modem, and not putting the modem into bridge mode, I don't have access to my build server. Their customer service is first disabling WiFi before they can put the modem into bridge mode and they told me it could take up to an hour. Apparently flipping a software switch is a tough job. Hopefully a new test build soon!


#757

Thats why i always use my own modems and i use the ISP modem only for support requests.
But i heard that some ISPs are forcing the customer to use their hardware... :confused:
I would definitely change my ISP if they wouldn't allow me to control the modem myself!

Anyway i'm looking forward for your new release... Does anyone tried 18.06rc2 yet?


#758

just tried it and seems decent, 5ghz works perfect can reach throughtput of 54MB/sec but 2.4 Ghz is so crapy that is useless, sqm-qos perfect, samba works as it should, i am using transmission and i was happy to find out that it could reach full speed with this build,i think that 2.4Ghz needs a lot of work, its so bad that its useless, throughtput unstable 30-50mbps, at the best ,on 300Mbps connection with 100% signal.


#759

That's quite bad for my setup as i need a decent 2.4GHz connection for my garden. :frowning:
Hopefully they fix 2.4GHz soon...


#760

if your line is <30Mbps i think you will have no problrm, but if you use repeaters or wireless clients AP then its useless


#761

My line is >90mbps :wink:


#762

thrn try to use 5Ghz, it works fine! dont even bothered to enable 2.4Ghz, it will be a dissapointement


#763

The signal range of 5GHz is too weak to reach into my garden... This might be related to the power output bug with DFS (Tx-Power is locked down to 20dBm but 27dBm would be allowed over here).
I'm only able to use 5GHz indoor because of the signal range. I would be happy with ~35mbps at 2.4GHz in my garden.


#764

To be honest i cant see any reason to use openwrt with such bad 2.4Ghz , would be beter to go back to factory firmware and return when 2.4 Ghz will have been fixed. Believe me 2.4 is so bad that even a 801 11g adapter would be beter