Optimized build for the D-Link DIR-860L

Can you please share your 5ghz wifi settings? I can't seem to be able to get it stable...

Good to hear

This has not happened for me but keep in mind I am using a Xiaomi MIR3G. If you have those problems is there something in your kernel/system log?

Does anybody else have 5 GHz issues?

Will do when I get back home. However, haven't changed much except for encryption (WPA2, AES), KRACK countermeasures and SSID.
Have my builds always been troublesome for you 5 GHz wise? A while ago there were some changes to the WiFi interfaces which had problems with wireless confs. Did you try starting from scratch?

Edit, my 5 GHz WiFi conf:

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option htmode 'VHT80'
        option legacy_rates '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid '***SSID***'
        option encryption 'psk2+ccmp'
        option key '***password***'
        option wpa_disable_eapol_key_retries '1'

Thanks, I believe it might be a driver issues since numerous reports are circulating of similar issues, basically something triggers a hardware restart on the 5ghz radio, similar to these:


Then there should be something in your logs. Is this the case?

I'm back to stock at the moment so I can't reproduce exact messages, but from memory the errors were indeed:
XXXX:XX:XX.X: MCU message XX (seq X) timed out leading to a hardware reset, which would cause 5Ghz to drop-out, whilst 2.4 GHz would remain active and alive.

Mon Aug 10 19:32:48 2020 kern.err kernel: [589780.317390] mt76x2e 0000:01:00.0: MCU message 2 (seq 7) timed out
Mon Aug 10 19:32:48 2020 kern.info kernel: [589780.398664] mt76x2e 0000:01:00.0: Firmware Version: 0.0.00
Mon Aug 10 19:32:48 2020 kern.info kernel: [589780.409821] mt76x2e 0000:01:00.0: Build: 1
Mon Aug 10 19:32:48 2020 kern.info kernel: [589780.418195] mt76x2e 0000:01:00.0: Build Time: 201507311614____
Mon Aug 10 19:32:48 2020 kern.info kernel: [589780.447370] mt76x2e 0000:01:00.0: Firmware running!
Mon Aug 10 19:32:48 2020 kern.info kernel: [589780.467376] ieee80211 phy0: Hardware restart was requested

Same error messages on new builds, same happens under dd-wrt as well...

Thank you for your testing. Never run into that issue myself. Can you post your config?

Do other people have the same problem?

Will try to dig up a back-up of the config tomorrow, but to be honest the setup was not anything extraordinary, router was being used as an AP only.

Other people appear to be having the same issue on the same and other devices, so it's likely a driver issue, there is an open issue here:

https://github.com/openwrt/mt76/issues/444

I'm seeing this as well, seems to be happening on the 2,4 GHz radio here. Might do a test with the last mt76 bump in master soon, see if that improves anything.

Here is a build with the mt76 version bump, r15252 to test :slight_smile:

2 Likes

In the meantime I'm also seeing the N radio disappear completely on master with 5.4 - I mentioned this on the kernel 5.10 PR for ramips. Seems to be back to normal now.

Pretty weird stuff.

Indeed pretty weird stuff. Some people have them, some people don't. Maybe different hardware revisions?
Good to see progress on kernel 5.10 though.

Side-note: is anybody interested in testing a 120 MHz overclock if I get that working?

2 Likes

Got 1 GHz working on my MIR3G :slight_smile:
If you want to test it on your DIR860L you can download it here. Before you flash, now that your router might not boot with the overclock so be prepared if stuff goes south. I am not responsible for how you treat your router :wink:

For what it is worth, BogoMIPS went from 583.68 to 663.55 BogoMIPS. A 13,7% increase, not to shabby :slight_smile:

2 Likes

The overclock build booted fine on my DIR860L. I'm not sure how to measure the performance improvement as I'm using it as a dumb ap.

2 Likes

You probably won't notice any difference since you are not running out of cpu clock cycles.
People with high speed connections might eek out 10% more bandwidth compared to previous since NATting taxes the cpu

1 Like

No melted cpu or strangeness AP-wise? :slight_smile:

No issues at all with over 4 days uptime

1 Like

Hello, I am back!
Some tests on this interesting 1 Ghz optimized version:

Performances: the speed increase over vanilla r14548 is +9,6% with iperf3 on LAN connection (comparison between the average of 6 tests on both builds)
Power needs: vanilla build consumes 3W at idle and 5W during iperf3 LAN tests, overclocked optimized build consumes 5W both in idle and stress test. I used a wattmeter on the power socket
Stability: It keeps settings after reboots (this big issue is finally solved), still in testing since I have just installed it.
Great work @Bartvz :+1:

3 Likes

Welcome back :slight_smile:
Thanks for your testing, especially the power consumption part.
Interesting to see that you "only" get a +9,6% performance boost, but we might eek out a bit more performance if we tune the IRQ affinities.

1 Like

I think its interesting we get about 10% speed increases for free. It consumes 5W during stress on both versions.

1 Like