Optimized build for the D-Link DIR-860L

Thanks man !
I'll give it a try right now... fingers crossed

edit: is there really no need to flash via recovery ? Can't be bad right ? :wink:

As long as you use the factory image, and NOT the sysupgrade image, you should be golden. :slight_smile:

1 Like

It worked out great, no problems what so ever !! Thanks for your quick help man !!! :slight_smile:
Now i need to figure out how to get this http to https redirect (i guess it's a package as well) and the material design (im used to it) to work.
After that i'm going to modify my whole setup together with my WRT3200acm...
Hopefully the Dir-860L has about the same Wifi performance as my old RT-N16 with Tomato fw. 'fingers crossed'

install the luci-ssl-openssl package :slight_smile: that's all there is to it.

Should also be a package. I believe @Bartvz has it included in the builds that he posted in his OP. Might want to ask him for the specific name of the package :slight_smile:

1 Like


1 Like

Opend a new thread, sorry for spamming this one here with my problem....

I think that's a good idea :slight_smile: I'll try to help you out in the new thread.

If you make your own build, I have included the config.seed for every build in the download directory which may be a good starting point

Thanks but to be honest i don't feel mighty enough to build my own image, unfortunately.
I was very happy to see that someone allready got a "optimized build" ready to go...
The big and only question for me is if vlan is fully working as i really need it for my setup with the isolated guest AP+switch.

The commit that fixed VLAN functionality is quite old and should be included in Bart's latest builds :slight_smile:

1 Like

Today i was about to configure my 860L as a guest AP but when i tried to enter the GUI i got the following error:

/usr/lib/lua/luci/dispatcher.lua:176: /etc/config/luci seems to be corrupt, unable to find section 'main'
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:176: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:99: in function </usr/lib/lua/luci/dispatcher.lua:98>

It was running for ~3 days, had to reboot to get Luci back.... build 6795.

Reflashed the build and reconfigured everything from the scratch. Vlan's are working for fine but one big problem, I cant install ebtables package via software...

Installing ebtables (2018-05-15-66a97018-1) to root...
Downloading http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/base/ebtables_2018-05-15-66a97018-1_mipsel_24kc.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for ebtables:
 * 	kernel (= 4.14.44-1-cfa316e572ea7fa890feb6abb050c445) * 
 * opkg_install_cmd: Cannot install package ebtables.

The package seems to be for Kernel Version: 4.14.44 and the build which i'm using has Kernel: 4.14.37...
How do i get this fixed ? I do need ebtables for my isolated guest Setup...

edit: It doen't seem to be fixable out of the box.
@Bartvz, do you have a custom package feed for ur build 6795 @ Kernel 4.14.37 ?
Or do you know a source where i can get the needed ebtable package ?

Pls help me :slight_smile:

That is due to a newer kernel in the master branch as compared to my build. You could try force installing it with opkg.

Please note that force installing can possibly brick your router. Be sure you are aware how to use the recovery to unbrick it :wink:

@Kherby the latest 18.06 snapshots now have commits that fix the WiFi issues you experienced earlier. So that might be the better option for you if you don't want to compile your own image.

Im running 17.01.4 stable atm and i was able to install ebtables + vlans are also working.
But my isolated guest setup is still not working as it should.
I might give 18.06 another try, thanks for the info... i dont need much, basicly just vlans, ebtables and decent wifi performance and ofc the build should be stable with daily usage. :wink:

Hmm, that commit or those commits that fix WiFi have passed me by then. The plan was to release a new build when wifi was fixed.

@All, what do you think about me releasing a stable 18.06 build and an experimental master build?

1 Like

+1 pls pls pls :+1:
Could u be so nice and include ebtables (fingers crossed) ?
ebtables + kmod-ebtables + ebtables-utils, its realy not so big in size...

In /etc/sysctl.conf set:


And reload those rules via sysctl -p

Install kmod-br-netfilter to be able to apply netfilter to bridge.

And lastly, set forward to reject for the firewall zone in which the bridge is included. That should give you client isolation without having to use ebtables.

1 Like

18.06-SNAPSHOT r6995 is running quite well here, Wifi performance seems to be way better than with 17.04.1 Stable.
I'm doing some iperf tests later on to check the actual numbers but i think a optimized build@ 18.06 would be very nice !

@Mushoz, my isolated Guest AP setup is finaly working as it should but i got it done via ebtables and vlans.
After the next flash i'll try to set the isolation via sysctl.conf and see how that goes for me...
For now i can finaly enjoy my DIR-860L. :slight_smile:

1 Like

Definitely interested in 18.06!