Optimized build for IPQ40xx devices

Hi @NoTengoBattery, sorry for not answering soon but I reverted this Mikrotik unit to stock RouterOS.

Your builds are really good from the software perspective however having too little RAM on this particular unit made it quite unresponsive serving several wireless devices even after removing Unbound, I saw you implemented automatic ZRAM in your firmware (compressed memory in Luci notation) but latencies suffered a bit under load due to additional CPU cycles being spent on compressing/decompressing memory blocks (I also run SQM CAKE at 100/100mbps :grinning_face_with_smiling_eyes:).

My current setup now consists of the Mikrotik with ROS 7 as main router/gateway doing fq_codel QOS and VLAN tagging (ISP requires VLAN 999 on WAN port when their ONT acts a bridge) and a Netgear R6400v2 with stock FW as dumb AP (which I retired from service years ago because the WAN port started to fail but the switch ports are still good but that's another story :rofl:).

Maybe if someday you can make a Lite version of your FW with just the right amount of additional packages I'll be glad to beta test.

Hello @NoTengoBattery, I am wondering how your build can be customized for port to the following tri-band IPQ4019 devices (with different RAM and flash configuration):

  1. Linksys Velop WHW03 (similar to MR8300)
  2. Mikrotik Audience
  3. Trendnet TEW-829DRU

I have 1 and 3 to test but not 2 (which I'm interested in acquiring). I am looking into these for a future deployment project.

Please pardon my ignorance of OpenWRT build process.


1 Like

Hello @NoTengoBattery

I have a couple of doubts.
i have a linksys mr8300 dallas,
i i have installed rc4 version. How do I enable hardware acceleration for openvpn?

from my router when I consult the public ip fom ssh is the ip of my vpn, how can I make it the ip of my wan?

Thank you

1 Like

@r1m2 Well, as long as those devices are already supported by the "original" OpenWrt it should be more or less easy.

@Gcholvi I am not sure how to answer that. I think there are threads about OpenVPN. Sadly, I don't use OpenVPN yet since my internet service is mediocre and is just not worth. Poor country problems you know?

I would ask that in the "Using OpenWrt" section since this custom build actually uses almost all OpenWrt software from their official builds including OpenVPN.

However, if they say that you have to enable or disable a kernel feature then you'll have to tell me since I would need to rebuild the kernel accordingly.

1 Like

Hi there - i'm seeing an odd issue where I can log into the rooter over SSH but not via the Civic Web interface. I've tried restarting several times without success and also changing the root user passwd (using ssh connection). The log simply reads:

Wed Aug 25 17:09:49 2021 daemon.err uhttpd[3616]: luci: accepted login on / for root from

When I enter a wrong password I get a web page popup indicating wrong password, and the logs reports a failed login too.

Any ideas on how to get around this? Perhaps clear civic caches and restart civic from ssh connection (sorry i don't know how to do that)

Many thanks :slight_smile:

EDIT - ISSUE RESOLVED, it's a browser thing. when I use private browsing I can log in to Civic.

1 Like

Hi @NoTengoBattery, hi all

I'm using the latest build (rc4) on the EA6350v3, but for the life of me I can't get wireless speeds above 400. I tried the open source module + fw as well as the -ct module and fw shipped with your build. Hardly reach 400Mbps with iperf at 50cm distance.

I remember getting very good results after calibrating the board file with your script in one of the older versions, but the calibration script seems gone now. Is there anything I could try?

Thanks very much

I have problem with the speed, i have only 250MB.

where there is a script to calibrate?

I have Mr8300.

Another thing, I have restarted my router and it has lost all the configuration, it is in factory settings, why?



Thank you @NoTengoBattery for the build and all the great work.


1 Like

I think that when I rebuild the repos to make this code less of a mess, I probably decided to remove that thinking that was a feature nobody used.

I will add it back now but please let us know what calibration works for you and what are the results.


When the stable version?


Hello everyone!
Sorry for the long delay, I've been kind of busy lately :slight_smile:

I want to inform you that version 3.0.0 based on the latest stable release is available. For users that requested, I released a "slim" version with no software installed. @geminis3 maybe you can try now.

As always, you can find everything in the post #1

@NPeca75 sorry for the way too late response. I was sure that I answered on time but I didn't :smiley: so the short answer is that those packages come directly from OpenWrt's feeds, therefore, I can't easily provide them in the current configuration.

@kitestramuort the new build does contain the files needed to calibrate wifi. Please report back your findings.

@Gcholvi the files to calibrate that device are currently not available. Those files need to be extracted from the OEM firmware.


Thanks dev. @NoTengoBattery

1 Like

The slim version, do you have hardware acceleration enabled?


Yes. You need to install and configure as it's instructed on the OpenWrt wiki.

I have an ASUS RT-AC58U if you want me to test :slight_smile: I'm really interested in the VLAN fixes actually :smiley:

Yes, I am interested for sure.
Let's talk via PM about it!

Will Zyxel NBG6617 be supported in near future? It's a ipq4018 device...

1 Like

Thank you for publishing this! Are you going to build latest version for mikrotik devices? And the slim version has the same packages as the official builds?

New OpenWRT user here (EA6350v3)--Thanks for building this image, because it solves almost all of the problems with the vanilla OpenWRT incl. latency and 2.4GHz connection speed. Much better than the stock Linksys software in terms of usability as well!

@kastesllsc as long as the normal OpenWrt supports it and you're willing to test and possibly recover from breaking it is fine for me.

@adrez99 I forgot to build it. It only supports one actually. Is that the one that you own? We can try the slim version if so.

Currently I'm kinda busy because I'm moving house and moving job. So is a long run to travel. I am aware of the forum and the pending work. Just a little bit overwhelmed.

1 Like