Optimized build for IPQ40xx devices

Hey, check the thread above. Change the wireless frequency to auto. The problem will be fixed.

I think the default FW probably has a issue of setting the frequency to a wrong data. Should be fixed. @NoTengoBattery

1 Like

What regulatory domain / country did you set radio0 to?

Now,the wireless country is displayed as US. Where to set it up? I don't see there's field to change it.

Signal: 0 dBm | Noise: -106 dBm
Bitrate: 0.0 Mbit/s | Country: US

Where you edit wireless settings in Advanced Settings -> Country Code

It's really bad to use openwrt on linksysea6350v3 with openwrt, very unstable 2.4ghz despite corrections and possible improvements, core saturation problems, I went back to using my xiaomi mi router 4a with padavan, show this linksys with default firmware is the best option. The compiler abandoned us a few months ago.

OK, so why you want to know the country code setup?

Please consider adding kernel support for chacha20poly1305, it is very useful when setting up ipsec tunnel, greatly improving performance over aes algorithm on ipa40xx platform. It has been merged into original openwrt.

Just wanted to check which channels are available in your setup. Your problem looks definitely related to radar detection. Channel 149 works because it doesn't require DFS. What is the output of iw phy phy0 channels?

I changed channel to auto and select my country code, and looks like for me all works correct:

root@Router:~# iw phy phy0 channels
Band 2:
	* 5180 MHz [36] (disabled)
	* 5200 MHz [40] (disabled)
	* 5220 MHz [44] (disabled)
	* 5240 MHz [48] (disabled)
	* 5260 MHz [52] (disabled)
	* 5280 MHz [56] (disabled)
	* 5300 MHz [60] (disabled)
	* 5320 MHz [64] (disabled)
	* 5500 MHz [100] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40+ VHT80
	  DFS state: usable (for 88071 sec)
	  DFS CAC time: 60000 ms
	* 5520 MHz [104] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 88071 sec)
	  DFS CAC time: 60000 ms
	* 5540 MHz [108] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 88071 sec)
	  DFS CAC time: 60000 ms
	* 5560 MHz [112] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 88071 sec)
	  DFS CAC time: 60000 ms
	* 5580 MHz [116] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 88071 sec)
	  DFS CAC time: 60000 ms
	* 5600 MHz [120] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 88071 sec)
	  DFS CAC time: 60000 ms
	* 5620 MHz [124] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 88071 sec)
	  DFS CAC time: 60000 ms
	* 5640 MHz [128] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 88071 sec)
	  DFS CAC time: 60000 ms
	* 5660 MHz [132] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: available (for 87988 sec)
	  DFS CAC time: 60000 ms
	* 5680 MHz [136] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: available (for 87988 sec)
	  DFS CAC time: 60000 ms
	* 5700 MHz [140] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: available (for 87988 sec)
	  DFS CAC time: 60000 ms
	* 5720 MHz [144] 
	  Maximum TX power: 20.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- VHT80
	  DFS state: available (for 87988 sec)
	  DFS CAC time: 60000 ms
	* 5745 MHz [149] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40+ VHT80
	* 5765 MHz [153] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5785 MHz [157] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5805 MHz [161] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5825 MHz [165] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40- VHT80
	* 5845 MHz [169] (disabled)
	* 5865 MHz [173] (disabled)
root@Router:~# 

Does 'country code' matter?

For 5 GHz Different countries have rules vary considerably between regions (some bands only allowed in the USA but not EU, or the other way around).

I check it and the country code is set as 'driver default'.

BTW, what's DFS and what's it used for?

root@JustinOpenWRT:~# iw phy phy0 channels
Band 2:
	* 5180 MHz [36] (disabled)
	* 5200 MHz [40] (disabled)
	* 5220 MHz [44] (disabled)
	* 5240 MHz [48] (disabled)
	* 5260 MHz [52] (disabled)
	* 5280 MHz [56] (disabled)
	* 5300 MHz [60] (disabled)
	* 5320 MHz [64] (disabled)
	* 5500 MHz [100] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40+ VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5520 MHz [104] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5540 MHz [108] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5560 MHz [112] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5580 MHz [116] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5600 MHz [120] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5620 MHz [124] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5640 MHz [128] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5660 MHz [132] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5680 MHz [136] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5700 MHz [140] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- HT40+ VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5720 MHz [144] 
	  Maximum TX power: 23.0 dBm
	  Radar detection
	  Channel widths: 20MHz HT40- VHT80
	  DFS state: usable (for 372088 sec)
	  DFS CAC time: 60000 ms
	* 5745 MHz [149] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40+ VHT80
	* 5765 MHz [153] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5785 MHz [157] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5805 MHz [161] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5825 MHz [165] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- VHT80
	* 5845 MHz [169] (disabled)
	* 5865 MHz [173] (disabled)

Hello all!

I have an EA6350v3 running NoTengoBattery v3.0.1 r16325-88151b8303. Very happy with it.
Apart from LAN and WAN I created two other interfaces, IOT (10.3.0.0/24) and GUEST (10.4.0.0/24) both with dhcp server activated.
I recently noticed the following recurring warning in the System Log:

daemon.warn dnsmasq-dhcp[5302]: no address range available for DHCP request via br-guest

I did some digging and found that dnsmasq is running the conf file at /var/etc/dnsmasq.conf.cfg04411c:

**# auto-generated config file from /etc/config/dhcp**
conf-file=/etc/dnsmasq.conf
dhcp-authoritative
domain-needed
filterwin2k
no-negcache
no-resolv
localise-queries
read-ethers
enable-ubus=dnsmasq
bind-dynamic
local-service
dhcp-sequential-ip
all-servers
domain=lan
local=/lan/
server=127.0.0.1#10053
server=::1#10053
addn-hosts=/tmp/hosts
dhcp-leasefile=/tmp/dhcp.leases
stop-dns-rebind
dhcp-broadcast=tag:needs-broadcast
conf-dir=/tmp/dnsmasq.d
user=dnsmasq
group=dnsmasq

dhcp-host=XX:A6:32:XX:B5:CA,10.1.0.66,ubuntu
dhcp-host=XX:A6:32:XX:B8:28,10.1.0.65,pisense
dhcp-host=XX:89:A5:XX:00:24,10.1.0.20,antec
dhcp-host=XX:DB:84:XX:EC:99,10.1.0.196,SonoffBridge

dhcp-ignore-names=tag:dhcp_bogus_hostname
conf-file=/usr/share/dnsmasq/dhcpbogushostname.conf


bogus-priv
conf-file=/usr/share/dnsmasq/rfc6761.conf
dhcp-range=set:lan,10.1.0.100,10.1.0.219,255.255.255.0,24h
dhcp-option=lan,6,10.1.0.1,10.1.0.242
no-dhcp-interface=eth0.2
dhcp-range=set:iot,10.3.0.12,10.3.0.131,255.255.255.0,12h

the last line only specifies the dhcp range for the IOT subnet, but there is nothing about the GUEST subnet. I cannot find anything wrong in /etc/config/dhcp:

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option ra_management '1'
	option ra_useleasetime '1'
	option dhcpv4_forcereconf '1'
	option force '1'
	list domain 'lan'
	option limit '120'
	option leasetime '24h'
	list dhcp_option '6,10.1.0.1,10.1.0.242'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dnsmasq
	option allservers '1'
	option authoritative '1'
	option dnsseccheckunsigned '0'
	option domain 'lan'
	option domainneeded '1'
	option filterwin2k '1'
	option local '/lan/'
	option localise_queries '1'
	option localservice '1'
	option nonegcache '1'
	option noresolv '1'
	option readethers '1'
	option rebind_protection '1'
	list server '127.0.0.1#10053'
	list server '::1#10053'
	option sequential_ip '1'

config dhcp 'wan6'
	option interface 'wan6'
	option ignore '1'

config dhcp 'iot'
	option interface 'iot'
	option start '12'
	option limit '120'
	option leasetime '12h'

config dhcp 'guest'
	option interface 'guest'
	option start '12'
	option limit '120'
	option leasetime '12h'

config host
	option name 'ubuntu'
	option dns '1'
	option mac 'XX:A6:32:XX:B5:CA'
	option ip '10.1.0.66'

config host
	option name 'pisense'
	option dns '1'
	option mac 'XX:A6:32:XX:B8:28'
	option ip '10.1.0.65'

config host
	option dns '1'
	option mac 'XX:89:A5:XX:00:24'
	option ip '10.1.0.20'
	option name 'antec'

config host
	option name 'SonoffBridge'
	option dns '1'
	option mac 'XX:DB:84:XX:EC:99'
	option ip '10.1.0.196'

As far as I know I set both interfaces the same way. Any idea why dnsmasq is giving the warning for the guest network, and why the dhcp-range is not specified in the auto-generated dnsmasq.conf? Just to clarify, dhcp on the GUEST subnet seems to be working fine, which is even more mind boggling. Thanks for any help.

Managed to find a solution. Nothing to do with OpenWRT, but another device on my network insists on providing dhcp. Solution (found here) is to select Force DHCP on this network even if another server is detected. Thanks.

1 Like

thanks, I'm trying to get this model in a few days. So I might have to check this. Should I stay with the regular openwrt or do you recommend the one from NotengoBattery ?

If you look at the 'known issues' on the EA6350 page on the openwrt website it recommends installing NoTengoBattery's custom firmware, as it fixes VLAN and 2.4 GHz wireless on the device. IPQ40xx based devices have some quirks which need to be remedied. I find NoTengoBattery's firmware to be very stable. In my case VLAN support was a must, so I didn't even try the official version. However, if you still didn't get the device yet, you might consider getting a different model which has more support.

I see, already got the router because was very cheap $20 I want to use it for homelab or testing. I'm still deciding what router for home use. I appreciate your response.

The thread is quiet! Hope NoTengoBattery and everyone else is ok!

1 Like

Hello all,

I have two questions. I'm using the EA6350 with NoTengoBattery v3.0.1 r16325-88151b8303 firmware.

  1. Does anyone know if I can update some of the files from the regular updates without getting issues? I tried just to update something like unbound or adblock but they broke after, so my fix is to restore to defaul state.

  2. Anyone can let me know how i can turn off the unbound, adblock, so I can use a Raspberry Pi so I can add adguard/pihole for the unbound/dns/ and enforce dns through the pi? I tried to do it manually like changing some dns forwarding and dhcp advanced options to point the raspberry but it doesn't work at all. I was thinking in just leaving alone this router with this os version.

thank you

I am new to this, but I'd like to get the firmware on my WR9000 replaced to utilize its full potential. Few questions. In the downloads above, you indicate that we should download the file for our device. Which file is the correct file to download for the WR9000? Should we be trying to download more than 1 file? Are there any instructions that can guide me through the process of flashing the router?