Opkg upgrade error - Read-only file system


I tried to upgrade package, but it always show Read-only file system error,
does anyone know why it is?

Executing package manager
Upgrading base-files on root from 1403-r15696-17fa01bb79 to 1403-r15756-da283a8f2c...
Downloading https://mirror.0x.sg/openwrt/snapshots/targets/ramips/mt7621/packages/base-files_1403-r15756-da283a8f2c_mipsel_24kc.ipk

Command failed: Not found
Command failed: Not found
umount: devpts busy - remounted read-only
umount: tmpfs busy - remounted read-only
umount: can't remount tmpfs read-only
umount: proc busy - remounted read-only
Collected errors:
 * copy_file: unable to open `/etc/group-opkg.backup': Read-only file system.
 * file_copy: Failed to copy file /etc/group to /etc/group-opkg.backup.
 * backup_make_backup: Failed to copy /etc/group to /etc/group-opkg.backup
 * opkg_install_cmd: Cannot install package base-files.
 * pkg_write_filelist: Failed to open //usr/lib/opkg/info/base-files.list: Read-only file system.
1 Like

Post the output:

ubus call system board; uptime; free; df -h; mount
        "kernel": "5.4.95",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "Xiaomi Redmi Router AC2100",
        "board_name": "xiaomi,redmi-router-ac2100",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r15696-17fa01bb79",
                "target": "ramips/mt7621",
                "description": "OpenWrt SNAPSHOT r15696-17fa01bb79"
 12:58:13 up 5 days, 11:44,  load average: 0.05, 0.06, 0.01
              total        used        free      shared  buff/cache   available
Mem:         121724       36028       67768        1364       17928       53180
Swap:             0           0           0
Filesystem                Size      Used Available Use% Mounted on
tmpfs                    59.4M      1.3M     58.1M   2% /tmp
overlayfs:/overlay       97.7M      5.3M     87.7M   6% /
tmpfs                   512.0K         0    512.0K   0% /dev
proc on /proc type proc (ro,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
overlayfs:/overlay on / type overlay (ro,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
tmpfs on /dev type tmpfs (ro,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (ro,relatime,mode=600,ptmxmode=000)
1 Like

OK, so normally not recommend to upgrade router's packages.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.