Opkg update failed, I need help (19.07, wget returned 4)

The output says that you need to check your network settings and connectivity... that is at the root of the issue. However, a few more things to know:

  • 19.07 is EOL and unsupported. It is best to upgrade to a current version if you can.
  • Even if you want to continue with 19.07, you will quickly run into another issue because you're on a snapshot -- you'll most likely encounter this:
    • When you get the message “Cannot satisfy the following dependencies for…” it is most likely because you installed a snapshot version of OpenWrt.
      Read here for possible solutions.

What device are you using? What is the output of:

ubus call system board
1 Like

One possible reason is that the end-of-life deprecated 19.07 downloads have been moved to "archive.openwrt.org"

You might need to fix the links in /etc/opkg/distfeeds.conf file

2 Likes