Opkg update download failed

I am trying to install OpenWRT on a NetGear R6020 and have flashed the firmware with the provided package. However, the opkg update command gives an error:

BusyBox v1.31.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt SNAPSHOT, r14926-41b867165d
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
root@OpenWrt:~# opkg update
Downloading https://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_core
Downloading https://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/packages/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/kmods/5.4.75-1-ee273df392101422eaeb0bb949b9db8e/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/kmods/5.4.75-1-ee273df392101422eaeb0bb949b9db8e/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/freifunk/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_freifunk
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/freifunk/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/packages/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/routing/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephony/Packages.sig
Signature check passed.
Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/kmods/5.4.75-1-ee273df392101422eaeb0bb949b9db8e/Packages.gz, wget returned 8.

I read in another post to just wait?
Since I am using a NetGear R6020, I can only use the image option.

Thanks for any help!

My hunch is that you need to reflash the router with a newer firmware (today's build).

There was a bug that prevented uploading of the kmod packages between Nov 7 and 13, and you are now running a build from 13th.

Note that the error only concerned kmod packages. You can install other normal packages.


How do I do that?
Is there a manual for flashing a new .img when openWRT is already installed?

Download the sysupgrade image and flash it with the sysupgrade command. Any additional packages will also need to be reinstalled.

Since the image server requires https, that generally means download the image to your PC first then scp it to the router's /tmp directory.

1 Like

Thanks for the reply!
It would have worked, was it not that I destroyed the upgrade for being impatient. It took a while so I did a power recycle which corrupted the upgrade. However the Nighthawk has a nice feature, when the firmware crashes you can still write new firmware with TFPT. After that I had no problems with the new firmware - as hnyman suggested.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Hey guys.

Same issue here. The opkg update fails with 'random' packages. Meaning, it fails with the routing pkg. then i run it again, it fails with the luci pkg. It keeps failiing for one or maybe 2 packages at a time.

I already installed the factory.bin, then i installed luci, then sysupgrade through luci, then ssh and install luci again won't work. Now I scp'd the firmware and tried the opkg update but it keeps failing.

I am trying to do this on a DIR-842 C1 with an ISP provided router (PPPOE, gigabit fiber) connected to the WAN port of the Dlink.

> I have 46% packet loss when ping / UPDATE: It was a momentary issue

Could you please help me figure out the issue here?

Sounds quite different to me. If you have major connectivity problems (46% ping loss), opkg will naturally fail.

Please do not hijack threads.

1 Like

Thanks comrade :slight_smile: great advice. Although we don't know the op's ping results, but my cmd line looks the same as his. I added the ping result after the original comment.

I was not even trying to 'hijack' - LOL - any threads. I was happy to find a post similar to mine which is unresolved since 2020. I hope you allow me to comment on it,

UPDATE: The 46% packet loss was a temporary issue. Constant 0 loss ever since.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.