Opkg unable to pull from downloads.openwrt.org

I've had this issue intermittently over the years but it does not appear to be transient this time.
All downloads from downloads.openwrt.org fail but not from Github.

# opkg update
Downloading https://raw.githubusercontent.com/stangri/openwrt-repo/master/Packages.gz
Updated list of available packages in /var/opkg-lists/stangri_repo
Downloading https://raw.githubusercontent.com/stangri/openwrt-repo/master/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/18.06.5/targets/x86/64/packages/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/18.06.5/targets/x86/64/packages/Packages.gz

Downloading https://downloads.openwrt.org/releases/18.06.5/packages/x86_64/base/Packages.gz

Tried testing with curl and I get:

# curl -k -vv https://downloads.openwrt.org/releases/18.06.5/targets/x86/64/packages/Packages.gz
* ssl_handshake returned - mbedTLS: (-0x0050) NET - Connection was reset by peer
curl: (35) ssl_handshake returned - mbedTLS: (-0x0050) NET - Connection was reset by peer

The thing that confounds me is that a browser behind the same openwrt router can download the packages fine. What am I missing here?

Without digging to deep into it, it might be outdated certs used by curl.

Half way down https://dev.archive.openwrt.org/ticket/19621

1 Like

opkg isn't using curl tho is it?


Didn't see those were two separate quotes :confused:

You sure it's not a space issue ?

You have configured Opkg to use repo URLs with HTTPS, so it still relies on CA certs.

With 28.7 GB free, it's not a space issue.

ca-certificates is installed.

sed -i -r -e "s|(\shttp)s(://\w+.openwrt.org/)|\1\2|" /etc/opkg/*.conf
opkg update

I had tried http too, with no change.
I gave up and decided this was a good excuse to upgrade the device to 19.x

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.